• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 309
  • Last Modified:

Intermittent asp navbar rendering issues

I am operating a website that I created in Visual Studio Web Developer 2010 and am running into rendering issues with the menu component I use for the site navigation. The problem seems to be intermittent and can generally be resolved by refreshing  the page. See attached screenshots. Does anyone have any idea what could be causing this and if so, how to resolve it?
8-28-2012-2-58-47-PM.jpg
8-28-2012-2-59-12-PM.jpg
0
dlacoste81
Asked:
dlacoste81
  • 6
  • 5
1 Solution
 
Roopesh ReddyIT AnalystCommented:
Hi,

May be due to browser cache!

Try clearing the browser cache and try again!

Hope it helps u...
0
 
dlacoste81Author Commented:
Browser cache doesn't seem to be the issue, the problem occurs across various platforms and multiple visitors have reported the issue. At first I thought it may be an issue with the GoDaddy hosting but recycling IIS didn't resolve it so I strongly suspect that the problem lies within my code though I don't see anything that would cause it to behave this way.

Here's the XHTML:

<div id="navbar" class="span-24 last">
<asp:Menu ID="Menu1" StaticDisplayLevels="2" DynamicHorizontalOffset="0" DynamicVerticalOffset="0" runat="server" Orientation="Horizontal" StaticPopOutImageUrl="/images/drop_down_arrow.png" DataSourceID="SiteMapDataSource1" />
<asp:SiteMapDataSource ID="SiteMapDataSource1" runat="server" />
</div>

Open in new window


And here are the styles:

#navbar {
	height: 44px;
	background: #091D42 url(../images/nav_bg.png) repeat-x;
	}
	
#navbar ul {
	padding-top: 10px !important;
	padding-left: 0 !important;
	}

#navbar a {
	margin-right: 10px;
	}
	
#navbar a:hover {
	color: #444;
	}
	
.level2 {
	font-size: 14px;
	font-weight: bold;
	color: #898989;
	}
	
.level3, .level4, .level5{
	font-size: 14px;
	color: #898989;
	background-color: #FDFDFD;
	border: 1px solid #898989;
	}

.level3 li, .level4 li, .level5 li{
	border-top: 1px solid #FDFDFD;
	border-bottom: 1px dotted #898989;
	margin-left: 10px;
	}

.level3 ul, .level4 ul, .level5 ul {
	padding: 0;
	}

.level3 li:last-child, .level4 li:last-child, .level5 li:last-child{
	border: none;
	}
	
.level3 a, .level4 a, .level5 a{
	border: none!important;
	margin: 0;
	}

Open in new window

0
 
Roopesh ReddyIT AnalystCommented:
Hi,

I didn't see any issues with your Style sheet and the code!

Ah, You have used class="span-24 last", and you didn't provide the styles you have used!

May be that causing the issue!

Hope it helps u...
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
dlacoste81Author Commented:
Here are the missing styles:

.span-24 {width:950px;margin-right:0;}
.last {margin-right:0;padding-right:0;}

Open in new window

0
 
Roopesh ReddyIT AnalystCommented:
Hi,

Oh k! It also looks fine!

If it's not Cache issue, then some thing is causing the issue!

You can try using CSS Reset - http://developer.yahoo.com/yui/reset/

Hope it helps u...
0
 
dlacoste81Author Commented:
Already done that, using the Blueprint CSS:

html {margin:0;padding:0;border:0;}
body, div, span, object, iframe, h1, h2, h3, h4, h5, h6, p, blockquote, pre, a, abbr, acronym, address, code, del, dfn, em, img, q, dl, dt, dd, ol, ul, li, fieldset, form, label, legend, table, caption, tbody, tfoot, thead, tr, th, td, article, aside, dialog, figure, footer, header, hgroup, nav, section {margin:0;padding:0;border:0;font-size:100%;font:inherit;vertical-align:baseline;}
article, aside, details, figcaption, figure, dialog, footer, header, hgroup, menu, nav, section {display:block;}
body {line-height:1.5;background:white;}
table {border-collapse:separate;border-spacing:0;}
caption, th, td {text-align:left;font-weight:normal;float:none !important;}
table, th, td {vertical-align:middle;}
blockquote:before, blockquote:after, q:before, q:after {content:'';}
blockquote, q {quotes:"" "";}
a img {border:none;}
:focus {outline:0;}

Open in new window

0
 
Roopesh ReddyIT AnalystCommented:
Hi,

Looks like weird issue!

As far my knowledge it should be cache!

Also try in different browser to simulate this issue! some times it also depends on the browser too!

Hope it helps u...
0
 
dlacoste81Author Commented:
I'm starting to wonder if it's a GoDaddy related issue as it doesn't happen on the local test server.
0
 
Roopesh ReddyIT AnalystCommented:
Hi,

May be! Check with them once!

Hope it helps u...
0
 
dlacoste81Author Commented:
I know it's been a while since I asked this question but I just thought I'd provide the solution in case anyone else is running into similar issues. After weeks of trying different things I finally came across some postings on the GoDaddy help forums that explained that .asp websites hosted on their shared servers occasionally have performance issues which caused the intermittent page render delays. I ended up switching to a Windows Azure shared webserver instance and haven't encountered any rendering issues since.
0
 
dlacoste81Author Commented:
Issue resolved
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

  • 6
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now