Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 540
  • Last Modified:


Today I updated Firefox from 12.? to the latest 15.0 and now Facebook won't load...
first it puts up headings without the graphics -- just text -- and then almost
immediately if flashes to a black screen.  See attached screen shot   .
Chrome brings Facebook up just fine.  There is something about the new Firefox that Facebook doesn't like.  

I have also found several PDF links that loaded fine under the old version of
Firefox but now come up with "file not found...."  yet pasting those same links
into Chrome works. See attached screen shot.

Any ideas how to "fix" Firefox?

I'm running a PC with Windows XP (latest update)
  • 9
  • 8
  • 6
1 Solution
Dave BaldwinFixer of ProblemsCommented:
I just did the update to Firefox 15 on Windows XP SP3 and Facebook is working fine.  You may have to re-install Firefox or create a new profile.
carolinadonAuthor Commented:
First I did a cold boot.  Then I uninstalled Firefox 15 via Control Panel; using Chrome went to website and downloaded new install.  Ran the install.  Same results with Facebook... except it hangs on the "text" version long enough to snap a screen shot (attached).

And it still won't bring up the pdf urls.

By "create a new profile" do you mean on Facebook?  If so I haven't a clue how...
I set it up years ago so I could look at others.   Besides, what would a Facebook
profile have to do with loading pdfs from a county govt. site?

If you mean a new profile on Firefox, I don't think I've ever done that.

This is why I never, never should update anything that is working.... "security
issues be damned"...  I think 30% of the time when I do an update something
fails and it takes days and days to get it working again... if ever.  :(
Dave BaldwinFixer of ProblemsCommented:
Well, so far, I have not had problems with Firefox updates since version 2.  Here's info on resetting Firefox and/or creating a new profile:  http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
[Webinar On Demand] Database Backup and Recovery

Does your company store data on premises, off site, in the cloud, or a combination of these? If you answered “yes”, you need a data backup recovery plan that fits each and every platform. Watch now as as Percona teaches us how to build agile data backup recovery plan.

carolinadonAuthor Commented:
I think my time would be better spent learning to use Chrome.  There is only one Firefox feature I like that I can't find in Chrome,
perhaps you or someone can tell me if I'm overlooking it or if it is indeed lacking.

In Firefox you can organize bookmarks in a tree and when you
open the top level it opens all the bookmarks below; a very
nice feature.  I know you can organize Chrome bookmarks in
folders but how do you have it open all with one click?

Another Chrome question: It wants me to "login" so, I'm sure, it can
tie me into other Google services, email, plus, etc.  I don't want to be linked to any
services.  Am I going to pay a price for using Chrome as a stand-alone browser?

As to Firefox, I suspect there is some plug-in that was part of version 12 that
got left out or changed in 15... but why it works for you and does
not for me is a mystery... unless you did not jump from 12 to 15 as I did,
but made version-by-version updates.
Dave BaldwinFixer of ProblemsCommented:
I've updated version by version since 2.0.  I have all the browsers that run on my machine which includes Firefox, Chrome, Safari, Opera, and IE8.  Note that Chrome will automatically update in the background even more silently than Firefox.  I don't believe it will give you a choice.
Marc ZCommented:
Carolinadan, you do not have to log in to chrome if you do not want to.
But for firefox, try going to the Help-Restart with Add-ons Disabled. And try facebook again. If it works, we can create a new firefox profile very easily.
carolinadonAuthor Commented:
I loaded Firefox in Safe mode. It brought up Facebook correctly.

Then I tried the pdfs that it could not find.  It still did not find them.
It will find and load some pdfs, but fails on others from the same
site.  Just to be sure I went to Chrome and loaded the pdfs, then I copied the
url to Safe mode Firefox...  same thing... it did not find them.

Is the faulty profile also messing up the urls?

Do you know if Chrome has the ability to load multiple urls with one click?
Marc ZCommented:
The faulty profile is messing up Facebook.  We won't know if the faulty profile is messing up the Links to Pdfs until you create a new profile. it's actually quite easy. and you shouldn't delete the old profile.
As DaveBaldwin pointed you to the Mozilla profile page, check it out in Chrome and follow along to create a new profile. One suggestion I would make, before committing (using it full time) to new profile is to uncheck the "Don't Ask at Startup" option.  This will give you the Selection to open either profile until you get all your existing bookmarks and passwords copied over to new profile.  Once you have everything in place, you can then delete or simply recheck that option and the old profile shouldn't get in your way any more.

I don't believe Chrome has the ability to load multiple urls with ONE click, however you can definitely, right click a bookmark Folder and select Open ALL Bookmarks, or Open all Bookmarks in New Window, or Open All bookmarks in Incognito Window.
Although I just tested, if you hit Ctrl and a Bookmark Folder, it will open all those bookmarks in new Tabs.
Marc ZCommented:
Here is a page for the Windows Chrome keyboard shortcuts.
carolinadonAuthor Commented:
ok. I changed default to olddefault and created a new profile.
That brings up Facebook and it loads the pdfs that the old one
would not...


the new profile knows none of my 100s of passwords
or book marks, including Experts Exchange.  To get to this I
had to use the olddefault profile.

Please don't tell me I have to move all the old stuff one-by-one
to the now default profile or try to remember them  :((

And I realized that I did make one change to the default profile
(now the olddefault) that I would like to make to the new IF I
decide it's worth all the trouble to use Firefox.  That is a setting
that prevents it from showing my url history when I start to type
a url.  I seem to remember changing a "1" to a "0" on some
line in the profile -- perhaps now there is a better way to kill this
unwanted feature.
Marc ZCommented:
Moving your passwords and bookmarks is very easy. No you don't have to move them one-by-one.
However, ONE of the Keys to successfully moving these items is to not be running Firefox when moving the items.  Firefox MUST be closed when copying files from one profile to another.  If you want to do it manually, you can follow the instructions here.   Paying attention to what you really want to move.
My suggestion would be to open Chrome to follow the above directions.

Or now that I've had time to look at the mozilla site, I see they have created a Reset Firefox which will basically do for you what you have just done, EXCEPT it actually migrates your Bookmarks, Passwords, History, Cookies, and Web Form Fill information.
See here for more info on what it DOES not carry over.  I've been using firefox for years, and I have found that the info on those pages is good.  As long as you read it.
Open your Troubled Profile and follow the directions on that page.
Basically Help->Troubleshooting Information->Reset Firefox.

Once you have your profile fixed up, you can modify the History in the Address Bar by going to Tools->Options->Location Bar and change what it suggests to you, such as "Nothing".
If you have questions, c'mon back.

Hope this helps.
carolinadonAuthor Commented:

The Reset using the old profile worked so far.

However I can't find: Tools->Options->Location Bar and change what it suggests to you, such as "Nothing".

Tools>Options>  is easy... but I see nothing called Location Bar in any of the Option
Tabs across the top or within those tabs. And the "History" tab at the top
of the window is grayed out.
Marc ZCommented:
Tools->Options->Privacy->Location Bar
Screenshot of LocationBar Options
If you are not seeing this same under your Options, please confirm you do have Firefox 15.0.
carolinadonAuthor Commented:
It's a curse to be blind.

Thank you. Thank you. Thank you.
Marc ZCommented:
Thanks carolinadan, glad to help.

I wouldn't be opposed to splitting points with DaveBaldwin, as he is the one that gave you the fastest, first correct response.  I just clarified a few things.

Either way, I'm glad your working again.
Dave BaldwinFixer of ProblemsCommented:
That's fine, I don't need the points.  You did a lot more work on this than I did.
carolinadonAuthor Commented:
As long as you are still fresh on this...  why am I still getting notification
from Moz. saying version 15 is available and I need to
download it.  I read online that people keep getting this notification
weeks after they have updated.  And that updating again does not
seem to stop it.   Is there a way to stop it?

Fine with me however you work out the points...  mtz spent
a lot of time holding my hand.
Marc ZCommented:
See this page for that issue.
if that doesn't help, I have another suggestion.
Marc ZCommented:
and if that doesn't help, perhaps a screenshot might help me. But I've found if you download the full install from
After downloading,  you Uninstall Firefox, you will not lose your profile, if during the uninstall you tell it not to delete your stuff, reboot then reinstall the full download.
That used to fix my issue a few years ago.
carolinadonAuthor Commented:
It's definitely not the two reasons mentioned in the first link...
1) not saved as the homepage
2) it pops up every x hours, not when I start Firefox.  

Also, I first uninstalled the old Firefox before I went to Mozilla and
downloaded the new 15.0 to install.  So I should have a clean copy.

I do not usually re-start the browser but leave it running for days at a time.
In the past there were 2 copies of this message on the screen each
morning --  but at that time I WAS running 12.  So far I've only see it
once since I updated, so tomorrow I'll see what it does overnight.
Dave BaldwinFixer of ProblemsCommented:
For what it's worth, I never leave a computer running overnight.  Firefox has been notorious for memory leaks and using up all available memory in some versions.  I have 'cured' a number of problems for clients by having them turn their computers off at the end of the day.  Also, I have them turn off 'sleep' and 'hibernate' because those functions tend to corrupt files on a number of systems.
carolinadonAuthor Commented:
I have always left them running 24/7, 365.  When we have instant boot
I'll turn them off.   I do have every sleep and hibernate option I can find turned off.
But I'm really glad to know about Firefox leaking memory because I do
see the results of that...  just didn't know what was causing it.  When I come
down in the morning the screen is really sluggish... especially the browser.
It takes 20 or 30 seconds for Foxfire to come up to speed.  And, like you say,
if I close FF at night and start in the morning I don't have that problem.
Contributing to that I usually have 6 to 8 tabs open in at least one window.
After 20 or 30 days I have to re-boot --  it's like having a new computer for a
few days until memory starts slipping away.

So far this morning I do not have any "Update Reminders" so perhaps the one
yesterday afternoon was a fluke.
Dave BaldwinFixer of ProblemsCommented:
Then maybe you should plan a reboot once a week since you know you'll have to do it eventually.  I'd recommend once a day, I'm sure there is a period each day where you know you're not going to be using it.

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 9
  • 8
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now