Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2858
  • Last Modified:

FATAL: Connection Failed :'Too many connections' (Spine thread)

Hi Guys

Recently I keep getting this from cacti log:

08/29/2012 10:51:01 AM - PHPSVR: Poller[0] WARNING: Script Server terminated with signal '15' in file:'', function:'', params:''
08/29/2012 10:55:04 AM - SPINE: Poller[0] FATAL: Connection Failed, Error:'1040', Message:'Too many connections' (Spine thread)
08/29/2012 10:55:04 AM - PHPSVR: Poller[0] ERROR: Input Expected, Script Server Terminating
08/29/2012 10:55:04 AM - PHPSVR: Poller[0] ERROR: Input Expected, Script Server Terminating
08/29/2012 10:55:04 AM - PHPSVR: Poller[0] ERROR: Input Expected, Script Server Terminating
08/29/2012 10:55:04 AM - PHPSVR: Poller[0] ERROR: Input Expected, Script Server Terminating
08/29/2012 10:55:04 AM - PHPSVR: Poller[0] ERROR: Input Expected, Script Server Terminating

I did search online, many links saying to increase defalut_connection to 500 in my.cnf

however, in my.cnf i didnt find the option "default_connection". Should I add it?

thanks for your help.
0
mxgong
Asked:
mxgong
  • 2
1 Solution
 
DcpKingCommented:
Yes. It defaults to either 100 or 150, depending on your version of PHP (I believe). set it to 200 and see how you go. For more info see here:

http://dev.mysql.com/doc//refman/5.5/en/too-many-connections.html

hth

Mike
0
 
mxgongAuthor Commented:
fixed
0
 
mxgongAuthor Commented:
thanks
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now