• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 441
  • Last Modified:

Slow share access when using host name

Hi,

Opening documents or photos located on our file server when using hoste name (\\host_name\share_name) takes a considerable amount of time. When I do the same using IP address of the host (\\xxx.xxx.xxx.xxx\share_name) it's instantaneous.
The issue started occurring few weeks ago. Nothing has been modified on the server as far as I know that could cause the issue.
The server is Windows Server 2008 Standard 32bit, a guest machine on an EXS server. It's beeing accessed by Windows 7 clients.
The DNS information for the server seems to be correct.
I would be very grateful for some hints on how to resolve the problem.

ZK
0
kiilaa
Asked:
kiilaa
  • 10
  • 4
  • 2
  • +1
1 Solution
 
DJ2liveUKCommented:
have you tried a dns flush of the cache?

ipconfig/ flushdns
0
 
kiilaaAuthor Commented:
on the client, you mean? yes, I've just tried it. no luck.
0
 
SteveIT ManagerCommented:
check your event logs for any DNS related issues

Due to IP working and name not working it definitely sounds like DNS related issue.

is it the same for all client machines or just one ?

does the problem still occur when you logon as a different user ?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
kiilaaAuthor Commented:
ok, I'll check the event viewer.

It is the same for all clients.

Issue persists when logged on as a different user.

thanks
0
 
Adam AndersonCommented:
check you dns and wins settings on the file server and on the client you are trying to access from

next on the client start run cmd.exe
enter nslookup SERVERNAME

type exit to exit.

next type ipconfig /flushdns on client.

this should give you a good idea where your problem lays.
0
 
kiilaaAuthor Commented:
nslookup points to the correct DNS server and resolves the name correctly. As before flushing DNS cache didn't help.
0
 
kiilaaAuthor Commented:
DNS and WINS settings match.
0
 
Adam AndersonCommented:
how many dns servers do you have ??
0
 
kiilaaAuthor Commented:
There are two different servers. One locally, another one in a remote office.
0
 
Adam AndersonCommented:
so youre client is looking at local dns server, the dns request could be forwarding to the remote dns server. hence the slow response.
0
 
kiilaaAuthor Commented:
Are you suggesting incorrect configuration of the local DNS server?
0
 
Adam AndersonCommented:
Yes sounds like it..
0
 
kiilaaAuthor Commented:
haw can I check that's really what's happening?
0
 
SteveIT ManagerCommented:
remove the remote DNS from the configuration as a test
0
 
kiilaaAuthor Commented:
Hi, sorry about the delay. Removing the remote DNS hasn't worked unfortunately.
0
 
kiilaaAuthor Commented:
Finally I managed to sort the issue out. Disabling SMB2 on the server did the trick.
Thanks for all the contributions.
0
 
kiilaaAuthor Commented:
None of the experts' suggestions solved the problem.
0

Featured Post

Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

  • 10
  • 4
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now