Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Exchange 2010 not receiving email (port 25 blocked)

Posted on 2012-08-29
16
Medium Priority
?
968 Views
Last Modified: 2012-08-29
Dear Experts

I have been trying unsuccessfully for days to try and resolve as to why I cannot get port 25 open on my network and therefore exchange working.

I have ports 80 and 443 open on the firewall and can externally telenet fine to these ports so I know the firewall on the router is configured correctly to open ports.

I have disabled windows firewall and disabled AVG antivirus and still cannot connect to port 25.

The MX records are configured correctly.

I have run the internet address management wizard on SBS 2011 which completed successfully.

The domain name is broomlands.com

Can anyone suggest as to why I cannot seem to get port 25 unblocked.

Many thanks for any help

GRant
0
Comment
Question by:grantballantyne
  • 6
  • 5
  • 3
  • +1
16 Comments
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 38346768
Is the port not opening on firewall ?
Can you telnet to port 25 from Internal or External to MX ?
Can you telnet to port 25 from Internal to Exchange HUB ?
What is MX pointing to Firewall or Exchange ?

- Rancy
0
 
LVL 13

Expert Comment

by:xDUCKx
ID: 38346785
Internet Email -> Inbound Test

https://www.testexchangeconnectivity.com/

Should tell you what's going on.  

You can also try to telnet from outside to port 25 and manually send an email:

http://www.rdpslides.com/webresources/FAQ00035_Send_Email_via_Telnet.htm
0
 
LVL 13

Expert Comment

by:xDUCKx
ID: 38346796
In very very rare cases the ISP could be blocking port 25.  if this has never worked and is the first time you are setting things up you can try asking them.  If it has worked and it's something new that you're troubleshooting, verify that the SMTP service is running on the Exchange server.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
LVL 60

Expert Comment

by:Cliff Galiher
ID: 38346808
As Rancy says, the first place I'd start is trying to telnet to poet 25 on your server from an INTERNAL machine. It may not be your server or the router. Many ISPs block port 25 on their end with non-commercial accounts. And if that is the case, you will have to talk to your ISP and possibly pay to upgrade.
0
 

Author Comment

by:grantballantyne
ID: 38346815
Rancy

I cannot even telenet to port 25 on the exchange server internally - connection refused.
0
 
LVL 60

Expert Comment

by:Cliff Galiher
ID: 38346852
Okay. View the services control panel. Make sure all services are in a "started" state.

Also, run the "fix my network wizard" to repair problems with the receive connector.

Do you have 2 NICs?

Did you make any changes to the exchange connectors...perhaps for a network acanner/fax for relaying?

These are the common reasons why exchange would refuse port 25.
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 38346855
So you arent able to telnet to HUB server ?
Is HUB role installed on the server ?
Is all Microsoft services running ?

- Rancy
0
 

Author Comment

by:grantballantyne
ID: 38347048
Thanks Rancy

Not all services running - which ones do I need to make sure are running?

I ran Fix my network and the only potential network issue that was not resolved was 'Exchange SMTP connectors are invalid'

The details say to ensure that Exchange is running and then try again.

Exchange services are definately running........?
0
 
LVL 60

Expert Comment

by:Cliff Galiher
ID: 38347058
Your first sentence says "not all services running" and then later you say they are "definitely" running.

Which is it?
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 38347070
which ones do I need to make sure are running - Transport and also hope SMTP isnt installed on the server ?
All services in Automatic should be running or else please share a screenshot of the services console :)

Is there any other 3rd party that could be using the port 25 .... ??
How many NIC's on the server ... can you do a nslookup from the Exchange server ?

Run EXBPA from the toolbox :)

- Rancy
0
 

Author Comment

by:grantballantyne
ID: 38347135
Only automatic services not runiing are:

Microsoft Exchange Transport and shell Hardware Detection.

I have manually started the Transport Service which starts OK but when I check later it is not running?

No third party using port 25.

Only one NIC on the server.

See the attached for results of nslookup on the server


Thanks

Grant
nslookup.docx
0
 
LVL 52

Accepted Solution

by:
Manpreet SIngh Khatra earned 2000 total points
ID: 38347152
Microsoft Exchange Transport starts and fails\crashes :(
What event ID do you see in App logs ?
If Transport service isnt running or stops email flow or telnet wont work .... simple

- Rancy
0
 

Author Comment

by:grantballantyne
ID: 38347199
Rancy

I changed the logon on the transport service to 'local logon' and the service is no longer stopping.

Also noe able to telenet internally and passed the Rempote Connectivity Analyzer.


Many many many thanks.....................hopefully mail will start to flow.............................................................infact messages are starting to come in now.

Thanks
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 38347215
Awesome ... me very happy to be able to assist much faster over kind of email process at EE :) .... hope you can have some refreshments.

- Rancy
0
 

Author Comment

by:grantballantyne
ID: 38347257
Thanks Rancy..........................definately will be having a beer now......................would gladly get one in for you also if I could!!

Thanks again
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 38347264
You can have mine too and just think i'm there :)
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Mailbox Corruption is a nightmare every Exchange DBA wishes he never has. Recovering from it can be super-hectic if not entirely futile. And though techniques like the New-MailboxRepairRequest cmdlet have been designed to help with fixing minor corr…
In this article, I will demonstrate that how to do a PST migration from Exchange Server to Office 365. This method allows importing one single PST, or multiple PST's at once.
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
Whether it be Exchange Server Crash Issues, Dirty Shutdown Errors or Failed to mount error, Stellar Phoenix Mailbox Exchange Recovery has always got your back. With the help of its easy to understand user interface and 3 simple steps recovery proced…
Suggested Courses
Course of the Month15 days, 9 hours left to enroll

575 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question