Folder Redirection for Application Data doesn't seem to be working

Posted on 2012-08-29
Last Modified: 2012-09-05
I had setup Folder Redirection many years ago when I was still using a Windows 2003 Active Directory Server. About a year ago we migrated our domain to a new Active Directorty 2008 Server.
I am still using 2003 Server for Terminal Server. I noticed that although the Desktop and Documents are still being redirected, the Application Data seemed to have stopped. I also noticed in the GP that it is now called AppData(Roaming) probably changing with 2008 and Windows 7. Is this the cause of it. Do I need to load a different ADM to set for 2003 Server.

Another question related to this in a way.
I also have the documents redirected. The folder being redirected to is "My Documents" as you can see from the attached jpg called oldgp. I wanted to keep some directories different for 2008 terminal server so I created a new GP with folder redirection and when I go to documents on this one it defaults to "Documents" as you can see from attached JPG called newgp. This can be an issue because now the user will have 2 separate document folders depending on which OS Server he logs on to. I guess this also has to do with the update to 2008 and I am willing to bet that if I disable this on the old GP and then re-enable it will switch to "Documents".
Is there a way to have a 2003 ADM and 2008 ADM on the same Domain GP
Question by:swenger7
    LVL 77

    Expert Comment

    by:David Johnson, CD, MVP
    Windows XP only had one application data area.
    Win Vista and above have appdata local,roaming, and locallow and programdata (machine wide)
    btw oldgp and newgp are the same.

    Folder redirection must ALWAYS point to the same point (otherwise the situation that you have outlined will occur... It doesn't have to be on the 'server' it can be a network share when setting it up. even a DFS share.

    Author Comment

    Sorry, I posted the same image twice. Here is the new Gp where it shows "Documents" Instead of "My Documents". I also realized something else strange which may explain the duplicate image. I went back to my GP and as you can see from the new image the server name is "sngfs". However, I went to change it to a generic name for demonstration purposes which is what I did yesterday and as soon as I remove the "sngfs", the "users\clair\documents" changes to "users\clair\My Documents"

    Author Comment

    I was unable to view the PDF you posted. It says it is corrupted. I also am not sure how your answer helps me.

    Author Comment

    I started to investigate further by looking into the event viewer on the server. I noticed that there was a contsant error when the user logged in. The message is

    Event Type:      Error
    Event Source:      Folder Redirection
    Event Category:      None
    Event ID:      112
    Date:            30/08/2012
    Time:            10:00:53 AM
    User:            Username
    Computer:      Server
    Failed to perform redirection of folder Application Data. The files for the redirected folder could not be moved to the new location. The folder is configured to be redirected to <\\server\users\%USERNAME%\Application Data>.  Files were being moved from <M:\Documents and Settings\username\Application Data> to <\\server\users\username\Application Data>. The following error occurred while copying <M:\Documents and Settings\username\Application Data\Adobe> to <\\server\users\username\Application Data\Adobe>:
    The security descriptor structure is invalid.

    There seems to be similiar message each time. Most with Adobe beacuse alphabetically it is first but one user it was Avira, because they didn't have an Adobe folder.

    I actually tried deleting the Adobe and Avira folder and then logged in again and the same error above with what is now the first folder CCH. So it seems that there is something preventing it froim creating or moving the Application Data folder onto the network share. I checked the security of the folders and all is fine. Besides, it was able to create the Application Data folder as well as the Adobe or Avira or CCH subfolder.

    Any insight on how to fix this would be greatly appreciated.

    Accepted Solution

    I found an article from Microsoft which explains the proper security settings for the Redirect Share. I followed this article and it worked like a charm.


    Author Closing Comment

    The solution worked and no other one was given

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    What Should I Do With This Threat Intelligence?

    Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

    Setting up a Microsoft WSUS update system is free relatively speaking if you have hard disk space and processor capacity.   However, WSUS can be a blessing and a curse. For example, there is nothing worse than approving updates and they just have…
    You might have come across a situation when you have Exchange 2013 server in two different sites (Production and DR). After adding the Database copy in ECP console it displays Database copy status unknown for the DR exchange server. Issue is strange…
    This tutorial will give a short introduction and overview of Backup Exec 2012 and how to navigate and perform basic functions. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as conne…
    This tutorial will walk an individual through the process of configuring their Windows Server 2012 domain controller to synchronize its time with a trusted, external resource. Use Google, Bing, or other preferred search engine to locate trusted NTP …

    794 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    16 Experts available now in Live!

    Get 1:1 Help Now