all icons changed to .lnk windows 7

all icons changed to .lnk on a windows 7 workstation
How do I fix this?
LVL 1
HubmanAsked:
Who is Participating?
 
MereteConnect With a Mentor Commented:
Here is a utility that helps you unassociate a file type quickly in your Windows Vista or Windows 7 computer without the need to edit the registry manually.
Windows 7 & Vista do not provide a GUI option to unassociate file types, thus the need arises for such a tool below.
 Unassociate file types in Windows 7 & Windows Vista
http://www.winhelponline.com/blog/unassociate-file-types-windows-7-vista/

Click>> Remove .lnk file association <<  should be solved!!
0
 
Darr247Commented:
In regedit, go to
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\lnkfile
in the tree on the left, right-click on 'lnkfile' and choose New->String Value
name it NeverShowExt
close regedit.
If change doesn't take effect immediately, reboot.

If that String Value already exists, then report that back here instead. :-)
0
 
amarpal0102Connect With a Mentor Commented:
Open the Registry Editor
type regedit in run and hit enter).
go to this registry branch: HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVersionExplorerFileExts.lnk
Find the subkey called "User Choice" and delete it.
Close Registry and Reboot.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
HubmanAuthor Commented:
That key already exist
0
 
Darr247Connect With a Mentor Commented:
The 'NeverShowExt' String Value should also exist in the
HKEY_CLASSES_ROOT\lnkfile
key, so if it already exists at
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\lnkfile
check there, too.
0
 
andytagonistConnect With a Mentor Commented:
I think others have posted this, but to elaborate:
I believe what happened is you used "open with" on a shortcut. You can confirm this by going to the control panel > programs > Associate a file type or protocol with a program, scroll down to LNK for the associated program it should say Unknown.

1.    Click Start Menu, and then type regedit in the Start Search and press ENTER. Right click on regedit from the search results and run as administrator.
2.    Navigate to the following registry branch:
HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Explorer\FileExts\[ext]
Replace the [ext] with the actual file extension that you want to restore its file type association to revert back to original Windows 7 default (probably .lnk). If you unsure, simply browse through all the sub-key under FileExts. 
3.    Delete the sub-key named UserChoice.
4.    Exit from Registry Editor.

Reboot.
0
 
HubmanAuthor Commented:
Dont see [ext]
0
 
Darr247Commented:
I think what andytagonist meant by that is '[ext]' is the one that accidentally had 'Always use this program' checked when Open With was used, and that it would likely be the
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.lnk key (which should exist right above
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.log).
0
 
Darkworld1000Commented:
Just download link fix file for window 7 and run it , it will solve out

http://www.winhelponline.com/blog/file-asso-fixes-for-windows-7/
0
 
MereteCommented:
Just curious why you accept second answer which is copy of mine, I posted same solution first?
Glad to see the solution worked
with 2 choices lol
0
 
HubmanAuthor Commented:
You are correct, that was a mistake a you should have those points.
0
 
HubmanAuthor Commented:
Tried all these and things I googled....after reboot...working
0
 
MereteCommented:
That's good to see Hubman
Thanks again
Cheers
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.