• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2092
  • Last Modified:

Installing ruby for metasploit

hello
i have tried to install metasploit all day but no luck,
my system info:
Centos 6.0 64bit i has cpanel installed on it
i installed ruby via yum
Package ruby-1.8.7.352-7.el6_2.x86_64 already installed and latest version
but last time i check metasploit need ruby 1.9.1 and up

here's what i get with ruby 1.8.7 and metasploit:
[root@server script]# ./createuser
/opt/metasploit-4.4.0/apps/pro/msf3/lib/gemcache/ruby/1.9.1/arch/linux64/nokogiri-1.5.2/lib/nokogiri/nokogiri.so: libexslt.so.0: cannot open shared object file: No such file or directory - /opt/metasploit-4.4.0/apps/pro/msf3/lib/gemcache/ruby/1.9.1/arch/linux64/nokogiri-1.5.2/lib/nokogiri/nokogiri.so (LoadError)
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from /opt/metasploit-4.4.0/apps/pro/msf3/lib/gemcache/ruby/1.9.1/arch/linux64/nokogiri-1.5.2/lib/nokogiri.rb:27
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from /opt/metasploit-4.4.0/apps/pro/ui/config/boot.rb:35
        from ./createuser:8:in `require'
        from ./createuser:8

Open in new window

so any help guys
0
NoBoDyDD
Asked:
NoBoDyDD
1 Solution
 
southpau1Commented:
is this on a Centos VM?  if so I recommend just downloading the Backtrack VM, which has metasploit and many other awesome pen test tools on it.

http://www.backtrack-linux.org/
0
 
NoBoDyDDAuthor Commented:
nope , it is a normal server no gui thing, i will try to install vmware
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now