?
Solved

Installing ruby for metasploit

Posted on 2012-08-29
2
Medium Priority
?
2,070 Views
Last Modified: 2012-09-23
hello
i have tried to install metasploit all day but no luck,
my system info:
Centos 6.0 64bit i has cpanel installed on it
i installed ruby via yum
Package ruby-1.8.7.352-7.el6_2.x86_64 already installed and latest version
but last time i check metasploit need ruby 1.9.1 and up

here's what i get with ruby 1.8.7 and metasploit:
[root@server script]# ./createuser
/opt/metasploit-4.4.0/apps/pro/msf3/lib/gemcache/ruby/1.9.1/arch/linux64/nokogiri-1.5.2/lib/nokogiri/nokogiri.so: libexslt.so.0: cannot open shared object file: No such file or directory - /opt/metasploit-4.4.0/apps/pro/msf3/lib/gemcache/ruby/1.9.1/arch/linux64/nokogiri-1.5.2/lib/nokogiri/nokogiri.so (LoadError)
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from /opt/metasploit-4.4.0/apps/pro/msf3/lib/gemcache/ruby/1.9.1/arch/linux64/nokogiri-1.5.2/lib/nokogiri.rb:27
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
        from /opt/metasploit-4.4.0/apps/pro/ui/config/boot.rb:35
        from ./createuser:8:in `require'
        from ./createuser:8

Open in new window

so any help guys
0
Comment
Question by:NoBoDyDD
2 Comments
 
LVL 7

Accepted Solution

by:
southpau1 earned 2000 total points
ID: 38349844
is this on a Centos VM?  if so I recommend just downloading the Backtrack VM, which has metasploit and many other awesome pen test tools on it.

http://www.backtrack-linux.org/
0
 

Author Comment

by:NoBoDyDD
ID: 38350875
nope , it is a normal server no gui thing, i will try to install vmware
0

Featured Post

 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

It’s time for spooky stories and consuming way too much sugar, including the many treats we’ve whipped for you in the world of tech. Check it out!
Last month Marc Laliberte, WatchGuard’s Senior Threat Analyst, contributed reviewed the three major email authentication anti-phishing technology standards: SPF, DKIM, and DMARC. Learn more in part 2 of the series originally posted in Cyber Defense …
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
This video Micro Tutorial shows how to password-protect PDF files with free software. Many software products can do this, such as Adobe Acrobat (but not Adobe Reader), Nuance PaperPort, and Nuance Power PDF, but they are not free products. This vide…

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question