No rules, but emails move automatically into subfolder

I have a strange problem with my Outlook 2010. In my inbox, I have a sub folder that has emails with subject "RE: GP/Name, Ship". When I receive emails from with the same subject name, it gets automatically redirected into this folder.

There is no rules running that is moving this email. Neither is conversation enabled on this folder nor the inbox. I restarted Outlook using /cleanrules but this is still occuring.
It only happens for this particular email subject.

Any ideas?
Who is Participating?
stergiumConnect With a Mentor Commented:
perhaps your problem is grouping and not rules.
check this one
and please feedback
Since you have no rules that could be creating this behaviour, you can try renaming the folder. Just to see where these mail will go.
please feedback your results.
frukeusAuthor Commented:
It still goes into the folder after being renamed.
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Sushil SonawaneCommented:
Reconfigure your outlook then check
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
frukeusAuthor Commented:
I've reset both client and server rules but still the same results.

Subsequently, I tried check marking "Show as Conversations", and moved the entire conversation back to Inbox. Then I moved it back into the subfolder and unchecked "Show as Conversations".
That seemed to have resolved the auto-move issue.
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
I guess than we might need to use MFCMAPI to try and check and delete any corrupted rules.

Delete Corrupted, Hidden or Stale rules from mailbox with MFCMapi

How to delete corrupted and hidden rules from a single mailbox in Outlook 2003

Deleting a corrupt rule with MFCMAPI

- Rancy
frukeusAuthor Commented:
It indeed looked like the grouping was manual.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.