• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2180
  • Last Modified:

Ubuntu 12.04 on VMware ESXi 4.1.0 - "wired network disconnected" & update problems

I have installed Ubuntu 12.04 as a vm on our VMware 4.1.0 production cluster.  The initial install and upgrade went fine but after a reboot of the vm Ubuntu showed "wired network disconnected". All of our Windows vms on the same cluster/hosts are fine.

The vm spec is 512mb, 1cpu, 1x vmxnet3 nic  which connects to our server vlan (10.59.18.x) and 1 x flexible nic that points to our legacy vlan (10.56.x.x).

If I disable the vmxnet3 interface I do get a network connection back but the update window shows 409 updates with sizes range from a few kb to several mb each but the tag line says 409 updates slected 14kb will be downloaded.  When I click on install updates I get a message that says "failed to download package files" & "check your internet connection".  The internet connection is fine and I can happily browse to sites.

Please can someone point me in the right direction to get this problem resolved. Urgent so 500 points up for grabs!

Thanks
0
cmdown
Asked:
cmdown
  • 10
  • 7
4 Solutions
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
there is a fault with Ubuntu and virtual machines, with the rules for the network connection.

check the MAC Address in the rules, is the same as the VM.

e.g. if you type ifconfig, what is the output?
0
 
cmdownAuthor Commented:
Hi hanccocka
Output attached as png image
ubuntu-nic.png
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
does this VM have working networking?

does it have two network interface cards in the VM?
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

 
cmdownAuthor Commented:
1. No if both are powered on at vm startup, yes if the vmxnet3 i/f is disabled - i.e vm only has access to the 10.56 vlan
2. Yes - both were configured in the bare vm shell prior to Ubuntu being installed from iso image mounted on the esx host
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
so you need to working network cards in Ubuntu VM?
0
 
cmdownAuthor Commented:
Yes, there are two nics in the network panel of system setting.  One is on the 10.56 vlan using ipv4 dhcp (ipv6 ignore).  The other is on the 10.59 vlan again using ipv4, dhcp, ipv6 ignore but it won't connect.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
the network interface is set to connected and connected at power on, in the VM Settings, next to the interface.
0
 
cmdownAuthor Commented:
update to the above...
Just in case it was vmxnet3 itself not being 'liked' by ubuntu I added a third nic set to use if type = flexible but again on the 10.59 vlan - I still get the same issue where this comes up connecting/disconnected.
0
 
cmdownAuthor Commented:
sorry - our two posts crossed over.  In answer to your question, yes the interface is set to connect at power on for both network cards.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
check the following

/etc/udev/rules.d/70-persistent-net.rules

remove all the contents of the file, and restart

the file gets re-created
0
 
cmdownAuthor Commented:
Hi hanccocka.  Thanks for the reply.  I'll give this a go later this afternoon and let you know how I get on.
0
 
cmdownAuthor Commented:
Hi hanccocka

opened the file for edit - it is blank
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
the rules process is not running it should contain MAC Addresses.
should be like this:-

ACTION=="add", SUBSYSTEM=="net", SYSFS{address}=="00:e0:4c:12:34:56", \
    NAME="realtek"
ACTION=="add", SUBSYSTEM=="net", SYSFS{address}=="00:a0:c9:78:9a:bc", \
    NAME="intel"
0
 
cmdownAuthor Commented:
Hi Hancocka

Sorry for the delay in replying.  Are you saying that in the absence of this file I should create it manually  or is there a way to force ubuntu to generate this file itself?

Regards
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
in the absence of the file, it will be re-created at computer startup.
0
 
cmdownAuthor Commented:
Hi Hanccoka

Apologies I missed the email alerting me to your last post.  This file isn't getting recreated so I'm going to blow away the VM and start again - probably with Mint as I've got another linux vm based on Mint 13 that has installed fine.
0
 
cmdownAuthor Commented:
Hi Hanccoka

Another Linux Mint VM has gone in with no problems - there must have been a problem with the previous Ubuntu install.  Many thanks for your help.  Points awarded for all the good advice given.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 10
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now