• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 570
  • Last Modified:

Mac Question

My Mac is indexing for no reason.  I would like to turn this off since it is using up my resources.  How do I go about doing this.  I am new to the Mac Computer platform.
0
NikkitaKialandMiles
Asked:
NikkitaKialandMiles
  • 2
  • 2
2 Solutions
 
SjizzelCommented:
This link helps stopping Spotlight:

http://www.usingmac.com/2008/5/9/spotlight-indexing


What version of OSX are you running?
0
 
NikkitaKialandMilesAuthor Commented:
10.7.4
0
 
SjizzelCommented:
0
 
XaelianCommented:
Hi,

You got 2 chooses. The first is disabling spotlight with indexes so you can't search with it and it won't index. The second is only disable indexes. Here are the steps for both. I would advice you to read everything carefully. Because when you only disable indexes it can be that it throws you an error..

Turn of spotlight + indexes
1. Open up the Terminal (found in /Applications/Utilities/) and enter the following commands based on the need to either disable or reenable Spotlight indexing. This will effect indexing on all drives connected to the Mac.

2.this will require the administrative password:
sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

Open in new window


To re-enable it:
Reload it into launchd using launchctl:
sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

Open in new window


Turn of indexes

1. Open up the Terminal (found in /Applications/Utilities/) and enter the following command:
sudo mdutil -a -i off

Open in new window


Re-enable it with:
sudo mdutil -a -i on

Open in new window

But be carefull, this can throw the "Spotlight server is disabled" error. And you can't turn it back on. But if you have this you can run the
sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

Open in new window

and it will work. So if you choose for the second method. Keep this topic bookmarked so you can find the command to turn it back on :).
0
 
NikkitaKialandMilesAuthor Commented:
Great work.  Thank you so much
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now