• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 642
  • Last Modified:

Un able to connect using RDP or Computer managment

Error message "The connection cannot be completed because the remote computer that was reached is not the one you specified. This could be caused by outdated entry in the DNS cache. Try using IP address of the computer instead of the name."

After adding this working on my domain, I received this error message when I try to RDP using the hostname. But if I use the IP address it work. Also I’m not able to remotely used computer management to  this workstation.
This is what I did prior to this issue.
1.      I change the power setting to always on.
2.      I enable the RDP setting.
3.      I Disable the firewall setting.
4.      I add the Pc to the domain.
This is the steps I followed to trouble shoot this.
1.      I run I config/all – no anomalies
2.      I run nslookup – no anomalies
3.      I flush the dns
4.      I remove the PC out of the domain
5.      I re-add the PC back to the domain using different host name.
After all of this, I still receive the same error message. Thoughts?
Hence, I know I having a DNS related issue, but where?
0
tomfontanilla
Asked:
tomfontanilla
1 Solution
 
ransommuleCommented:
Try to ping hostname and see if the IP reached if the desired one.

Windows -> run -> cmd.exe -> ping hostname

Look in host file if there is an entry for that hostname

Locations of hostfile can found here : http://en.wikipedia.org/wiki/Hosts_(file)
0
 
tomfontanillaAuthor Commented:
Hi ransommule,

In additon to what I said above, I did check for possible dups entry on hostname or IP address. If you ping resolve the host, it is the correct info. What I dont understand here, is that I cannot use the host name for any remote connection. Thoughts?
0
 
tomfontanillaAuthor Commented:
I also run ipconfig /registerdns and hostname.
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
Matt VCommented:
Do an nslookup of the hostname, you might get a different result than the ping.
0
 
tomfontanillaAuthor Commented:
See my original post, I did that too.
0
 
ransommuleCommented:
Hi, tomfontanilla

Have you tried to flush dns cache ?

ipconfig /flushdns ?


As I explained previously windows will cache the DNS hostnames and if you don’t want to reboot the workstation you will have to clear its internal cache so it will query again the DNS resolver that will hopefully follow the standards and get the correct IP. In order to do this open a command prompt (Start/Run then type cmd) and type:
http://www.ducea.com/2006/08/07/flush-dns-cache-on-windows-workstations/
0
 
TheGeezer2010Commented:
Is the hostname suffix the same as your source machine ? If not try adding the suffix (in the DNS entries) on your source machine.

If you look in DNS, what entry(s) are shown for the target IP address ?

What do you get if you do ping -a <IPaddress> - the correct FQDN ?

How many DNS servers does your client have in its configuration ? Are the DNS servers in sync ? Has your target DNS server cached the errant entry ? Try clearing the server DNS cache, the client dns cache and the client NETBIOS cache (nbtstat -R).

Any joy ?
0
 
tomfontanillaAuthor Commented:
See my original post. I did that too rebooted and flush.
0
 
ransommuleCommented:
Sorry I didnt saw that, what about add a entry in the host file ?
0
 
tomfontanillaAuthor Commented:
what do you mean "add entry on the host file?
0
 
ransommuleCommented:
I also found this

Make sure the time on the target server is accurate. It has to be within 5 minutes of the DC usually or servers and workstations start to act funny, though it should be exact. I corrected the time on my newly reformatted target server (2008 not R2) and immediately connected afterwards from my Win7 PC.
0
 
ransommuleCommented:
# Copyright (c) 1998 Microsoft Corp.
# This is a sample HOSTS file used by Microsoft TCP/IP stack for Windows98
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
# For example:
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host

192.168.1.1 hostname
0
 
tomfontanillaAuthor Commented:
Time is correctly synchronize on the PC and Server.
0
 
ransommuleCommented:
Interesting....

tracert hostname points to the correct ip ?
0
 
Premkumar YogeswaranAnalyst II - System AdministratorCommented:
Hi,
Before registerdns... Delete the record.in dns... And then register the system.. Using
Ipconfig /registedns

Also in ipconfiguration dns tab make register dns automatically is checked..

Regards,
Prem
0
 
tomfontanillaAuthor Commented:
Hi premglitz,
Thank you for your response. That was my initial thought to check the DNS on each of my DC.

I think I fixed the problem.
I remove the PC out of my domain, add it to a group.  
I flush the dns
I remove it from AD, DHCP, and DNS the hostname used.
Then I added the PC again to my domain
flush the dns
re-register the domain
And it work.
0
 
tomfontanillaAuthor Commented:
Fixed the issue by simple removing the PC's domain membership and re-adding it back to the domain.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now