iSeries Data Transfer error

I have a new Windows Pro 64bit pc with iSeries Access for Windows 5.9 installed that is getting an error when an exist transfer request is ran. (.dft)

The user originally installed it with PC5250 access only.  After uninstalling and reinstalling you are able to run a transfer manually, but when it is double clicked you get the following error.
"The filename, directory name or volume label syntax is incorrect."  Then if you click OK a second error reads Invalid file type or corrupted.

The file is set to open with C:\Program Files (X86)\IBM\Client Access\cwbtf.exe

Any suggestions on what to try?
DCS12Asked:
Who is Participating?
 
Gary PattersonConnect With a Mentor VP Technology / Senior Consultant Commented:
Oh, okay.  Good to know.

Open up regedit.exe
Navigate to HKEY_CLASSES_ROOT\.dtf\ShellNew
And post the current value of the Command string.  On my machine it is:

C:\PROGRA~2\IBM\CLIENT~1\cwbtf.exe /r %2

Since my Client Access folder is c:\program files(x86)\Client Access\.

If all else fails, just remove Client Access, reboot, and reinstall - that will most likely properly re-register file associations.

- Gary Patterson
0
 
Gary PattersonVP Technology / Senior Consultant Commented:
This usually happens when the filename, directory name or volume label syntax is incorrect in the saved DFT.

Open up the saved DFT and make sure the name of the target file location is valid.

- Gary Patterson
0
 
DCS12Author Commented:
Yes it is valid.  If I open the Data Transfer for System i, then click File-->Open, browse to the same file it opens now problem and transfers no problem.  

It is only when I double click it or try to run it from the 5250 window using STRPCCMD.
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Gary PattersonVP Technology / Senior Consultant Commented:
Any chance your file associations are corrupted?  You said "DFT", and it should be "DTF", I think.  IF it is named with the wrong extension for some reason, that could certainly be a problem.

If that is not the issue, then I suspect that it is just something funky in the way the command that is eventually running is getting composed.  

Do you have the full command that you are trying to execute through STRPCCMD that you can post here?

Looks like the path to the EXE has some spaces in it - does the path to the DTF or the target file have spaces in them?  Also, I've seen problems like this when the final command was just too long due to long pathnames.

If so, just as a test, try moving the DTF to a simple, short folder name and changing the target filename to a simple folder name:

md c:\testxfer

then move the DTF to c:\testxfer, and update the DTF to put the target file in that same folder, and see if the same thing happens.

You might also want to consider trying the RTOPCB / RFROMPCB commands instead, which are designed specifically as command line utilities, unlike CWBTF, which is a GUi utility.

- Gary Patterson
0
 
DCS12Author Commented:
The STRPCCMD is not the issue, because I get the same when I just run the .dtf by double clicking the file.

I does have something to do with file associations.  Forgot to mention that somehow these files got changed and where trying to open with Excel and I had to change it back to CWBTF.      

I have never used RTOPCB.  Can it transfer PF directly to Excel format?  This company has hundreds of these transfers already setup so it might be a lot of effort to change for one pc not acting right.
0
 
Gary PattersonConnect With a Mentor VP Technology / Senior Consultant Commented:
While you are in regedit, verify the other cwbtf.exe entries:

HKEY_CLASSES_ROOT\.dtt\ShellNew COMMAND = C:\PROGRA~2\IBM\CLIENT~1\cwbtf.exe /s %2
And
HKEY_CLASSES_ROOT\AS400Transfer\Shell\Batch\Command default = C:\PROGRA~2\IBM\CLIENT~1\cwbtf.exe %1 /b
and
HKEY_CLASSES_ROOT\AS400Transfer\Shell\Open\Command default = C:\PROGRA~2\IBM\CLIENT~1\cwbtf.exe %1
and
HKEY_CLASSES_ROOT\AS400TransferFrom\Shell\Open\Command default = C:\PROGRA~2\IBM\CLIENT~1\cwbtf.exe %1
and
HKEY_CLASSES_ROOT\AS400TransferTo\Shell\Open\Command default = C:\PROGRA~2\IBM\CLIENT~1\cwbtf.exe %1

- Gary Patterson
0
 
tliottaCommented:
For future reference, there is no "iSeries Access for Windows 5.9". Almost certainly you are referencing the version of the Personal Communications (PCCOMM) Workstation Program. PCCOMM is one component of iSeries Access.

To see the iSeries Access version navigate through Start-> Programs-> IBM iSeries Access for Windows-> Properties.

In addition to Gary's advice, you should also report here the version from Properties and the Service level that is shown next to it. Also, by "Windows Pro 64bit", you mean Windows XP Pro 64bit, right?

Tom
0
 
MurpheyApplication ConsultantCommented:
Try to avoid using the short names like PROGRA~2,  because this is sequential named and depending on the sequence you installed programs, it could be different per user.

Names with spaces also give problems with STRPCCMD

To be sure use long names and if spaces are included, quote the command:
C:\PROGRA~2\IBM\CLIENT~1\cwbtf.exe %1
as
"C:\Program files\IBM\Client Access\cwbtf.exe %1"
or in some cases as
"C:\Program files\IBM\Client Access\cwbtf.exe" %1

You als can include "C:\Program files\IBM\Client Access" in your path setting or
make a substitute to this path with :

SUBST Q:  "C:\Program files\IBM\Client Access"

In the last case, you can use Q:\cwbtf.exe %1
0
 
DCS12Author Commented:
We never did resolve this, but thanks for the suggestions.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.