• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 576
  • Last Modified:

RDC TO WORKSTATION

we already have set up terminal server 2003 wherein users connect through rdc from outside and access e-mails. and drives.we are not using vpn.

i am trying to make my boss workstation (xp)accessible directly through RDC from his home pc

for that i have configured in my watchguard firewall as follows

1) created new policy
2) any external-public-ip-workstation ip on port 3389-3390

changed his workstation port number through registry -3390

still cannot connect directly to his workstation, anything missing.
0
pramod1
Asked:
pramod1
  • 8
  • 6
  • 3
1 Solution
 
CompProbSolvCommented:
Here is my answer from the other thread:

When you try to connect to the workstation, just add a colon and the port number at the end.

For example, if the TS is at 192.168.1.180 and uses port 3390, you would specify the server address (when on the LAN) as 192.168.1.180:3390.  If you are remote, use the external IP address followed by :3390.

I would test it locally first to isolate problems with the port change from problems with the port forwarding in the router.  That is, first try to connect to the workstation with another workstation using the 192.168.1.180:3390 address.  Once you are successful with that, try the remote connection from a computer not on the LAN.
0
 
PAdocITCommented:
If he doesn't have admin rights you will need to add him to the remote desktop users group on his work machine.

remote desktop users
0
 
pramod1Author Commented:
i am trying to connect from outside by his computer name sam.domain.com(example)

I have added his name in remote desktop users.

can't i connect by his computer name:3390??
0
Microsoft Certification Exam 74-409

VeeamĀ® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
pramod1Author Commented:
when in officebehind my firewall i type his computer name in rdc window, i connect

but not from outside
0
 
CompProbSolvCommented:
When outside you would use the same name as you use when connecting to the main TS box (which is your external IP address or name), but you will add the colon and port number.  When inside, you can use his local address or name (with the colon and port).
0
 
PAdocITCommented:
Are your domain/IPs public?

I know that in the past in order to be able to remote to my home computer from work i had to use my public IP address and then use port forwarding in my router to actually get to my computer with a nat IP.
0
 
pramod1Author Commented:
have i configured correctly port

3389-3390

or it should be 3390-3390 on my policy which is RDP1
0
 
pramod1Author Commented:
when inside i use his name. domainname.com  and connect to his workstation from any other workstation in office

but when i use same with: 3390, i cannot connect to his workstation.
0
 
CompProbSolvCommented:
It should be 3390-3390.  That is, the external port number (the one that the remote client will use) is 3390 and the internal one (that is passed to the workstation) is 3390.
0
 
PAdocITCommented:
So when your outside of your network what DNS is resolving your boss's hostname?

For example your boss is connected to his ISP at home. Is his ISP able to resolve his computer's hostname? Have you tried using IP instead of computer name?
0
 
pramod1Author Commented:
i am trying to change to 3390 , let me check that first and get back to u
0
 
pramod1Author Commented:
When i try to put in port range it says invalid port range (start server port-3390-end server port-3390)

what should i do
0
 
CompProbSolvCommented:
Is it conflicting with another rule or policy that uses that port?
0
 
pramod1Author Commented:
no. i don't have any policy with 3390-3390
0
 
CompProbSolvCommented:
You should be able to have a rule or policy that starts and ends with the same port number.  

Try setting up a policy that  starts and ends with 3391.  If that works, change the workstation and the remote client to use port 3391.
0
 
pramod1Author Commented:
am i doing something wrong, i am going into policy  manager add policy name the template

select port range 3391-3391 it says invalid port range
0
 
CompProbSolvCommented:
I don't know your router well, but my first assumption is that the range overlaps the range of some other policy.  Can you list all of the existing policies?
0

Featured Post

Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

  • 8
  • 6
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now