• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 714
  • Last Modified:

Weird characters in URL

I've been developing a site locally and the i upload to out hosting server. I noticed the URL having weird characters. When I first started developing the site, i dont recall seeing the characters....this is how it looks like

https://mysite.com/(S(pm2bnyltd2yzazhlv32wcpzs))/default.aspx

and on my local machine, when i run it thru VS2010:

http://localhost:43130/testsite/(S(ulhlgk5rmxt5k5gf34bpymmi))/Default.aspx
0
Camillia
Asked:
Camillia
  • 3
  • 3
1 Solution
 
ransommuleCommented:
That happens when you manage session states without cookies.


http://msdn.microsoft.com/en-us/library/aa479314.aspx
0
 
CamilliaAuthor Commented:
oh, is that ok tho? to manage session states without cookies?
0
 
ransommuleCommented:
I prefere cookie session management, but I think it is OK to manage cookieless.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
CamilliaAuthor Commented:
yeah, i dont have a lot of variables in session. Let me read the article. Thanks
0
 
CamilliaAuthor Commented:
Can i have

 <sessionState mode="InProc" cookieless= "false" timeout="20"/>

even if I'm not saving anything in a cookie? or should that be "true"?
0
 
ransommuleCommented:
Try
 <sessionState mode="InProc" timeout="20"/>

I think the default value of cookieless is false
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now