• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2205
  • Last Modified:

Exchange 2010 - Ghost objects in global address book

I have two items that are showing in the global address book that I want to hide and or get rid of.  The two items are not listed in the recipient configuration under mailbox or distribution group.  

When I tried to use the powershell command I get an error that the object does not exist in the domain controller.  I decided to try and fake it out by recreating the objects but that didn't work either.  

Any ideas on how to remove these items or find out where the global address book thinks they are?
0
taadmin
Asked:
taadmin
  • 20
  • 15
1 Solution
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Possible contacts or Mail enabled Public folders :)

- Rancy
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Sorry you said cant find them in Recipient configuration so only place left is Public Folders ... see if you can find the object in ADUC ?

- Rancy
0
 
taadminAuthor Commented:
I looked at the public folders and they are not listed in there either.  Really I have no idea how they would've been part of Exchange as they were never mailboxes in the first place.  I have done a search in Active directory and I have not found them.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Can you please if possible share a screenshot of them ?

- Rancy
0
 
taadminAuthor Commented:
from the address book?
0
 
taadminAuthor Commented:
here is a screenshot
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Sorry but no screenshot :(
0
 
taadminAuthor Commented:
I tried to attach a file but I have no clue where it went.  The items in question are listed in  the GAB as Asset Copy 2012 - alias is assetcopy2012
0
 
taadminAuthor Commented:
The second is Conference Room A - alias conferencerooma

The Email address address in the properties says
 
x400:C=us;A=; P=NHHFA;O=Exchange;S=assetcopy2012
SMTP:assetcopy2012@nhhfa.org


x400:C=us;A=; P=NHHFA;O=Exchange;S=conferencerooma
SMTP:conferencerooma@nhhfa.org
0
 
taadminAuthor Commented:
Oh - also I know it is not a user or distribution group because the icon next to each is a picture of a file folder with an envelope on it.  This as you mentioned before seems to indicate a mail enabled folder
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Did you try to search in ADUC with the email address as below ?
assetcopy2012@nhhfa.org
conferencerooma@nhhfa.org

- Rancy
0
 
taadminAuthor Commented:
Yes and there are no items that match the current search
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Run the below command .... once the command completes try to find the Asset copy and Condroom

Get-PublicFolder -Identity \NON_IPM_SUBTREE -Recurse -ResultSize Unlimited  | Format-List Name  > C:\Public.txt

- Rancy
0
 
taadminAuthor Commented:
I have to log out of the exchange server for now so I will do it first thing in the morning.
Thanks.
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
cool ... keep me updated
0
 
taadminAuthor Commented:
This is what was produced:




Name : NON_IPM_SUBTREE

Name : EFORMS REGISTRY

Name : Organization(409)

Name : Organizational Forms

Name : Events Root

Name : OFFLINE ADDRESS BOOK

Name : /o=NHHFA/cn=addrlists/cn=oabs/cn=Default Offline Address List

Name : OAB Version 2

Name : OAB Version 3a

Name : OAB Version 4

Name : EX:/o=NHHFA/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)

Name : EX:/o=NHHFA/ou=First Administrative Group

Name : OWAScratchPad{22CBC541-B3FE-44C6-9DD9-76F37D1F8A7E}

Name : OWAScratchPad{D204A937-B4AC-404C-9E3E-007EF3790B6D}

Name : OWAScratchPad{D724CCE7-B24B-4B50-B5EF-119F3B3E852B}

Name : SCHEDULE+ FREE BUSY

Name : EX:/o=NHHFA/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)

Name : EX:/o=NHHFA/ou=First Administrative Group

Name : Schema

Name : schema-root

Name : Default

Name : microsoft

Name : exchangeV1

Name : StoreEvents{D204A937-B4AC-404C-9E3E-007EF3790B6D}

Name : globalevents

Name : internal
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Get-PublicFolder -Identity \IPM_SUBTREE -Recurse -ResultSize Unlimited  | Format-List Name  > C:\Public.txt

:) - Rancy
0
 
taadminAuthor Commented:
The error message that I get says "No existing 'PublicFolder' matches the following identity: 'IPM_SUBTREE'
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Get-PublicFolder -Identity "\" -Recurse -ResultSize Unlimited  | Format-List Name  > C:\Public.txt
0
 
taadminAuthor Commented:
Interestingly enough the IPM_SUBTREE is showing up in the file.  ConferenceroomA and AssetCopy2012 does not.
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
So does the last comment gives you a list of all the PF's in your environment ?

- Rancy
0
 
taadminAuthor Commented:
yes.
0
 
taadminAuthor Commented:
I would send you the file however everytime I browse for the file, select it then select attach I get a message that says to select the file to uploaded.  no clue what it wants.
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Humm no issues .... quiet strange !!

If the object isnt found in AD where could it be ?

Do we have multiple domains ?

- Rancy
0
 
taadminAuthor Commented:
Just one domain.  I can tel you that the assetcopy2012 was actually a copy of our asset database in an old helpdesk system.  Assets was a subfolder under the helpdesk folder.  

Conferencerooma may have been a public calender at one point, not really sure.  We do have an active conference room a but the mailbox is called confrooma
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Strange and it should either be .... what all information do they list and are they seen in GAL from OWA ?

PF\Contact\Mailbox\DL :(

- Rancy
0
 
taadminAuthor Commented:
These show up in the gal as public folders
0
 
taadminAuthor Commented:
I can not get into the webapp.  We must have it blocked somewhere.  I get a login screen but when I enter the credentials is says the page cannot be displayed.
0
 
taadminAuthor Commented:
I think I may have stumbled onto something.  when I run the cmdlet
get-mailbox|fl name, emailaddresses >> c:\addresses.txt       it runs great however when I

run Get-MailPublicFolder | fl name, emailaddresses >> pf-addresses.txt     it fails and a whole bunch of errors come up.  From what I can see the offline address book is corrupt.
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
It will fail as not necessary that all PF's would be Mail enabled.

As its a PF it should be in MESO or in the command i shared as i to work on such things everyday :)

Huff can understand how lengthy its getting ..... but using EE thatss at most i can ... let me see today i can get something more in my Lab.

Can you share the error when you try to create an object with the same name ... plzz

- Rancy
0
 
taadminAuthor Commented:
I created the public folders again and mail enabled them.  They now appear in the Gal twice.  Interestingly enough the email addresses were created with a 1 on the end of them.   So it must know something is out there I just can't get to it.
0
 
taadminAuthor Commented:
When I tried to change the email address it says it is use.  


--------------------------------------------------------
Microsoft Exchange Error
--------------------------------------------------------
The following error(s) occurred while saving changes:

Set-MailPublicFolder
Failed
Error:
The proxy address "X400:C=us;A= ;P=NHHFA;O=Exchange;S=assetcopy2012;" is already being used by "nhhfa.org/Microsoft Exchange System Objects/asset copy 2012". Please choose another proxy address.


Error:
The proxy address "SMTP:assetcopy2012@nhhfa.org" is already being used by "nhhfa.org/Microsoft Exchange System Objects/asset copy 2012". Please choose another proxy address.




--------------------------------------------------------
OK
--------------------------------------------------------
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
The error also says "Microsoft Exchange System Objects" ...... so its there ..... can you right click on that OU in ADUC and try to find with "assetcopy2012" or "assetcopy2012@nhhfa.org"

- Rancy
0
 
taadminAuthor Commented:
I finally found the stupid things.  Apparently in active directory, in order to see MESO you have to have this little thing called Advanced Features turned on.  I am not overly familiar with Exchange 2010 or Windows 2008 servers.  This could have been solved along time ago had I been able to see the Microsoft Exchange System Objects in the first place, I just figured it was a change in how exchange and AD worked in the new environment.  


Thank you for your patience.  Nothing like learning on the fly
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
I finally found the stupid things - YIPEEEE !!!!

Apparently in active directory, in order to see MESO you have to have this little thing called Advanced Features turned on - Oops my mistake :(

Your always welcome !!

- Rancy
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

  • 20
  • 15
Tackle projects and never again get stuck behind a technical roadblock.
Join Now