• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 11281
  • Last Modified:

Remote Access an IP Camera using a Tenvis and BT Home Hub

Guys,

I need help!!! I have been trying to sort this on and off for about two weeks and keep running into problems.

I have bought a Tenvis JPT3815W. Using their software (IP Camera Tool) from their site:

http://www.tenvis.com/support_service.html

I can get my camera to work through the LAN and thus through WiFi. Process is pretty simple, you just connect camera to the LAN, do a search for your WiFi and then follow the instructions.

Thus I can get it on my Mac, my W7 (64Bit) PC's (all three of them), my iPhone, my iPad etc etc.

However...................

I cannot get it if I am not on my network.

Tenvis videos talk about two things. Port Forward and DYNDNS. I have bought myself a DYNDNS account for $20.00, and had a go at adding it into the BT Home Hub.

I also looked at port forwarding and on portfrward.com and considered just paying the $30.00 to buy their wizard.

Problem is, I actually have no idea what I am doing with it all. If I go to the IP Camera Tool and enter my DYNDNS domain, user name and password all it does it says network comms error. I suspect it is needing something doing to my Home Hub router.

I can find thousands of articles on this, but none that join the dots and none that are use to a man with very limited network knowledge.

PLEASE PLEASE HELP!!! I need it working today as I will be away from Monday and need to see what is happening

T H A N K

Y O U
0
arasburn
Asked:
arasburn
  • 30
  • 12
1 Solution
 
edster9999Commented:
The network inside your house is not visable from the outside.  The only thing that is, is the BT modem.

To connect to something inside you need two things.  

1. You need to know the IP address of the router - there is a good chance that this gets updated about once a day.  There are two methods of fixing this.  The first (because it is the easiest) is to ring the BT helpdesk and ask can you have a fixed public IP address.  If they say yes... job done.  Go to a page like
http://www.whatismyip.org/
and you will see your IP address on the outside.
If this does not work then you use the dynamic DNS.  You will either need to find one that your modem supports (check the book that came with it or log onto the modem (see below)) - or you can run a program on a PC inside if you leave it turned on all the time that will update the named address when your ISP (Internet company) change your address.


2. The second thing you need is a 'port forward'.  This says that when something comes from the internet bounce it to this machine inside.
Don't pay for this - it is free.
You need to get the IP address of your camera.  This is the address you contact it on ie 192.168.0.X
and you need to know what port it talks on.  If it is all http at the start of the web address then it is port 80.  If it sometimes goes to 'https' then you also need port 443.
Every modem is different but you need to go to its address from your PC inside the house.
check the bottom of the modem - that often gives you the address and the password.
Login and look for a menu option saying 'port forward' or 'NAT'
you might have to click on 'advanced' to see these options and they may be hidden under 'network' or 'lan'

Normally it asks for incoming port : 80
and address to forward it to : 192.168.0.XXX (as above)

Sometimes it also asks for the port to go to : 80
now click SAVE and test it from outside.

You may also have to find another menu option that says firewall and select port 80 as open.
Oh and if you found you need port 443 above then also forward that in.

Now - a word of caution.  IP cameras are notorious for not having great security.
If you are going to do this, set it to the best security level it has.  Make sure your password is a bit better than '1234' or 'password' :)
If your modem has the option to land on a different port you could try doing something like -

incoming port : 80999
forward it to : 192.168.0.XXX (as above)
port to go to : 80

This means you would connect to it using -
http://10.20.30.40:80999
but that would go to port 80 on the camera.

This would make it a little harder to find.
0
 
carlmdCommented:
Is there a firewall protecting the LAN?

Is this a business or home, and what kind of internet connection (cable modem, dsl, fios, T1 etc) do you have. Do you have fixed ip addresses available on the WAN?
0
 
arasburnAuthor Commented:
edster9999 !!!!!!!!!!!!!!

Thank you, will work my way through your list. May need to ask a couple more questions!
0
Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

 
arasburnAuthor Commented:
Hi carlmd,

I have Kaspersky running, although did turn it off. I am not sure what connection it is, I know its not a T1. It's BT Broadband (not fibre optic) and not that fast!

I would not know about the fixed IP, sorry!
0
 
edster9999Commented:
Fixed IP - Thats the thing I mentioned on point 1.  It is unlikely you have it from BT unless you asked for it.
Going to a website like whatsmyip.org will tell you your current public IP but it doesn't say if it is fixed or not.
0
 
edster9999Commented:
and here is how to do the port forward :
http://www.filesaveas.com/bthomehub_portforwarding.html
0
 
arasburnAuthor Commented:
Hi  edster9999,

BT have informed me I can only have Dynamic on consumer Broadband!

My DYNDNS I bought is this:

XXXXXX.dyndns-free.com

I can type in full if safe to do on here?
0
 
arasburnAuthor Commented:
Hi  edster9999,

Camera IP is this one:

192.168.1.239:81

Will work through the port forward piece now!
0
 
arasburnAuthor Commented:
Hi  edster9999,

I had done the PF piece I think except it shows to use a zero at the end, and I had 81 (on Trigger Port).

Image attached, does it look ok?
0
 
arasburnAuthor Commented:
On the second bit I am not sure I have done it right. Do I delete the :81?
0
 
arasburnAuthor Commented:
Thus I now have:
0
 
arasburnAuthor Commented:
Not sure my images have attached?
Untitled.jpg
Untitled2.jpg
Untitled-3.png
0
 
arasburnAuthor Commented:
Hi  edster9999,

This is my attempt at the DYDNS bit....
Untitled4.jpg
0
 
arasburnAuthor Commented:
Hi  edster9999,

When I go to my camera tool, I get this (note the chrome message appears in the iframe)
Untitled-5.png
0
 
edster9999Commented:
Ok the DynDNS stuff looks ok.   (you are correct in NOT publishing the name here)
The port forward looks good too.  You don't need the trigger port bit so leave that at '0'

I assume the test screen shot is from out side your network.

It is getting the menu on the left so that bit is working.
It looks like the main image bit maybe comes in over a different port.
I'll see if I can find anything on it...
0
 
edster9999Commented:
Try looking at the source to that web page.
It should have the address it is going to for the iFrame.
Mask the address bit and show the rest (or enough to give me a clue)    :)
0
 
edster9999Commented:
In the setup for the camera - set up the http port but do not set anything in RTSP port
0
 
arasburnAuthor Commented:
Hi,

This was the page that generated the Google Chrome response. It did not used to do that, it used to say 'Network Communications Error'.


Re security, its a camera in my Hedgehog Cage so no one would be that bothered I don't think! :)
Untitled-6.jpg
0
 
arasburnAuthor Commented:
This is the status page:
Untitled-7.jpg
0
 
arasburnAuthor Commented:
These are the options from the camera tool. Double clicking opens a browser window.

Was going to try sending you a Teamviewer but does not seem to be a way to do it :(
Untitled-8.png
0
 
arasburnAuthor Commented:
This is from Network Settings:
Untitled-9.png
0
 
arasburnAuthor Commented:
I choose sever push on here (although have tried IE) this is the web page that opens when you double click the camera tool. the other images above are right mouse clicks
Untitled-10.png
0
 
arasburnAuthor Commented:
This is what I can see on Live Video (Food pots!!) :)
Untitled-11.png
0
 
arasburnAuthor Commented:
These are the videos Tenvis send, but they seem to just stop at a point and assume all works.

http://www.tenvis.com/support_service-49.html
0
 
arasburnAuthor Commented:
"Try looking at the source to that web page.
It should have the address it is going to for the iFrame.
Mask the address bit and show the rest (or enough to give me a clue)    :)"


I tried this by right clicking and it just seems the iframe source is the camera IP address, could be wrong. What is worst that could happen if I send it you? Guessing means someone can see my hedgehog? :)
0
 
edster9999Commented:
The DynDNS page is not able to talk to the main server (outside on the internet) to tell it your IP.

You only need to do this in one place - so either do it on your router or on the camera.
If you are doing it on the camera, check your settings.
I'm guessing you have gateway or DNS server wrong.

Check the top image here again :
http://www.tenvis.com/support_service-59.html

If you cannot get it going - try the DNS IP as 8.8.8.8

When you have this going click on 'server push' and show what error you get from that.
0
 
edster9999Commented:
I would suggest against sending it.  It will always be published.
People will be finding it in searches for cameras for years to come.

If the address that is coming up is your cameras address (like 192.168.x.x) then this is the issue.
It should be able to work this out itself.  It should use just the path and not the full IP.
Check the setup in the camera again to see if you can specify it is going over a port forward connection or something like that
0
 
arasburnAuthor Commented:
Ok so the IP addresses are different? Is that what you expected?
Untitled-12.jpg
0
 
arasburnAuthor Commented:
Just tried on the IP Camera Tool 8.8.8.8 and it rebooted the camera.

That DYNDS page after server push has brought back the chrome error screen and the live video has now gone.
0
 
arasburnAuthor Commented:
Correction............. video is back on again!  Will try the DYDNS Submit thing again!
0
 
arasburnAuthor Commented:
Ok so the DYDNS rebooted camera and gave the chrome screen again.
0
 
arasburnAuthor Commented:
I dont mind giving you an old e-mail address that I can still check, if I did that when you get a spare minute would you Team View in??
0
 
arasburnAuthor Commented:
PS. Happy to pay you for this!! Its been the bain of my life for weeks!! :)
0
 
edster9999Commented:
the gateway and DNS are wrong
they should both be 192.168.1.254
0
 
arasburnAuthor Commented:
Just changing them now on IP Camera Tool
0
 
arasburnAuthor Commented:
Did that and changed them, it rebooted. Went to the DYNDNS page and got that chrome error again?

Sorry!! If sick of this question, can totally understand!
0
 
arasburnAuthor Commented:
Noticed that on DYNDNS there is a name but also numbers (IP?)

Image below, should I use the numbers on my HomeHub and Camera Tool and not the name?
Untitled-13.jpg
0
 
edster9999Commented:
The number is the IP that it points at.
As it has not been updated in a while it may not be your IP address anymore
check the webpage above (whatismyip.org) to see what your address is from a pc on the network.

Do one thing at a time.  Get the port forwarding thing going first.
you should be able to access it from outside by going to :
http://10.20.30.40:81

(where 10.20.30.40 is the IP address you are given on whatismyip site)

Then when you have this bit working, then work on the dynamic DNS bit to give it a name so you dont have to remember the IP and it doesn't matter if it updates
0
 
arasburnAuthor Commented:
Hi,

No further on :(

I got sent this too, and then I watched all the videos again.

http://dyn.com/support/wizard-js/#camera-dvr-1

I have taken my iPhone off WiFi and tried http://result_from_whats_my_IP:81 and it just goes to a blank screen.

On the link it suggest that IP Cameras have two ports you need to forward.

Very depressing.

Thanks for the help though, sorry took up so much of your time.
0
 
edster9999Commented:
That link is about setting up pot forwarding for generic cameras - not specifically your one so the bit about a second port may or may not be right.

A new idea - go to the router IP address (192.168.1.254) and look for an option that says 'enable uPNP' or something similar to that.  Tick it so it is on.
Test again.
0
 
arasburnAuthor Commented:
Hi,

A friend of mine had a couple of hours on Team Viewer using your notes. He changed the port to 8080 - it seemed to do something for a few seconds then stopped.

He tried my DYNDNS..........

uPnP is turned on. Gutted to be honest as only have today to sort it and I am no further on.

Thanks for the help though...
0
 
edster9999Commented:
Hi - still there ?
A last ditch attempt would be to forward everything to the camera.
That way it is almost as if you are on the internal network.

There is an option on the router.  SOmetimes it is called DMZ computer, sometimes it is called 'Port Forward - All', or 'port forward - default'
Look for this and set it to go to the camera IP.
This means all ports on the outside public IP will be sent to the camera.

This is not great for security as if there are open ports on the camera it could be a security issue but as we are running out of time it might get you going until you come back and have more time.

Hope this helps.
Ed.
0
 
arasburnAuthor Commented:
Thanks for in-depth response, very kind. We were still unable to resolve the issue but fortunately now got it fixed with help from a friend.
Thanks again
0

Featured Post

Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

  • 30
  • 12
Tackle projects and never again get stuck behind a technical roadblock.
Join Now