• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 8630
  • Last Modified:

Create a NLB cluster between two Win2k8 R2 servers in a workgroup

Hi!

We have two Windows 2008 R2 Servers located in a DMZ. They are not joined to a domain and reside in a workgroup named "PROXY".

We would like to create a Network Load Balancing cluster using the built-in feature in windows server (Network Load Balancing Manager).

Both servers are provided with two physical NIC's and are not virtualized in any way.

Server A:
- NIC #1 is given a static IP (i.e 192.168.2.10)  with gateway 192.168.2.1 and only provided with my ISP's DNS.
- NIC #2 is left in DHCP mode.

Server B:
- NIC #1 is given a static IP (i.e 192.168.2.11)  with gateway 192.168.2.1 and only provided with my ISP's DNS.
- NIC #2 is left in DHCP mode.

When I create a new cluster from Server A using the NLB Manager (logged in as local Admin) I add "ServerA" and choose to add NIC #2 to the cluster. I do not assign a dedicated IP. Finally I provide the IP for the cluster (i.e 192.168.2.100) and assign the full internet name (i.e cluster.domain.com). I select Unicast and finish the wizard using the default settings for port rules.

I then get an error message saying "The inferface is misconfigures" and when i click the error message i get more information: "Cluster IP address (192.168.2.100) not added to TCPIP properties".

The next error message on the line below reads: "The bind operation was successfull but the NLB is not responding to queries" with additional info:
-----------------
Starting update...
Going to bind NLB...
Bind operation succeeded.
Error reading cluster configuration
Update failed with status code 0x8004100a.
-----------------

All help greatly appreciated :)
0
cegeland
Asked:
cegeland
  • 5
  • 5
1 Solution
 
Vinod PawarIT Core Computing AdvisorCommented:
First change DHCP address for both to static ( Best practice)
also hope your gateway IP address is reachable .
on first server create NLB cluster with cluster.domain.com and 192.168.2.100
 and add first host in it and then try to add second one.
if error persist add 192.168.2.100 as secondary IP in Second Nic card of second server server
which you will be going to add
0
 
cegelandAuthor Commented:
Thanks for your suggestion. However the problem still persist.

Server A:
- NIC#1 is static 192.168.2.10 with gateway 192.168.2.1. ISP DNS set as primary/secondary.
- NIC#2 is now also static 192.168.2.20 with gateway 192.168.2.1 (seems do dissappear after I set it - next time I open TCP/IP protocol the gateway field is blank). No DNS set.

Server B:
- NIC#1 is static 192.168.2.11 with gateway 192.168.2.1. ISP DNS set as primary/secondary.
- NIC#2 is now also static 192.168.2.21 with gateway 192.168.2.1 (same behavior as Server A regarding the disappearing gateway). No DNS set.

I am able to ping the gateway 192.168.2.1 from both the servers. I still get the same error when I create the cluster (192.169.2.100 - cluster.domain.com) on Server A and adding 192.168.2.100 as a secondary IP on Server A NIC#2 does not make any difference.

Note that this error occurs when I try to add the first host (Server A). If I try to add Server B to the cluster (from NLB manager on Server A) i get the same error in addition to the one existing for Server A.
0
 
cegelandAuthor Commented:
Does anybody know what could be causing this?
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
Vinod PawarIT Core Computing AdvisorCommented:
check this:-
How to create Windows NLB Cluster-

Install First NLB role on each server and make sure both server which need to added into NLB should have 2 nic cards. Name one as private and other as public
 
Suppose private has ip address as 159.199.38.76 don’t give gateway.


Open NLB on one server and
Create New Cluster as any new domain name  ( like ex2010.in.com) and select       same host as primary host of cluster

Select private address
 
Add Cluster IP address
 
Add full internet name and
 
Then click finish
 
So you had added 1st host successfully
Now when you open private NLB address you will find no Gateway address
Just add gateway addres there
 
You will recive warning click on yes.
Then its time to add second host into cluster.
On NLB name Just add second hostname into cluster
0
 
cegelandAuthor Commented:
Thanks for your suggestion. This does not work though.

I have named one connection "Local Area Connection" and the other "NLB". "The Local Area Connection" has a static IP (192.168.2.10) with the gateway specified (192.168.2.1). The "NLB" or "private" as you call it has a static IP (192.168.2.21) but no gateway or DNS specified.

Here's what happens:
1. I create a new cluster - type in the server name (SERVER-A) and select the "NLB" connection.
2. Click "Next"
3. Set "Priority" to "1"
4. Leave the dedicated IP address as is (192.168.2.21)
5. Click "Next"
6. Add a cluster IP address (192.168.2.2)
6. Click "Next"
7. Leave the IP address as is (192.168.2.2). I specify "Full Internet Name" as "fs.domain.com" and select "Unicast"
8. Click "Next"
9. Leave the port rules in default settings
10. Click "Finish"

The computer name is then added to the cluster, but the configuration fails wih a yellow "!" symbol covering the computer symbol. In the log window below I see an error saying "The interface is misconfigured [double click  for details...]".

When I double click to show details I get the additional info saying:
"Cluster IP address (192.168.2.2) not added to TCPIP properties
Dedicated IP address (192.168.2.21) not added to TCPIP properties".

I click "OK" and notice that the next line in the log says "The bind operation was successfull but the NLB is not responding to queries". I double click to show details which presents the following:

"Processing update 1 from "NLB Manager on SERVER-A"
Starting update...
Going to bind NLB...
Bind operation succeeded.
Error reading cluster configuration
Update failed with status code 0x8004100a."

Even if I add the gateway to the "NLB" connection afterwards this does not remove the errors.

I did the exact same thing for my internal NLB cluster, only both the servers were HyperV servers where MAC spoofing was enabled. This worked perfectly. I get this problem on the servers that are supposted to be my proxy NLB cluster. These servers (Server-A and Server-B) are both physical machines with Windows 2008 R2 installed (not joined to domain) residing in a vlan seperated from my internal network. I log in as local admin on Server-A which is the same username/password as local admin on Server-B.
0
 
Vinod PawarIT Core Computing AdvisorCommented:
There is some problem in Nic or NLB is unable to add Secondary IP address on cluster in NIc.
what workaround you can do is .
create NLB with same process
once yellow color warning is shown in TCPIP properties of NLB nic add both IP address
192.168.2.21 and 192.168.2.2
then you can click ok to NLB creation. and check logs.
0
 
cegelandAuthor Commented:
Thanks for your suggestion. I have manually added the IP (192.168.2.21 and 192.168.2.2) to the NLB nic.

Still yellow ! mark and same error message saying the interface is misconfigured. I did create a identical cluster using different IP addresses on the inside network, without problems (they are hosted on HyperV while this cluster on the "outside" is 2 physical servers).

Any settings on the NIC itself that needs to be configured? On the HyperV cluster i had to enable MAC spoofing in order to make it work but I guess that has nothing to do with this?
0
 
Vinod PawarIT Core Computing AdvisorCommented:
there should not be any thing in nic settings. remove IPV6 from Nic configuration or disable from registry. you can check with system logs for yellow color mark of warning.
0
 
cegelandAuthor Commented:
I found this in the system log:

NLB cluster [192.168.2.2]: NLB will not attach to adapter '{9DB22754-AEB5-460E-8B12-9251D024F391}' because it does not support dynamic changing of its MAC address. Replace the network adapter with one which supports that capability.

The servers were installed a few weeks ago: HP ProLiant DL120 G7

So there is no setting that would allow dynamic changing of MAC address?
0
 
Vinod PawarIT Core Computing AdvisorCommented:
try to operate NLB cluster in multicast mode.

To change the cluster operation mode to multicast:
 •
Click Start, click Administrative Tools, and then click Network Load Balancing Manager. You can also open NLB Manager by typing Nlbmgr at a command prompt..


If NLB Manager does not already list the cluster, connect to the cluster.


Right-click the cluster, and then click Cluster Properties.


Click the Cluster Parameters tab, and specify Multicast in Cluster Operation Mode.
0

Featured Post

[Webinar] Database Backup and Recovery

Does your company store data on premises, off site, in the cloud, or a combination of these? If you answered “yes”, you need a data backup recovery plan that fits each and every platform. Watch now as as Percona teaches us how to build agile data backup recovery plan.

  • 5
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now