ubuntu 8.04 samba issues

Posted on 2012-08-31
Last Modified: 2012-09-17
Running Ubuntu 8.04
I replaced a motherboard (not sure if this is a factor???) -- I had an issue with the network card, this has been corrected.  I had to install new drivers --
I installed the latest patches, there were 394 of them
As a result of the issue below, I have uninstalled and reinstalled Samba (I did not delete the directory)

At boot the screen gets stuck at "Starting Samba daemons" for about 10-15 minutes.
It will then continue to boot.

When the GUI is starting, before the icons appear, after about 3-5 minutes, I receive a message:
"There was an error starting the GNOME Settings Daemon.

Some things, such as themes, sounds, or background settings may not work correctly.

The last error message was:

Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

GNOME will still try to restart the Settings Daemon next time you log in."

Everything seems to run fine, less Samba
I can ping the station, but cannot access the shares.
After the GUI starts I run:
sudo /etc/init.d/samba start
 * Starting Samba daemons                                                [ OK ]  
(This starts right away.)
I can now see the shares, but not access them.  Explorer will get "stuck" trying to open the folder. The next time I try to open //server, I cannot see the shares.

I the run:
sudo /etc/init.d/samba stop
 * Stopping Samba daemons                                                [ OK ]
sudo /etc/init.d/samba start
 * Starting Samba daemons                                                [ OK ]
sudo /etc/init.d/samba restart
 * Stopping Samba daemons                                                [ OK ]
 * Starting Samba daemons                                                [ OK ]
(These all run right away, but I cannot access any shares, or see them)

Sometimes, when I run this I get:
sudo /etc/init.d/samba restart
 * Stopping Samba daemons
start-stop-daemon: warning: failed to kill 5093: No such process
                                                                         [ OK ]
 * Starting Samba daemons                                                [ OK ]
(This process will take about 5-10 minutes)

When this happens, the shares function as normal, and will work fine until a reboot.
If I reboot, the sequence will act the same again.
Question by:bmsjeff
    LVL 6

    Accepted Solution

    If the new motherboard isn't the same as the previous one, when you installed the OS, the kernel was compiled with the drivers for all the components of your past motherboard, the change to a new motherboard is the principal fact that your Ubuntu is running slow and having such problems, i suggest reinstalling the system.
    LVL 14

    Author Comment

    what is the best way to go about that?  I am an Ubuntu newbie.  Do I have to start from scratch or can I perform an backup and restore after the new installation?
    LVL 6

    Expert Comment

    by:Ricardo Martínez
    I think the best way is reinstalling from zero the system, backup your info and reinstall it. Another fact can be the new updates you installed, did you check that no samba update where in the list of the 394 new packages? cause maybe some newly installed patches might not be compatible with some of your samba services.
    LVL 14

    Author Comment

    I upgraded to 10.04 and everything is working properly now.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Looking for New Ways to Advertise?

    Engage with tech pros in our community with native advertising, as a Vendor Expert, and more.

    This document is written for Red Hat Enterprise Linux AS release 4 and ORACLE 10g.  Earlier releases can be installed using this document as well however there are some additional steps for packages to be installed see Metalink. Disclaimer: I hav…
    The purpose of this article is to demonstrate how we can upgrade Python from version 2.7.6 to Python 2.7.10 on the Linux Mint operating system. I am using an Oracle Virtual Box where I have installed Linux Mint operating system version 17.2. Once yo…
    To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
    Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

    779 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    11 Experts available now in Live!

    Get 1:1 Help Now