• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 681
  • Last Modified:

Cannot access to the network resource in the same WORKGROUP From a 2008 R2: logon failure

Server: 192.168.44.103 W2008R2 One network connected
Client:  192.168.44.185 XP test VM (is the same with all the machine on the network)

Client SHARES  a folder like \\192.168.44.185\d and \\192.168.44.185\Shared

Both have the SAME Administrator  password.

From SERVER when issued start \\192.168.44.185\d I got
logon failure: bad username or password
The strange is that in the 2008 logon window the domain appears to be the local machine (D7K8N85J) and not the workgroup.

Any suggestion?

Thank you in advance
Francesco
0
_ecpirosis_
Asked:
_ecpirosis_
  • 10
  • 4
  • 2
1 Solution
 
serchlopCommented:
In server 2008 R2, when you try to connect to resources in another computer it try to use the domain user, nevertheless that the user is administrator and the password where the same.

You have to pass the username in the form computername\administrator to say the server that the user has to use is the local computer user.

You can use in a command line or in a bat file

net use \\192.168.44.185\d /user:computername\administrator password

or

net use \\192.168.44.185\d /user:computername\administrator

the difference is that for the first the password is shown in the command line and in the second the command will ask for the password
0
 
_ecpirosis_Author Commented:
Thanks serchlop: but I wish to use the UNC path. How to register that logon for the network resource?
0
 
serchlopCommented:
You can create a bat file with the command net use like I post before and then add it to the startup folder in start menu for the user. This will authenticate to the network resource when the user logon.

Another way is tho cache o save the credential to the network share.

You can edit this credential in control panel - users accounts and in the left menu Manage your credentials. There you can add your network share credential in windows credential.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
ChiefITCommented:
I got to ask.

You have a server right there. Why not use a domain based network???

Now, you have to authenticate per machine:

Servername\Administrator

is different from

Computername\Administrator

HOWEVER:
Domain\administrator
is the same as
Domain\administrator
0
 
_ecpirosis_Author Commented:
@ChiefIT: thanks for the question: we cannot use a domain network, it is an heterogeneus lan with several thirdy part closed computer and the only requirements are ip, some shared resources and user and password that can access them

@serchlop: unfortunately now I got the error 86 the specified network password is not correct  (I am logged on both with the same password!!)
 
To summarize:
computer A name D7K8N85J  ip 192.168.44.103  user administrator
computer B name EMH           ip 192.168.44.185  user administrator
computerB shares d and shared ( I directly access them form other computers without problems.)

same password for both.
The command is from computer A:
net use  \\EMH\d /user:EMH\administrator

Thanks for your patience
Have a good we
Francesco
0
 
ChiefITCommented:
Using this implies your Netbios is working. Netbios is fickle and configured per computer basis.

\\EMH\d

Try instead using the IP: \\192.168.144.185\d$

d$ is the admin share and will be inaccessible to all except the local administrator. Using the IP address bypasses NetBIOS, and DNS resolution to change the Hostname or Fully Qualified Domain name to an IP address>Examples:

\\EMH\d$    (uses Netbios naming in the URL path)
\\EMH.domain.com\d$    (uses DNS naming convention in the URL path)
\\192.168.144.185\d$  (uses ARP to direct traffic to a final MAC address within the URL path)
0
 
_ecpirosis_Author Commented:
@ChiefIT: I tried it but i got the error  password error  if i use the machine name I got the error 86 I mentioned above (really strange!).


@serchlop: I hav'not yet tried to save credential as you suggest but I have a "news":

downloading this iso
magnet:?xt=urn:btih:YE3Y26JFPKQZJNXQYUXUR4UKCWSZF27L&dn=MICROSOFT.WINDOWS.SERVER.2008.R2.FOUNDATION.RTM.WITH.SP1.X64.OEM.ENGLISH.DVD-WZT

I installed  (on VirtualBox) a perfectly working copy of the Dell machine W2008 server R2 that   whitout doing anything works with  \\192.168.44.185\d
Unfortunately I cannot reinstall the Operating system on this machine and moreover I have to prepare tre of them to be deployed with already licensed Windows/Dell OS.
Could be some Dell strange settings?
Thank you
Francesco
0
 
ChiefITCommented:
password error:

A password error is just as it says. You are mapping correctly using the IP address:

\\192.168.144.185\d$

Now that the map is correct, you need to use the right username and password. Since this is not a domain based network, you have to use the computername with the user to authenticate with. You see, authentication username and passwords on a peer-to-peer network are stored on each computer...

As an example: Let's say you are accessing the file share on a computer called ComputerA and your administrator username is "administrator"..

Here's how you map the share and authenticate:

Map the share to: \\192.168.144.185\d$  (The D drive of computer A)

Check the box to "USE ALTERNATIVE CREDENTIALS"

Now, use the username of: \\ComptuerA\Administrator
and the password of: (that administrator's password)

---------
Explained differently:

(peer to peer networks, or workgroups)
ComputerA\Administrator (does not equal) ComputerB\Administrator

(Domains)
Domain\Administrator == Domain\Administrator
0
 
_ecpirosis_Author Commented:
@serchlop: I tried just now to save and edit credentials in this form:

internet or network address 192.168.44.247
user  EMH\Administrator or Administrator or D7K8N85J\Administrator

I always got logon failure: unknown user or bad password

really strange: it seems to be so promising! Any other suggestion?
Thank you
Francesco
0
 
_ecpirosis_Author Commented:
@ChiefIT: that's exactly where we started.
the result of map command
    net use z: \\192.168.44.185\d  /USER:EMH\Administrator

is

System error 86 has occurred.

The specified network password is not correct.

as the first try serchlop advised.

Thank you for your patience
Frrancesco
0
 
_ecpirosis_Author Commented:
Just to clarify:
System error 86 has occurred.

The specified network password is not correct.
is the result of:
net use z: \\192.168.44.185\d  /USER:EMH\Administrator
net use z: \\EMH\d  /USER:EMH\Administrator
net use z: \\192.168.44.185\d  /USER:192.168.44.185\Administrator
net use z: \\192.168.44.185\d  /USER:Administrator

About the alternative credentials the problem is thet on 2008 I ALWAYS got the name of the server as domain ...
0
 
ChiefITCommented:
You are not providing a password to any of your mapped drives within your script. When you use the /User:... switch, you should also provide a password.

To make sure there is nothing else wrong, you should follow the GUI way of mapping. I will look up the means to edit the script to provide a pssword. I believe there should be another switch, like  /Password:abcdefghijk after selecting the user.

Anyway, here is the GUI means to map a drive using alternative credentials:
http://compnetworking.about.com/od/windowsxpnetworking/ht/mapnetworkdrive.htm
0
 
_ecpirosis_Author Commented:
@ChiefIT  after each line the system  asks the password even if I can use it in this form  
net use z: \\192.168.44.185\d  /USER:192.168.44.185\Administrator pippo

I got the same error.
 
If I try net view \\192.168.44.185 I got error 5 access denied


Now the situation is:
I have the first W2008R2 that does not uses UNC resources but I have a second one that uses it !!! (I asked to the costomer also the next server to prepare).

Same hardware same operating system version and same programs installed, same updates: the role servers installed for both is 0 the features installed for both is 0: any suggestion?
0
 
_ecpirosis_Author Commented:
Performing a more deep comparison on the PC that is working
the key HKLM\System\CurrentControlSet\LanmanServer\Linkage
uses   \Device\Smb_Tcpip_  (and also in lanmanworkstation)

instead the not working PC
uses \Device\Tcpip_

For sure I have not changed them.
How I can set the same \Device\Smb_Tcpip_    device?
Thnks Francesco
0
 
_ecpirosis_Author Commented:
Solved by

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2003_Server/Q_27115884.html

When I set on the non working machine this key EVERYTHING started immediately to work:

Network security: LAN Manager authentication level
Set to Send LM & NTLM responses only

Now: start \\192.168.44.185\c$  or start \\192.168.44.185\d works perfectly.
Thanks for your efforts
0
 
_ecpirosis_Author Commented:
The question <br /><br />http://www.experts-exchang<wbr />e.com/OS/M<wbr />icrosoft_O<wbr />perating_S<wbr />ystems/Ser<wbr />ver/2003_S<wbr />erver/Q_27<wbr />115884.htm<wbr />l<br /><br />it was refferred to a 2003 Server but works perfectly for 2008R2. <br />the "mistery" is: two apparently identical PCs same hardware same w2008r2, same windows update BOTH set  ter setting Network security: LAN Manager authentication level to NOT DEFINED one works and the other not. On the not working one after setting Network security: LAN Manager authentication level<br />to  "Send LM & NTLM responses"  solves the problem.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 10
  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now