VM not seeing network computers

Hi!
Host puter is Mac OS X.  I'm running VMWare with a Windows 7 VM.  That Mac can see the other network pc and the shared printer.  Problem is that the Win 7 VM can NOT.  I've verified that network discovery is on and file and printer sharing is on.  All pc's have the same workgroup name.  When I browse for network computers on the VM it only sees itself.  Any ideas?  I'm new with using VMWare.  Thanks.
PCGalOfCalAsked:
Who is Participating?
 
leuqarteConnect With a Mentor Commented:
Is network adapter in VM settings configured to NAT? try changing to bridged
0
 
ApothisCommented:
Can your VM get to the internet?
0
 
TunerMLSystems EngineerCommented:
Network browsing is always a problem maker, is the browsing service enabled in the Windows 7 VM, can you ping or use other network services, is it just the browsing that is not working?
0
Will You Be GDPR Compliant by 5/28/2018?

GDPR? That's a regulation for the European Union. But, if you collect data from customers or employees within the EU, then you need to know about GDPR and make sure your organization is compliant by May 2018. Check out our preparation checklist to make sure you're on track today!

 
ApothisCommented:
Additionally, if your VM has a fake IP from VMWare, and isn't getting a real IP from the subnet your other devices are on, you will not be able to see them with network discovery.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)Connect With a Mentor VMware and Virtualization ConsultantCommented:
Switch your Virtual Networking in the VM to BRIDGED MODE.
0
 
PCGalOfCalAuthor Commented:
VM is on the internet, no problem. I will try posted solutions in a little bit.  Thank You!
0
 
PCGalOfCalAuthor Commented:
I switched to bridge mode and then I was able to see the other workstation on the network.  However, I'm getting an ip conflict error.  I'm doing this remotely and it keeps kicking me off and I keep having to restart the VM after having to log back in remotely.  It's getting time consuming.   Any suggestions to fix this while I'm still remote?  
THANK YOU!
0
 
PCGalOfCalAuthor Commented:
dang it.  I gave the VM a static ip and i still got disconnected while trying to install a remote printer.  :(
0
 
PCGalOfCalAuthor Commented:
I don't know why, but after several attempts and restarts it finally started working.  Now I'm having a printer issue with a printer that is directly connected via usb to the iMac (host).  When I do an install of the printer on the VM, it finds the printer (as a network printer) and adds it as printer with a LPT port.  Is that normal?  When I try to print from the VM, it won't print.  Suggestions?
0
 
PCGalOfCalAuthor Commented:
thank you.
0
All Courses

From novice to tech pro — start learning today.