• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1774
  • Last Modified:

AIX, and adapter device

I did the following:

                                                                           
# lslpp -l | grep a2191007df1033e7  
#
#                                            
# lsdev -Ccadapter                                                              
lsdev: 0514-521 Cannot find information in the predefined device                
        configuration database for the customized device ent0.                  
lsdev: 0514-521 Cannot find information in the predefined device                
        configuration database for the customized device ent1.                  
ent0   Defined   01-00 N/A                                                      
ent1   Defined   01-01 N/A                                                      
ent2   Available       Virtual I/O Ethernet Adapter (l-lan)                     
ent3   Available       Virtual I/O Ethernet Adapter (l-lan)                     
usbhc0 Available 02-08 USB Host Controller (33103500)                           
usbhc1 Available 02-09 USB Host Controller (33103500)                           
usbhc2 Available 02-0a USB Enhanced Host Controller (3310e000)                  
vsa0   Available       LPAR Virtual Serial Adapter                              
vscsi0 Available       Virtual SCSI Client Adapter                              
#                                                                               
#    

Open in new window

                                                                         

So AIX can see en2 and en3, not en0 and en1, and it does not have a driver

So I ran the command cfgmgr -i /dev/cd0, it ran, and the command produced the following
output (partial listing)

--------                                                                        
  Filesets listed in this section failed pre-installation verification          
  and will not be installed.                                                    
                                                                                
  Missing Filesets                                                              
  ----------------                                                              
  The following filesets could not be found on the installation media.          
  If you feel these filesets really are on the media, check for typographical   
  errors in the name specified or, if installing from directory, check for      
  discrepancies between the Table of Contents file (.toc) and the images that   
  reside in the directory.                                                      
                                                                                
    devices.pciex.a2191007                                                      
    devices.pciex.a2191007df1033e7                                              
    devices.pciex.df1033e7                                                      
    devices.pciex.ethernet                                                      
    devices.pciex.pciex19a2.710.10df.e733.2                                     
    devices.pciex.pciex19a2.710.2                                               
    devices.pciex.pciexclass.000200                                             
    devices.pciex.pciexclass.020000                                             
                                                                                
  << End of Failure Section >>                                                  
                                                                                
#               

Open in new window

                                                               

So the driver I want is missing from the AIX installation disk

Any ideas on what I should do next ?

Thanks
0
Los Angeles1
Asked:
Los Angeles1
  • 2
1 Solution
 
woolmilkporcCommented:
How old is your installation DVD? Is it one of the first ones issued, still at AIX 7.1 TL0?

The required device support came with AIX 7.1 TL1 (or AIX 6.1 TL6).

So if you have a newer Base DVD, or a medium or a repository containing TL1 or later of AIX 7.1 use this one.

It must contain this file:

devices.pciex.a2191007df1033e7.7.1.0.0

maybe suffixed with ".I":

devices.pciex.a2191007df1033e7.7.1.0.0.I
0
 
woolmilkporcCommented:
Just an idea: Maybe your PowerVM DVD will do!

Or perhaps you have a CD labelled "Additional Device Drivers"?
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now