?
Solved

Companyweb Calendar Credentials

Posted on 2012-09-03
23
Medium Priority
?
1,274 Views
Last Modified: 2012-12-08
Afternoon!

I was wondering if you all could help me solve and issue I'm having with the Companyweb calendar and Outlook 2010.  Let me explain what I've done to give you head start, big picture.

Both servers are running SBS 2011 Standard.

In an effort to become more efficient (yeah, right), I added the companyweb calendar to Outlook 2010 via the following method.  While NOT on the domain where I am connecting the sharepoint calendar, I:
opened https://remote.targetcompany.com/
signed in
clicked our Internal Website
typed in my username and password (why? since I've already signed just one step ago)
clicked on Calendar to the left
clicked on Calendar at the top under Calendar Tools
clicked Connect to Outlook
clicked No when asked about viewing only secure content (another annoyance)
clicked Allow
entered my username and password AGAIN
Wahlah...it appears in Outlook under Other Calendars/Companyweb - Calendar

Now, that's just to connect to my workplace calendar that I'm interested in.  I am not interested in connecting to the calendar on my home server also running SBS 2011 Standard (I think also called SBS Standard 2008 R2); we'll get to that in a sec.

Everything works fine until I close Outlook.  When I re-open, I have to put in my username and password to BOTH companyweb.homecompany.local (which I don't even want showing) and remote.targetcompany.com.  Even when I place a checkmark in remember password, it doesn't.

I know Outlook is looking for http://companyweb per the error message I receive saying the Sharepoint list Companyweb - Calendar cannot be found.  An alternate Web address to this SharePoint site will be attempted.  That explains why it looks to my home server's username and password and then to my company's.

The goals is to add the targetcompany calendar to Outlook and not have to type in passwords each time I close and re-open.  I don't want Outlook to even try to connect to homecompany.

How do I accomplish this?  As I add this feature to my remote users, I don't want them to have to type in a password each time they close and re-open their Outlook.  I would rather not have to automatically connect via VPN to accomplish this as well.

Thoughts?

Thanks!

Rexx
0
Comment
Question by:rexxnet
  • 11
  • 10
21 Comments
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 38375821
This is fairly simple to fix.  The calendars did not get listed in Outlook automatically.  They can only get there if you navigate to the SharePoint web site and select "Connect to Outlook" from the Calendar Tools menu on the Calendar page.  The problem exists because both were probably added by navigating to http://companyweb at each location.

So first you need to undo what has been done.  Open Outlook and select CALENDARS from the left side menu.  Locate the SharePoint calendars and right click each of them and select DELETE.  This will only delete the link in Outlook, not the actual SharePoint calendars.

Then, you need to clean up your network passwords.  Click Start and type "Manage Network Passwords" in the search box and then hit enter.  This will open the Credential Manager.  Go ahead and delete any credentials which are related to either of your SharePoint sites.

Once all that is cleaned up, you can now add the targetcompany calendar back to Outlook.

To do this, open up the targetcompany companyweb site with it's FULL URL rather than with http://companyweb.  The FULL URL will be something like https://remote.targetcompany.com:987 

Once that is open, navigate to the Calendar page and then click the "Add to Outlook" button.  This should now prompt you for credentials which you can save, and you won't have to enter them again.

Jeff
TechSoEasy
0
 

Author Comment

by:rexxnet
ID: 38421850
What a long time since my post.  I'm sorry, Jeff.

I've cleared out every password in my Manage Network Passwords and followed the instructions to the letter.  I connect the calendar, it initially asks me for my username and password, I enter domain\username and then the password, check remember password and it goes away and the calendar appears.  That's GREAT!  

However, when I close outlook and reopen, it ask for for username and password for homecompany.local rather than just going to targetcompany.local.  

Does it have to be setup on the domain where I am connecting first to avoid this?  Doesn't seem like it should have to.
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 38424166
and followed the instructions to the letter.

Well... not really.

My instructions were that you needed to use the FULL URL (which, as the example shows is NOT a .local domain, but rather a routable TOP LEVEL DOMAIN NAME).

So when you say "I connect the calendar", how are you accessing the SharePoint site?  Do not use Remote Web Workplace/Access, as these use redirects which will not give you the full URL.

Jeff
TechSoEasy
0
 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

 

Author Comment

by:rexxnet
ID: 38424697
Yes. I use https://remote.target.com:987

I then click on calendar on the left and then click calendar near the center and then connect to outlook and follow the prompts.
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 38425641
Okay... let me ask this... on the calendar you added, are there two dashes in the name?  (ie, "Name - companyweb - calendar")?

Jeff
TechSoEasy
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 38425649
Actually... I just tested this with my Outlook and I seem to have a similar problem.  I'm going to play around with the configuration for a bit and will get back to you shortly.

Jeff
TechSoEasy
0
 

Author Comment

by:rexxnet
ID: 38426158
Thanks, Jeff.  And, yes.  It does have Companyweb - Calendar.  In the advanced settings, you can rename it; but, that doesn't help.  It looks to http://companyweb first, then fails, THEN tries the alternate https://remote.targetcompany.com....... that we're trying to acheive.  That's where I want to have it look first.  

Thanks for your persistence.
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 38431719
As I said above,  I'm getting the exact same issue when I connect a SharePoint list from another domain to my Outlook.  I hunted around a bit for some answers and found some which say it didn't happen when they were using Outlook 2007.  I might try that just to see if I can narrow down the problem.

This has made me curious enough to figure out why its not holding the credentials though.

Jeff
TechSoEasy
0
 

Author Comment

by:rexxnet
ID: 38447077
It's driving me bonkers.  I've been on a cruise this week and havent had time to even worry with. Back to the real world again!  Hopefully we'll be able to figure it out soon!
0
 

Author Comment

by:rexxnet
ID: 38587629
Any new ideas?
0
 
LVL 74

Accepted Solution

by:
Jeffrey Kane - TechSoEasy earned 2000 total points
ID: 38587900
Hi rexxnet --

So sorry for the delay in responding, but I do believe I've found the solution for this problem.

Add the site of the additional Companyweb to the INTRANET Security Zone of Internet Explorer.

For instance, I added https://remote.domain.com and then added the calendar from https://remote.domain.com:987 to Outlook and it no longer prompts me for the password.

Jeff
TechSoEasy
0
 

Author Comment

by:rexxnet
ID: 38594104
I'm still working on that.  It may have worked.  I had it pop up on me the other day and wondered why.  I know what they system is doing.  I just wish there was a way to tell it to look to another address.  Outlook is looking at http://companyweb FIRST, then, failing and going to what I want it to look for.  Even though I add the calendar as you suggest through https://remote.domain.com:987, Outlook is still looking to http://companyweb first.

Any thoughts on that one?

Thanks for sticking in there with me.

Rexx
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 38605837
I do see that it is requesting http://companyweb first before going to https://remote.domain.com:987, but it does seem to work overall, right?

Jeff
TechSoEasy
0
 

Author Comment

by:rexxnet
ID: 38608778
I still get requests for passwords now and again.  Not sure what's going on.
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 38609567
Can you verify that you only have Office 2010 installed and no remnants of a previous version?

Also, be sure that the SharePoint Stssync Handler is enabled in Internet Explorer's Add-ons.  If it already is enabled, disable, restart IE and re-enable.

If still getting the issue, be sure that Microsoft SharePoint Foundation Support is installed in the Office Installation Options (listed under Ofice Tools).

FYI, I'm currently running Outlook 2013 on Windows 8 and am no longer getting any prompts for a 2nd or 3rd domain's Companyweb calendar attached to Outlook.

Jeff
TechSoEasy
0
 

Author Closing Comment

by:rexxnet
ID: 38650634
I'm thinking this is the best it's going to get using the Intranet Zone.  The system still goes and looks to http://companyweb first.  I no longer get the pop-up asking for a username and password after entering what you suggested in the Intranet Security Zone.  

I still get the error message and that an alternate Web address for this site will be attempted.  The data on the SharePoint calendar is correct, though.

Thank you for your help.
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 38651994
FYI, you could add a line to your computer's HOST file that points companyweb to the actual public IP.

Jeff
TechSoEasy
0
 

Author Comment

by:rexxnet
ID: 38653200
Thanks, Jeff.

Could you please show me the line to do that?  

Rexx
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 38665655
It's rather simple, just add the following line to the bottom of your HOSTS file (in C:\Windows\System32\Drivers\etc):

12.34.56.78      companyweb

(where 12.34.56.78 is the actual public IP of the remote SBS).

Jeff
TechSoEasy
0
 

Author Comment

by:rexxnet
ID: 38666855
will that mess anything up if I am on two difference servers?  One at home, one at work.  Both running SBS 2011 Standard.
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 38671889
Well, it would make http://companyweb always go to the IP noted in the HOSTS file.

If that's a problem, then either don't make this change, or depending on how you use your SharePoint calendar at home you could always access that one via http://companyweb.homedomain.local

Jeff
TechSoEasy
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article lists the top 5 trialware OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their Exchange server is no longer available or other critical issues with Exchange server or impo…
Take a look at these 6 Outlook Email management tools which can augment the working and performance of Microsoft Outlook to give you a more rewarding emailing experience.
Get people started with the process of using Access VBA to control Outlook using automation, Microsoft Access can control other applications. An example is the ability to programmatically talk to Microsoft Outlook. Using automation, an Access applic…
CodeTwo Sync for iCloud (http://www.codetwo.com/sync-for-icloud?sts=6554) automatically synchronizes your Outlook 2016, 2013, 2010 or 2007 folders with iCloud folders available via iCloud Control Panel. This lets you automatically sync them with…
Suggested Courses

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question