[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 456
  • Last Modified:

SharePoint 2007 and Credentials when Opening a Document

I have an single SharePoint 2007 server set up in a DMZ with a connection back to a SQL server inside the firewall.

I have a Shared Documents library set up that is having lots of documents uploaded to it which others are then having to open, manipulate, etc.  

I have received the complaint that the users do not like having to enter their SP credentials each and every time they open a new document.

I have read a work around to have the user open a document (enter their credentials) close the document, but not the application.  This of course works for some but not others and I don't know why.

I am a real beginner in administration of SharePoint and didn't know if there was something that I could change to make it so that this was not so tedious.  The user accounts are set up locally on the box and then given permission to the sites they need and as well as have profiles established if they need to receive emails.  (Just details that I thought I should provide to help troubleshoot).

Thank you for any help that you can provide.
0
mounty95
Asked:
mounty95
1 Solution
 
Justin SmithSr. System EngineerCommented:
Couple of things could cause this issue.

1. Not having Alternate Access Mappings properly set for the web application.  If users are accessing a web app with a URL not registered on the web app, it can cause problems.  Just verify in Central Admin - Web App Management - Alternate Access Mappings

2. There has always been a bug between certain OS and Office versions with SharePoint 2007.  In these cases, the following registry edit must be made:  http://support.microsoft.com/?id=943280
0
 
mounty95Author Commented:
1.  I am not sure how the mappings are supposed to be set up.  I have four Internal URLs set up for the Default Zone.  I have read information in the SharePoint 2007 Bible on this and it doesn't make sense to me how I should set this up.  So to say that the URL mappings are not set up right.  I am not sure how they should be.  I can say that the users can access an Internal review in the default zone that is mapped to a Public URL for Zone.

2.  I am wondering whether the fact that some users are using Office 2010 and the SharePoint server is 2007 could possibly be the problem.

Any further clarification that you can make on the Alternate Access Mappings would be greatly appreciated.
0
 
Justin SmithSr. System EngineerCommented:
For your setup, as long as the URL that users are accessing your site with, is registered as an internal URL (with the matching public URL), you should be fine.  Please double check that if you are using https, it says so in the mapping.

I would do a test on one of the users with the problem, make the registry change on their machine, see if it fixes the issue.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
mounty95Author Commented:
The URL that users are accessing my site with is registered as an Internal URL.  I do not use https so that is not an issue in that everything registered is simply http://.

I will try the registry change and get back to you.

Thank you for the quick response.
0
 
martushaCommented:
Also you can add site into local intranet zone in user's browser (Internet options->security tab->local intranet->sites->add site to this zone), if for some reasons it is not detecting automatically.
0
 
Shailendra_karveCommented:
On the user machine in internet explorer add the site in trusted zone
Then later in the custom level select the option "Automatically logon with the current username and password"
Check if this works.
0
 
mounty95Author Commented:
So two things to add to this solution:
1.  If you add the site under Trusted Sites you can't then add it under Intranet Sites and this isn't even an Intranet Site to be able to add so adding to Trusted Sites works.
2.  Using Google Chrome instead of Internet Explorer or Firefox eliminated the credential prompting all together (once you had logged into the SharePoint site initially).
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now