[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Failing to Install FOG 0.32 on Ubuntu 12.04

Posted on 2012-09-04
3
Medium Priority
?
1,625 Views
Last Modified: 2012-09-12
I have been using FOG to deploy systems for about two years now. I have one FOG server fully and reliably functioning in our main office. A second FOG server, from our branch office, recently began behaving unreliably. Rather than troubleshoot multiple intermittent problems, I decided to simply reinstall Ubuntu and FOG. The hadware on the server has all been tested with QuickTech pro.
  Here is the problem:
Ubuntu installs successfully every time.
I successfully run the "cd /opt/fog_0.32/bin" command.
When I try to run the "sudo ./installfog.sh /opt/fog_0.32/bin" to run the installer, I am prompted for the password. I type it in and receive the error "command not found".
I am returned to a command prompt.
From that point forward any command I use in the terminal results in "command not found" or"permission denied". This includes cd.

I have tried a clean install of Ubuntu 11.04 (which is what we run on the reliable server in the main office) . The results are the same.
I have done scores of successful FOG installs on Ubuntu without ever running into anything like this. I am at wit's end.  Please advise.
Thank You.
0
Comment
Question by:csialbany
  • 2
3 Comments
 
LVL 11

Expert Comment

by:legolasthehansy
ID: 38364061
It could be your installer is not able to find commands on a certain path? Is your FOG environment variables set? I haven't used FOG but the errors are more likely to be with your Environment variables.
0
 

Accepted Solution

by:
csialbany earned 0 total points
ID: 38376849
I found that what I needed to do was download a new copy of the installer and unpack it to a location other than /opt....

I still have no idea why I had to do that on this machine and never before on another, but this particular part of the problem is solved.
0
 

Author Closing Comment

by:csialbany
ID: 38390121
I was able to solve this aspect of the problem on my own after all.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Are you looking to recover an email message or a contact you just deleted mistakenly? Or you are searching for a contact that you erased from your MS Outlook ‘Contacts’ folder and now realized that it was important.
Google Drive is extremely cheap offsite storage, and it's even possible to get extra storage for free for two years.  You can use the free account 15GB, and if you have an Android device..when you install Google Drive for the first time it will give…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses

873 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question