Microsoft Exchange 2003 and Active Sync

Posted on 2012-09-04
Last Modified: 2015-03-19
We have Exchange 2003 in a cluster mode. We have service pack 2 and Version # 6.5, Build 7638.2.
We have active sync configured and its working fine for our IOS devices. but sometime user gets a message on their iphone that cant get an email and that person keep on getting the same message if he is pressing the  refresh button.

I checked the event viewer and every time that happened i got an error message in event viewer as below:
Event Type:      Error
Event Source:      Server ActiveSync
Event Category:      None
Event ID:      3005
Date:            9/4/2012
Time:            5:07:45 PM
User:            Domain\username
Computer:      ComputerName
Unexpected Exchange mailbox Server error: Server: []
 HTTP status code: [503]. Verify that the Exchange mailbox Server is working correctly.

For more information, see Help and Support Center at
Question by:amitbhardwaj100
    LVL 10

    Expert Comment

    From googling the event ID it's possibly a permissions issue or misconfiguration...
    You can try this one first

    If that doesn't help this was another KB someone mentioned fixing their issue
    LVL 17

    Assisted Solution

    by:Brad Bouchard
    Just for giggles, try this:

    Make sure to select to manually put the domain settings in and check all 3 checkboxes at the bottom.  Let me know the results.

    Also, 503 usually does indicate permissions issues and I would check IIS to ensure nothing has changed on any virtual directories.
    LVL 1

    Author Comment

    I am not getting 503 error message all the time. its only few times. most of the time Active Sync is working, its only some time a day user gets "cannot get email" error on their devices and i got the 503 Active sync error on event viewer on exchange.
    so what i am thinking it might not be a permission issue but maybe some tweaking of IIS.

    Any information will be highly apperciated.

    LVL 1

    Author Comment

    Any suggestion Experts...
    LVL 76

    Accepted Solution

    Please have a read through my article and check your IIS settings to make sure they are optimal.

    If you make changes - visit the test site mentioned and re-run the test.

    Fix any errors and if you still have problems, then updating the version of massync.dll may be an option that helps.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    How your wiki can always stay up-to-date

    Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
    - Increase transparency
    - Onboard new hires faster
    - Access from mobile/offline

    Email statistics and Mailbox database quotas You might have an interest in attaining information such as mailbox details, mailbox statistics and mailbox database details from Exchange server. At that point, knowing how to retrieve this information …
    Set up iPhone and iPad email signatures to always send in high-quality HTML with this step-by step guide.
    In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
    how to add IIS SMTP to handle application/Scanner relays into office 365.

    759 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    14 Experts available now in Live!

    Get 1:1 Help Now