Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Server 2008R2 Blue Screens and Reboots Upon Logon

Posted on 2012-09-04
18
Medium Priority
?
725 Views
Last Modified: 2013-04-17
We have a virtual machine running Server 2008 R2 that is setup as a file server on one of our sites. A couple of days ago after applying patches in the evening the next morning we discovered that the server reboots when support personnel log on to the box either with a domain or local account. Apart from patches being applied the VMware Tools version was also being upgraded around the same time and for some reason this was never successful even after numerous attempts in the past. What I have done is boot up the server to the login prompt and advised support personnel not to login. These way resources are still available to end users and we can connect to the server with limited functionality from other servers without causing it to restart but only via the Computer Management console. Attached is a mini dump file. Thanks in advance for the responses.
090412-26203-01.dmp
0
Comment
Question by:OSLEE
  • 7
  • 5
  • 3
  • +3
18 Comments
 
LVL 8

Expert Comment

by:RGRodgers
ID: 38366438
Check the event log in computer management to see what errors are being thrown.  Can it be booted into safe mode?  ...RG
0
 
LVL 10

Expert Comment

by:pclinuxguru
ID: 38366486
I was going to ask about safe mode too...

Are you able to remote desktop in with one of the accounts without it blue screening?

It's possible the failed VMware updates caused a change in the virtual hardware and the drivers need updating or reinstalled. Hopefully safe mode works though.
0
 

Author Comment

by:OSLEE
ID: 38366599
Yes I am able to boot into safe mode and login successfully without causing the box to restart. I also notice in the system event log that there are a number of failed service related errors. Attached is a dump of the system event logs.
03-05-Sep-2012-System-Log-Files.txt
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 24

Expert Comment

by:Nagendra Pratap Singh
ID: 38366608
You should have exported the file to a .evt file for easier reading.

You seem to have issues with VMware tools. Try removing those and reinstalling.
0
 
LVL 125
ID: 38366771
try and remove VMware Tools and see if the issue persists.
0
 

Author Comment

by:OSLEE
ID: 38366982
VMware Tools was removed previously and reinstalled on a number of occassions however installation failed VMware Tools was never successfully deployed.
0
 
LVL 125
ID: 38367009
If removed, or VMware Tools is not installed?

still crashes?
0
 

Author Comment

by:OSLEE
ID: 38370173
Yes. VMware Tools is not installed and it still crashes when someone logs into the box.
0
 
LVL 125
ID: 38370232
are you using roaming profiles?

local or domain accounts?
0
 

Author Comment

by:OSLEE
ID: 38370315
No not roaming profiles and yes we are using domain accounts. I have also logged on using a local account and this also caused the server to BSoD and reboot.
0
 
LVL 125
ID: 38370328
tried RDP and console connections?

have you removed locally stored profiles?
0
 

Author Comment

by:OSLEE
ID: 38370368
Even connecting through RDP and console connectios achieve the same reults.

However I have not removed locally stored profiles as I do not see whay this would be the cause.
0
 
LVL 125
ID: 38370394
the contents of the profile loaded into the hive could be the issue.

or try a new account that has never logged onto this server.
0
 
LVL 10

Accepted Solution

by:
pclinuxguru earned 1500 total points
ID: 38370500
If that fails you could always use msconfig to narrow it down.
Start - run - msconfig
Click the start up tab and click the "Disable All" button.
Then click on the "services" tab and do the same
Reboot and it should resemble safe mode.
Login and see if it crashes. If its doesn't crash go back into msconfig and under services click the enable all so everything is rechecked.... Then click the "hide microsoft services" then click disable all again.
Reboot and see if it crashes...
If it doesn't then you can re-enable the third party services... Msconfig - services - enable all
Reboot and see if it crashes.
If not then onto the startup tab. Enable a few at a time and reboot.

During this process it will eventually blue screen giving you an idea of what is causing it.
For instance if it blue screens after you enable the 3rd party services then you would disable them and re-enable a couple at a time until you find the one that is causing it. Same with startup tab.

When you find it write it down and leave it uncheck and continue on until all the stuff that can be enabled without causing the bsd is enabled.

Post what you find.
0
 

Author Comment

by:OSLEE
ID: 38378322
After starting up and logging in via safe mode and hiding all Microsoft services (in msconfig) then disabling all third party and startup services and rebooting into normal mode I could login successfully. I later enabled the third party services a few at a time and rebooted and it has never blue screened again even after all third party and startup services were enabled in msconfig. I also noticed that after logging in successfully in normal mode a patch was prompting to be deployed however after a closer look it had a failed status. The server has been up and running for two days now without any re-occurrences of the issue. I will give it another two days before I close out this thread and assign points.
0
 
LVL 10

Expert Comment

by:pclinuxguru
ID: 38378388
Huh... Stranger things have happened.
0
 

Author Closing Comment

by:OSLEE
ID: 38402983
After a week of monitoring, the file server has been running stable and has had no re-occurrences of the BSoD random re-boot issue.
0
 

Expert Comment

by:sewellia
ID: 39087002
I have tried all this, booting in Safe mode is ok, but the problem with rebooting at logon continues also after alle services and startup programs are disabled using msconfig. As long as I do not logon, the server is fully operational. (Exchange 2010 server works fine and receives and installs updates)
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article, I will show you HOW TO: Install VMware Tools for Windows on a VMware Windows virtual machine on a VMware vSphere Hypervisor 6.5 (ESXi 6.5) Host Server, using the VMware Host Client. The virtual machine has Windows Server 2016 instal…
In this article will go through how to backup a vPostgres DB from a broken vCenter Appliance and restore to a new vCenter Appliance.
This video shows you how to use a vSphere client to connect to your ESX host as the root user. Demonstrates the basic connection of bypassing certification set up. Demonstrates how to access the traditional view to begin managing your virtual mac…
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…

571 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question