• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2582
  • Last Modified:

Port 443 not opening on Cisco Linksys x3000

Hi,

We have had a new router installed on a site as the previous draytek went down.

However, the port forwarding for port 443 doesnt seem to be working from the router?

I've attached a screenshot of the router port forwarding page.

Now I can RDP, access the router remotely, etc.

I can access OWA locally from the server too.

I have been here http://www.yougetsignal.com/tools/open-ports/ and this is confirming the port is not open also www.testexchangeconnectivity.com is giving the following error;

ExRCA is testing Exchange ActiveSync.
       The Exchange ActiveSync test failed.
       
      Test Steps
       
      Attempting to resolve the host name mail.stratford-solicitors.com in DNS.
       The host name resolved successfully.
       
      Additional Details
      Testing TCP port 443 on host mail.stratford-solicitors.com to ensure it's listening and open.
       The specified port is either blocked, not listening, or not producing the expected response.
        Tell me more about this issue and how to resolve it
       
      Additional Details
       A network error occurred while communicating with the remote host.

router port forwarding screenshot
0
flynny
Asked:
flynny
  • 6
  • 3
  • 2
  • +1
2 Solutions
 
gaurav05Commented:
Hi,

Make Inbound rule  in windows firewall.

you need to create all allow rule for SSL/TLS in windows firewall on Public profile.

After then test it using telnet command..

telnet <hostname>  443

Let us know.
0
 
flynnyAuthor Commented:
sorry you mean an inbound firewall rule on the server?
0
 
gaurav05Commented:
Yes pelase...

check attached scren shot..

you need to go windows firewall advanced settings for this option
ScreenShot002.bmp
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
flynnyAuthor Commented:
Ok, thanks see the attached screenshot

firewall image
However I am still getting a closed response from

http://www.yougetsignal.com/tools/open-ports/

do I need to reset any services, etc?
0
 
gaurav05Commented:
Hi,

1) try to check ssl from your internal network ...using telnet command....on port 443
if its not working it means there is something blocking from your internal lan.

2)  if it is working it means externally your router or other wise your ISP has been
block some traffic on specific port.

If all above would not help... check below settings on network adapter of server

The Configure… button under the Properties of the adapter are now configured as:
·         IPv4 Checksum Offload as Disabled
(the other choices are Rx Enabled, Tx & Rx Enabled, and Tx Enabled)
·         Large Send Offload (IPv4) as Disabled
·         TCP Checksum Offload (IPv4) as Disabled
(the other choices are Rx Enabled, Tx & Rx Enabled, and Tx Enabled)
·         UDP Checksum Offload (IPv4) as Disabled
(the other choices are Rx Enabled, Tx & Rx Enabled, and Tx Enabled)

-Let us know.
0
 
flynnyAuthor Commented:
Hi,

From RDP on the sever I ran telnet with following command

o localhost 443
o 192.168.1.64 443 (ip of the server)

but it simply hangs trying to connect?
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Make sure that the router doesn't have it's own management console configured to use port 443.  Usually it does and you need to change it to something else.

Jeff
TechSoEasy
0
 
flynnyAuthor Commented:
ahh ok.

Any ideas on a linksys x3000?
0
 
flynnyAuthor Commented:
just to add if i telnet from the server

192.168.1.64 23

the telent fails to connect

if i try 443 as the port is seems to be hanging? i.e. just goes blank as though it is trying to connect but failing?
0
 
Rob WilliamsCommented:
I agree with Jeff, most often 443 is used for remote management by default on inexpensive routers.

>>"Any ideas on a linksys x3000? "
Likely on the Administration / management page, under Remote Management Access.  If remote management is enabled, (not the most secure option), make sure access is by http and not https
0
 
flynnyAuthor Commented:
sorry remote management for the router was set to HTTPS but to 8080.

I've changed this to http and it has solved the problem.

Many thanks for the help with this.

finally question though, why would it not open 443 wif 8080 is selected?
0
 
Rob WilliamsCommented:
Basically the router captures all https traffic if it is enabled.  Proper business class routers are more configurable.  I don't mean to be insulting but these are about as inexpensive a router as you can buy.
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
I agree with you that it would seem as though setting the port to 8080 and selecting HTTPS on the remote management configuration should free up 443 for pass-through, but I've seen cases where it doesn't.

FYI, I would highly recommend that you disable remote management as it is a security risk that probably isn't worth taking.

Jeff
TechSoEasy
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 6
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now