Oracle RMAN failing to accept connections on port 5501

We have an in-house oracle applications that we use the RMAN  web interface to manage a monthly tasks deleteing all obsolete and expired backups.

we access the site using  http://<server_name>/5501/em

However this is now giving me an error when it has worked perfectly before.  When i diagnose the issue I get this error message.

The device or resource (<server_name>) is not set up to accept connections on port "5501".

Just wondering if there is anything I can check to aid my diagnosis of the issue.
bronafon_ictAsked:
Who is Participating?
 
slightwv (䄆 Netminder)Connect With a Mentor Commented:
I assume you are using dbconsole and not grid control?

Make sure it is started:  emctl start dbconsole
0
 
bronafon_ictAuthor Commented:
Hi

Thanks for your reply. I started out with your thread and saw this command on an OTN forum as a starting point

So i set the oracle_sid to the production environment

and ran emctl status dbconsole
 to check the status of the console assuming that if it was stopped or started it would let me know.

I got this response from running the command:

OC4J Configuration issue. H:\oracle/product/10.2.0/db_1/oc4j/j2ee/OC4J_DBConsole <servername.domain name_dbname> not
found.
0
 
slightwv (䄆 Netminder) Commented:
>>and saw this command on an OTN forum as a starting point

That's fine but the 'status' isn't what I asked for.  Try to start it and post any errors.

When you say that it used to work and now doesn't:  What changed on the system?
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

 
bronafon_ictAuthor Commented:
Hi

I ran the command to start the console but got exactly the same error as i posted above.  As far as any changes are concerned, none that i'm aware of as last month I managed to use the console perfectly.
0
 
slightwv (䄆 Netminder) Commented:
Is the machine using DHCP?  Oracle likes a static IP address.  Try installing the Loopback adapter and making it the first network connection available.

You might need to recreate dbconsole.

Check out the following link:
http://arjudba.blogspot.com/2008/04/troubleshooting-dbconsole-error-oc4j.html
0
 
bronafon_ictAuthor Commented:
Hi

Thanks for all of your input on this. I'm a bit of a novice when it comes to oracle maintenance so you will have to forgive my stupidity. I decided to go back to the original thread and to determine if the console had started.  first time round i executed a bat file which sets up my environment variables for the porduction database and includes the SET ORACLE_SID command which i think was my first mistake. and this is when i got th error i reported in the second part of the thread

looking at it with fresh eyes i ran this sequence:

cmd.
C:
C:\set Oracle_SID=<prod db>
then ran
emctl start dbconsole
and it said the control was already running.
I got this message.

 ( see attached file).  I'm guessing this is a good thing as the console is running. Does it matter where the start dbconsole command is run from? When i'm on the server and enter the address i get a windows enhanced security window pop up so i have added the web site to a trusted site. still with the same result.
anite-console.docx
0
 
bronafon_ictAuthor Commented:
confirmed service had started had to do a restart of the server for another unrelated issue and checked the URL again and it worked.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.