Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Access 2010 having issue that was resolved in 2007 - Problem between Access 2003 & Access 2007 displaying forms correctly

Posted on 2012-09-05
3
Medium Priority
?
603 Views
Last Modified: 2012-09-30
I had a issue with linked master/child staying stable - found the work around that was working great until I attempted to use it in Access 2010 version - see my previous post.

http://www.experts-exchange.com/Microsoft/Development/MS_Access/Q_27105223.html

this results conflict with 2010 and when i comment out the workaround then the old problem of only 1 record being displayed on the form rears its ugly head again.

Old problem:

'The forms within the AK3 version work perfectly, however not in Ak7.  When I open the form with the multiple subforms in AK3 if functions correctly, but for some reason when the same form/subforms open in AK7 the subform (datasheet view) will only display 1 record when it should be multiple records.  When I view this subform outside of the Main form/Subform it displays the data correctly.  The Query returns the correct records etc.

Does anyone know why this is happening? "

any ideas on a better approach.

Karen.
0
Comment
Question by:Karen Schaefer
  • 2
3 Comments
 
LVL 74

Expert Comment

by:Jeffrey Coachman
ID: 38370481
Perhaps we need to go back then....

What is the reason for having to use code to set the links?

typically the links are set in the properties of the subform, and never needs to be changed...
0
 

Accepted Solution

by:
Karen Schaefer earned 0 total points
ID: 38372724
The recordsource changes hence the linked fields will change and this was the only work aground- I do not have time to redesign the entire forms/subforms - I am in testing phase now - My users will be in 2007 where it seems that my tester are in 2010.  Which is not a company standard, but they can roll back without affecting other work

This all started when the query and tables had all the correct data but the subform would only display the first record in the underlying data source.

I only have less than a week for testing and delivery of the first phase.

thanks,

Karen
0
 

Author Closing Comment

by:Karen Schaefer
ID: 38448349
forced user to use only 2007
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Microsoft Access has a limit of 255 columns in a single table; SQL Server allows tables with over 255 columns, but reading that data is not necessarily simple.  The final solution for this task involved creating a custom text parser and then reading…
Windows Explorer let you handle zip folders nearly as any other folder: Copy, move, change, and delete, etc. In VBA you can also handle normal files and folders, but zip folders takes a little more - and that you'll find here.
Do you want to know how to make a graph with Microsoft Access? First, create a query with the data for the chart. Then make a blank form and add a chart control. This video also shows how to change what data is displayed on the graph as well as form…
Have you created a query with information for a calendar? ... and then, abra-cadabra, the calendar is done?! I am going to show you how to make that happen. Visualize your data!  ... really see it To use the code to create a calendar from a q…

569 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question