• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 432
  • Last Modified:

Exchange 2007 Auto Discover Issues

I have been tasked with fixing the out of office feature on our Exchange 2007 server.  Let me start with giving you a bit of background.  I know the very basics when it comes to Exchange, but as our Exchange administrator left...this is now falling on me. I am trying to get up to speed on it, but every day it has a major problem.  I am starting the question the core configuration.  Anyway...

The OWA is not working.  That was also something that I was working on so I cannot test the out of office in the OWA environment,  When a user tries to turn on out of office in Outlook 2010 this is the error:

Your automatic reply settings cannot be displayed because the the server is currently unavailable.  Try again later.

I have been googling and found that this may be an autodiscover issue.  I don't even know where to locate autodiscover configurations. I looked in the console but didn't see anything.

HELP!!!
0
suzanne2003
Asked:
suzanne2003
  • 2
2 Solutions
 
Stelian StanCommented:
Read this article about Autodiscover Service: http://technet.microsoft.com/en-us/library/bb201695(EXCHG.80).aspx
0
 
Stelian StanCommented:
0
 
Sushil SonawaneCommented:
Install following hotfix on the server then check

(http://support.microsoft.com/kb/2598318)

Please refer below link Out of Office configuration in Exchange Server 2007.

(http://www.msexchange.org/articles_tutorials/exchange-server-2007/management-administration/configuring-outlook-2007-exchange-server-2007.html)
0
 
Simon Butler (Sembee)ConsultantCommented:
Autodiscover problems are usually down to the SSL certificate. If you aren't using a trusted SSL certificate then Autodiscover can generate prompts which Outlook cannot understand.
Autodiscover is a web service though, and if OWA isn't working either, then that indicates a more serious problem.

First, verify the server is fully up to date. It should be on Exchange 2007 SP3 (version number 8.3 in the console) with rollup 8 (shown in Add/Remove Programs). If it isn't, then update it. That will correct a lot of problems as it effectively reinstalls the product.

OWA not working could be a sign that the existing SSL certificate is corrupt and needs to be reissued.

So I would start with the SSL certificate to begin with.
http://exchange.sembee.info/2007/install/multiplenamessl.asp

Get OWA working first, then look at Autodiscover afterwards.

Simon.
0

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now