Internet Explorer 9 keeps remembering passwords even after reset

Hi, I have near new HP desktop computer using windows 7 64bit, and when I go to my banking website for the second time to do internet banking the fields to enter my password and account number are automatically added!!!! what da?

It did it 2 weeks ago, then reset IE9, rebooted but it still had the password there.

I then deleted my profile on the machine and on the SBS 2011 and then recreated it.
It disapeared, now after logging into the bank it is doing it again!

I have AVG paid version and MS security essentials they both come up with nothing.

Someone told me it's a bug with IE9.

i'm worried somebody is having a sneeky go?
Romans8Asked:
Who is Participating?
 
Romans8Author Commented:
finally fixed the issue...the problem was caused by HP Simple Pass software. this is a desktop and the software is only for desktops!!!!
anyway removed it and the problem is fixed.
http://community.spiceworks.com/topic/242502-deleting-stored-passwords-from-internet-explorer-hp-simple-pass
0
 
djsharmaTechnical ConsultantCommented:
Change the setting in IE9.
In Internet Options> Security> Internet Zone> Custom Level (near the bottom)  User Authentication> select "Prompt for user name and password.
0
 
Romans8Author Commented:
tried that twice...changed it then closed and reopened IE still the same.

account number and password automatic inserted.
0
How do you know if your security is working?

Protecting your business doesn’t have to mean sifting through endless alerts and notifications. With WatchGuard Total Security Suite, you can feel confident that your business is secure, meaning you can get back to the things that have been sitting on your to-do list.

 
alisafiaCommented:
clear browsing history
0
 
Romans8Author Commented:
Well if i have reset IE, one would think that clears the history don't you think?????????
0
 
djsharmaTechnical ConsultantCommented:
Open IE with another user account and check the issue persist.
Shift+Right click IE>Run as different user and check the bank site.If issue is resolve than you have to change the IE setting as per the user account setting.
0
 
Romans8Author Commented:
i just found that both AVG and MSE has been disabled
yes if i log in as another user all is ok
0
 
Sean ScissorsProgram Analyst IICommented:
Resetting just resets settings. It's not the same as clearing history. Also history isn't the problem. You have to clear cookies and cache. Also your saved passwords are in IE settings. Currently I'm on my phone but when I get home I will give you specific directions.
0
 
djsharmaTechnical ConsultantCommented:
Check the security settings-internet zone of another user and change your security settings-internet zone according to it.
0
 
Romans8Author Commented:
I have cleared all the history, cache passwords, the works last time but it did nothing.
The password was still auto filling in the fields.
I reckon a malware-virus has come through.
facebook friend requests i reckon....SHeur4.aohs
0
 
djsharmaTechnical ConsultantCommented:
Just have to make changes in security settings-internet zone and it will work.
In Internet Options> Security> Internet Zone> Custom Level .

Compare Custom Level it with the another user and change the setting and restart your internet explorer.
0
 
fourckCommented:
Internet Explorer is the absolute worst browser, and don't know why people still using it.

beside your problem, just use Chrome or firefox.

Firefox:
FireFox Download Page

or Chrome
Chrome Download page

Good Luck !
0
 
Romans8Author Commented:
already tried that, same problem
0
 
fourckCommented:
could you give us the website URL?

I think that this website is putting some cookies to store your credential (which is really strange for a banking website to do that).

but if that was the case, clearing cookies should be enough!

good luck!
0
 
Romans8Author Commented:
(which is really strange for a banking website to do that). yeah one would think.

i'm surprised nobody here is interested in possiblity that it could be viral?

Some of you guys are just toying around and kicking IE in the guts.
0
 
fourckCommented:
Hi Romans,

a virus is a normal program but installed without your permission, and acting in a way to steel some information or make some system modification, .... so in general works for the virus creator profit.

I can't imagine why could someone create a virus that steal your banking credential, and instead of posting them and take benefit, he is just filling you browser form !!!

-try to delete your browser history, and be sure that all fields still checked
-open an in-private IE session instead of normal session.
-post the site URL if still facing problems.

Good luck!
0
 
Romans8Author Commented:
I gave up, completed a system restore back to factory.
0
 
Romans8Author Commented:
fixed it myself as the answer from EE did not resolve the problem
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.