Nic Card Speed issue please help

OS: RHEL5.2
MAchine type VM
NIC Type VMXNET3

ethtool -s eth0 autoneg on speed 1000 duplex full
Cannot set new settings: Operation not supported
  not setting speed
  not setting duplex
  not setting autonegx
apunkabollywoodAsked:
Who is Participating?
 
Andrew Hancock (VMware vExpert / EE MVE^2)Connect With a Mentor VMware and Virtualization ConsultantCommented:
the settings you are changing DO NOT have any effect on the speed of the card, as both are emulated and virtual.

different drivers, the e1000 driver is provided by Linux OS, and is carrying out functions, but it has no effect, because it cannot tell if the e1000 NIC is virtual, and hence there is no reason to change the settings, because the Hypervisor hardware, will dictate the speed.

VMXNET3 driver developed by VMware, no reason to have nic settings, because it's not required.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
in a virtual machine ALL network interface settings are virtual.

e.g. speed and duplex settings do not apply, hence the operation supported message on th4 driver/hardware.

the speed of the VMXNET3 should be at least 1000 Full Duplex.
0
 
apunkabollywoodAuthor Commented:
But than y it shows:

 ethtool eth0
Settings for eth0:
        Supported ports: [ TP ]
        Supported link modes:   1000baseT/Full
        Supports auto-negotiation: No
        Advertised link modes:  Not reported
        Advertised auto-negotiation: No
        Speed: Unknown! (10000)
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: off
        Supports Wake-on: uag
        Wake-on: d
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
that's correct, what's the issue, it's a virtual NIC, which does not support change of speed or duplex settings.
0
 
apunkabollywoodAuthor Commented:
Yes ..its a virtual nic ..i wont able to change anything even autoneg or duplex settings whatever..pls advice what to do ?
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Correct, there is no need to change any of the settings on the NIC.

The fastest it's going to operate at is 1000MBps Full Duplex, which is what it is set to.

What do you want to do?

Why do you want to change the network config?
0
 
apunkabollywoodAuthor Commented:
Yes i want to change it to full duplex 1000 mbps with autoneg yes - pls suggest
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
there is no need to change it to this, it's already running at that speed.

you cannot change it, it's fixed and running at that speed.

It's a Virtual Machine with a Virtual NIC, there would be no benefit if you could make the change, because it's virtual!

Supports auto-negotiation: No because it's not a physical connection!

What is the Hypervisor?
0
 
apunkabollywoodAuthor Commented:
Okay but when we are selecting NIC type as e1000 we are able to see the proper 1000mbps settings using ethtool its only with vmxnet3....Pls explain?

eth0 on vmxnet3
eth1 on e1000 its on right speed and auto yes
\
both are on same machine vm machine
0
 
apunkabollywoodAuthor Commented:
Thank you for your help Hanccocka :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.