• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 801
  • Last Modified:

Exchange 2010 shared mailbox

I have setup a shared email via the EMC and everything looks fine so far.  Users are able to send as that user, email flow is working but...  When a user responds to an email that came into that shared box i want the reply to show up in the sent items for the shared user not the user that is replying.

Is that possible?
0
hamel01
Asked:
hamel01
  • 6
  • 6
  • 4
  • +1
3 Solutions
 
Simon Butler (Sembee)ConsultantCommented:
What version of Outlook are you using?

If Outlook 2010, add the Shared Mailbox as an additional account, rather than an additional mailbox.

If Outlook 2007, then follow this:
http://support.microsoft.com/kb/972148

Simon.
0
 
hamel01Author Commented:
Outlook 2010  I have added it as a account and also just let outlook add it by it's self and i get the same outcomes.  If i reply to an email that was sent to that account using that accounts address or mine own all the sent mail shows up in my sent items instead of in the shared accounts sent items.
0
 
scriven_jCommented:
You need to show the "From" field in Outlook which is on the Options tab (within Show Fields).  If you navigate to the Inbox of the Shared mailbox within Outlook 2010 and reply to a mail from there, it should default to the Shared mailbox user though....

Outlook will add any shared mailboxes on the left once you close and reopen Outlook.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
hamel01Author Commented:
I have the "From" field shown and yes it does default to the shared account but yet sent items still show up in the user performing the reply not the account from which the email is sent from.
0
 
scriven_jCommented:
If this is Outlook 2010:-

(from http://answers.microsoft.com/en-us/office/forum/office_2010-outlook/when-you-send-an-e-mail-message-from-a-shared/557b3fbc-ad15-4f8c-abf2-9337effa28da)

Please install December cumulative update for Outlook 2010 from http://support.microsoft.com/KB/2459115

Please create registry key to save sent items in shared mailbox.

•         HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Preferences

•         On the Edit menu, point to New , and then click DWORD Value .

•         Type DelegateSentItemsStyle , and then press ENTER.

•         Right-click DelegateSentItemsStyle , and then click Modify .

•         In the Value data box, type 1 , and then click OK .

•         Exit Registry Editor.

Then assign following permission on shared mailbox.

Shared Mailbox - Custom

Shared mailbox Sent items - editor

Add user as delegate and give Editor permission in shared mailbox.
0
 
scriven_jCommented:
If Outlook 2007, Sembee2's suggestion should work.
0
 
scriven_jCommented:
If you need to roll this out on Outlook 2010 for multiple users, then you would need to create a group policy to make these changes.
0
 
hamel01Author Commented:
Ok so i have added the Reg entry.  For the permission changes do i do that through the EMC or EMS?  Also should i then remove full access rights?
0
 
Simon Butler (Sembee)ConsultantCommented:
You don't have to make any permission changes at all.
Full Access and Send As are all that are required if those are currently in place.

Simon.
0
 
hamel01Author Commented:
Ok so i made sure Full access and Send as is on.  Now the messages sit in the users outbox but yet still get sent.  They do not show up in the shared users sent or outbox.
0
 
Rajitha ChimmaniCommented:
If full access already exists, then you need not modify any permissions.
0
 
scriven_jCommented:
I think you might need to be in cached mode - is that the case?

This link might explain the process more clearly:-

http://www.slipstick.com/exchange/sending-email-from-a-secondary-exchange-mailbox/
0
 
scriven_jCommented:
If this is getting too complicated, you could always create a rule to achieve the same thing?
0
 
hamel01Author Commented:
I've requested that this question be deleted for the following reason:

No soution found.
0
 
Simon Butler (Sembee)ConsultantCommented:
I disagree that no solution has been found. A number of possible solutions have been presented, but with no follow up from the original poster.
0
 
hamel01Author Commented:
The solutions presented didn't work.  I ended up having to upgrade the exchange server tot he latest exchange service pack and the latest update for that SP.  Once that was done evertyhing started to work correctly. Apparently you have teo have SP2 Update v4-2 (I think that is the one) for teh shared mailbox to work correctly in Exchange 2010.  Since that was never suggested i have asked for the question to be closed.
0
 
Simon Butler (Sembee)ConsultantCommented:
You didn't post that you had found a solution.

Furthermore I disagree that it requires Exchange 2010 SP2, as I have been using the function since Exchange 2010 RC1. If implemented as I outlined it will work - as I have been doing it for some time.

I suggest that question is closed, not deleted as there is useful information which others might find helpful.

Simon.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 6
  • 6
  • 4
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now