?
Solved

Remote Access Failed & Error running CEICW SBS2003

Posted on 2012-09-06
3
Medium Priority
?
473 Views
Last Modified: 2012-09-11
Hi

I have an SBS2003 Standard server with two NIC's installed.  This server has been operational and stable for a few years and I have made no configuration changes.

Two weeks ago I had an internet connection outage for about 10 days and when I got the Internet connection back I found that I could not connect my smartphone, IPad etc to the Exchange Active Synch (I cannot believe that the outage is related - just coincidence?).

All other aspects of my server are running fine - Exchnage sends and receives fine, Internet works OK on all computers etc.

I tried to run CEICW to see if that would resolve the issue and found that this failed on the Firewall configuration. See logfile below.

I have researched this error and tried several fixes suggested:

# Copied the secatt.dll file from the install disc and registered this
# Reinstalled the SBS Server Tools
# Reset the IP Address & Domain Name reastriction of the Default Website in IIS manager
# I have run the MS Best Practice Analyser and this found no issues

I do suspect that this may be related to IIS rights as I do not appear to be able to access the "CompanyWeb" website - not that I tend to use this.  I have just tried to access the ConnectComputer webpage from a client laptop and this seems to display OK so maybe not an issue with IIS rights.

I have tested the open ports and ports 80 and 443 are open but I cannot connect Outlook on a laptop using RPC over HTTP/S and this has always worked before.

I can access Outlook Web Access from inside my LAN but not externally when I could before.

I am at a complete loss with this now and very frustrated - anyone got any ideas what could have caused this and possible resolution?

ICWLog.txt:

06/09/2012 16:01
C:\Program Files\Microsoft Windows Small Business Server\Networking\ICW\wizemail.dll, version 5.2.2893.0
calling CEmailCommit::ValidatePropertyBag ().
calling pdispPPPBag->QueryInterface (IPropertyPagePropertyBag, 0x6e50c).
Call to pdispPPPBag->QueryInterface () returned ok.
calling ReadInt4 (0x1e73708, DB5E5E45-3598-4F1D-8FF7-0ED35B9EB6A4).
Call to ReadInt4 () returned ok.
The out param of ReadInt4() is -1.
calling CValidatePropertyUtil.ValidatePropertyInteger ().
Call to CValidatePropertyUtil.ValidatePropertyInteger () returned ok.
Call to CEMailCommit::ValidatePropertyBag () returned ok.
calling CNetCommit::Commit (31930120).
calling CNetCommit::ValidatePropertyBag ().
Call to Querying for the property bag () returned ok.
Property bag is not dirty, skipping validation
calling CNetCommit::Common ().
Call to Configuring the time service () returned ok.
Call to Notifying RWW for ISA () returned ok.
Call to CNetCommit::Common () returned ok.
Call to CNetCommit::Commit () returned ok.
calling CRFireCommit::CommitEx (0x1e73708).
calling CRFireCommit::ValidatePropertyBag (0x1e73708).
Call to CRFireCommit::ValidatePropertyBag () returned ok.
Call to GetPrivateNICGuid () returned ok.
Call to WMIGetIPAddress () returned ok.
Error 0x8007041d returned from call to IISConfig Set().
Error 0x8007041d returned from call to CRFireCommit::Commit().
calling GetBOConnector ().
Call to GetBOConnector () returned ok.
calling spADs->PutEx (ADS_PROPERTY_CLEAR, msExchSmtpOutboundSecurityPassword).
Call to spADs->PutEx () returned ok.
calling spADs->SetInfo ().
Call to spADs->SetInfo () returned ok.
0
Comment
Question by:BorisMatthews
  • 2
3 Comments
 
LVL 30

Expert Comment

by:pgm554
ID: 38375077
Did you check to see if your SSL is expired?
Only lasts 5 years.
0
 

Accepted Solution

by:
BorisMatthews earned 0 total points
ID: 38375167
The SSL is still valid.

I have resolved the remote access aspect of this issue but the CEICW still fails if I try and run it.

I am going to close this question and start a clean question just focusing on the CEICW problem.
0
 

Author Closing Comment

by:BorisMatthews
ID: 38386107
Spurious problem with remote access caused by my ISP changing my "Fixed" IP address
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Written by Glen Knight (demazter) as part of a series of how-to articles. Introduction One of the biggest consumers of disk space with Small Business Server 2008(SBS) is Windows Server Update Services, more affectionately known as WSUS. For t…
I work for a company that primarily works with small businesses as their outsourced IT vendor. As such the majority of these customers utilize some version of Small Business Server. Due to the economics of running a small business, many of these cus…
Integration Management Part 2
How can you see what you are working on when you want to see it while you to save a copy? Add a "Save As" icon to the Quick Access Toolbar, or QAT. That way, when you save a copy of a query, form, report, or other object you are modifying, you…

579 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question