• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 412
  • Last Modified:

Wireless no IP address

Please can anyone help, we have a Windows Small Business Server running DHCP. On the network is a wireless internet router providing internet and wireless access.

If I plug connect a PC to the main switch (simple and unmanaged) it gets an IP address.

If I connect a PC to one of the free network connections on the back of the router, it gets an IP address.

If I connect any PC by wireless we can connect with limited access as no IP is handed out!

If I manually add an IP address to the wireless network card we connect with no problem.
Help please
0
samcory
Asked:
samcory
  • 6
  • 5
  • 2
  • +2
1 Solution
 
JohnGerhardtCommented:
Hi,

Check whether there is not some kind of Firewall active between the wireless and the wired network on the router. This is a common feature.

Jaggie
0
 
Fred MarshallCommented:
This happens quite frequently when there is a typo in the passphrase for the wireless.  I have had to try as many as half a dozen times to get it right - all when I was sure my typing was perfect!
0
 
samcoryAuthor Commented:
No its not the firewall, and its not a typo. We changed the router and the same thing happened,
get wireless ip address =no
get wired ip address = yes

We have the same running in another office with no problem.
0
Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

 
JohnGerhardtCommented:
Just so we are clear...

I presume that you have tried multiple laptops and they all do the same thing?

What model of router is it?
0
 
BillBondoCommented:
You might need to add a dhcp relay to the router
0
 
JohnGerhardtCommented:
As BillBondo has suggested there is often also on these routers a number of settings regarding DHCP.

It can be
ON
OFF
DHCP RELAY

Do you have these settings?
0
 
samcoryAuthor Commented:
Tried different laptops, iphone and andriod phones, all have the same problem.
DHCP on the router is turned off as it is provided by the SBS2000 server.
The router is a Netgear DGN2200M
The DHCP has only 2 options ON or OFF
0
 
JohnGerhardtCommented:
I think your problem is that the router is not forwarding the DHCP request from the wireless side of the router to the wired side (where the SBS DHCP server is).

If the router doesn't have this feature then you are not going to be able to get an IP from your DHCP server as the packets being broadcasted by the machine on the wireless asking for the IP from a DHCP server.

Are there any settings that you can change on the router than allow you to change DHCP Settings, can you specifiy a DNS Server other than itself? If so then you can turn DHCP on, on the router and then off on the SBS and let all client (wired and wireless) get their IPs from the router and then query the SBS for internal and external DNS requests..

Else you are going to have to buy a router that is capable.

Does this make sense?
0
 
samcoryAuthor Commented:
I can disable dhcp on the SBS2000, and enable dhcp on the router

The router has an option to get DNS from the WAN or to specify 2 dns servers.
Should I enable the SBSserver ip address in the first one and a wan ip address in the 2nd one?
0
 
JohnGerhardtCommented:
Yep that sounds like it should work.

All clients should then get an IP from the router and but query the SBS for resolving their DNS requests.

You might be better to just leave the SBS as the only DNS server and then make sure that the SBS server can resolve external addresses using the WAN DNS servers...
0
 
samcoryAuthor Commented:
Thanks, I will try that over the weekend when no one is working.

and let you know
0
 
BillBondoCommented:
From what I can tell dhcp relay uses ports 67-68. Open or set a rule to allow them.
0
 
Darr247Commented:
Another way would be to connect the server to one of the router's LAN ports instead of to its WAN/Internet port. Then the BOOTP broadcasts should make it across the wireless to wired bridge in the router.

Or, at the bottom of the Basic Settings menu, set NAT to Disable.
0
 
samcoryAuthor Commented:
Thanks John
I disabled the DHCP on the server and enabled it on the router and changed the router dns to refer to the server first and then to the router.
That fixed the problem and the wireless is now working correctly.

Thanks for your help
0
 
samcoryAuthor Commented:
Thanks
Sam
0

Featured Post

 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

  • 6
  • 5
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now