?
Solved

Problem installing Percona innoDB tool

Posted on 2012-09-06
1
Medium Priority
?
963 Views
Last Modified: 2012-09-06
Greetings.

I'm currently running RHEL 6.3 and attempting to compile Percona innodb-tool (https://launchpad.net/percona-data-recovery-tool-for-innodb).

Everything './configure's fine but when I run make, I get:
/usr/bin/ld: cannot find -lrt

I've obviously googled this and made sure that librt was installed and that the library path librt was in was included when compiling, but it still isn't working.

Any suggestions on what I should try to get this to compile?
Thanks.
0
Comment
Question by:indsupport
1 Comment
 

Accepted Solution

by:
indsupport earned 0 total points
ID: 38374351
I actually solved this by yum install libaio-devel glibc-static.
Truth be told, I had to fix some dependencies first, but 'great success'!
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this blog post, we’ll look at how ClickHouse performs in a general analytical workload using the star schema benchmark test.
In this blog post, we’ll look at how using thread_statistics can cause high memory usage.
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses
Course of the Month15 days, 14 hours left to enroll

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question