Make printer available for all networks?

We have a Cisco ASA 5510 with some 2960 switches..

We have a few networks and separate v-lans for each network.

We have a printer that is kind of for general use for everyone, how do I allow everyone to have this printer?

Are there certain steps I can do on the command line or preferably the GUI?
LVL 4
Pancake_EffectAsked:
Who is Participating?
 
qbakiesCommented:
There are several ways to do this depending on how your network is structured.

- Add a print server role to a server and deploy the printer to the users
- Create a printer VLAN, add the printer to it, and open traffic from the other VLANs.  You would then need to deploy it as an IP printer.
- Add the printer to an existing VLAN and deploy as an IP printer

How are you currently routing between VLANs?  Are you doing static routing on the switches?  On the ASA?  Do you have an actual router on the network?
0
 
Carlisle_AgentCommented:
What is the model of the printer? If it has a ethernet port on it, you can hook that up and hold the feed button (or whatever the button is to get the network info), then add printer to each computer by IP address. Download the drivers for the device and they should all work.
0
 
Pancake_EffectAuthor Commented:
I actually tried that already, it does have a Ethernet port. I set a static IP on the printer *for example* at 192.168.0.1. However when I grab a laptop, and make a local port using TCP/IP that's using for example an IP of 192.168.20.1, it states it cannot find the device. However if I'm on the 192.168.0.1 it does find it. I'm guessing the firewall is blocking communication between the two networks...which it should. But I know there's a way to make a exception just for a single IP such as a printer. I had a networker do it in the past for us. I know enough just to be dangerous in terms of networking. So I like to have steps before I do anything.
0
 
Carlisle_AgentCommented:
If you already set up a IP for that printer, and you are sure the 192.168.0.1 works well for you, try going to the Control Panel-Windows Firewall-Change Settings-Exceptions-Add Port-Change scope and add a custom list. Enter the IP.
0
 
Pancake_EffectAuthor Commented:
Thanks, we already have a print server role, but that v-lan idea mgiht work, thanks!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.