AIX, netsvc.conf

Sorry about the .conf extension in the previous thread.  Not thinking

Anyway, I have the following hosts file:

# cat hosts
...
...
...
127.0.0.1               loopback localhost      # loopback (lo0) name/address
::1                     loopback localhost      # IPv6 loopback (lo0) name/address
10.14.52.224    lp2
#####10.14.52.223       wlpar1  lp2

10.14.10.10    localdomain.com

Open in new window


I have the following netsvc.conf file

# cat netsvc.conf
# IBM_PROLOG_BEGIN_TAG
...
...
...
# aliases = nis, files
#
hosts = local,bind4

Open in new window


And get the following from the lookup

# nslookup controller2
Server:         10.14.10.10
Address:        10.14.10.10#53

Non-authoritative answer:
Name:   controller2.localdomain.com
Address: 98.124.199.1

Open in new window



I still do not know where I get the IP address of 98.124.199.1 from

Does this make sense ?

Thanks
Los Angeles1Asked:
Who is Participating?
 
woolmilkporcConnect With a Mentor Commented:
You're still using "nslookup"!

I thought I told you that nslookup doesn't care about /etc/netsvc.conf and /etc/hosts.

nslookup queries the nameserver exclusively, in your case obviously the one with this address:

 10.14.10.10

There is a file /etc/resolv.conf used to determine which nameserver to query.
Please check this file!

10.14.10.10 is a private address, so it must belong to a server residing in your company's network.

controller2 is a regular host in your network, and so it's quite OK that its address 98.124.199.1 is returned by nslookup.
Are you "Shallotte Enom Incorporated " (DemandMedia) or one of their customers? If so, ask Albert Valerio or Ben Svobodny what it's all about.

"nslookup lp2" will either return nothing (if lp2 is not configured in DNS) or it will return an address probably different from the one in your /etc/hosts (if it is the address of an already existing server somewhere else in your network).

If you want to bypass DNS for tools like "ping", "host" etc. (not for nslookup!) remove "bind4" from the "hosts=" line of /etc/netsvc.conf.

If you want to disable the DNS service for your machine completely (thus effectively also disabling nslookup) rename /etc/resolv.conf, or delete it.
0
 
Los Angeles1Author Commented:
I was confused by the address, its not on my network and I have another IP for that node,  I thought the 98 address was something else, not the node IP returned from the DNS.

Thanks for your help
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.