Cisco 1262 AP with Cisco 525G Wireless phones. Getting lots of duplex mismatch messages

Sep  6 17:09:07 EDT: %CDP-4-DUPLEX_MISMATCH: duplex mismatch discovered on FastEthernet0/1/2 (not half duplex), with SIP708105B36528 wlan0 (half duplex).

Is this a problem, if so, how do I fix it?
chikagohAsked:
Who is Participating?
 
Craig BeckConnect With a Mentor Commented:
To stop the power issue without CDP you need to try the power inline negotiation prestandard source command on the AP.  Maybe you can turn CDP off on the phone?

http://www.cisco.com/en/US/docs/voice_ip_comm/csbpipp/ip_phones/user/guide/spa525_sip_user_low.pdf

CDP depends - some devices will pass CDP messages even if they don't support the protocol themselves (such as unmanaged switches).  Usually though if a device does support CDP and you turn it off, it stops passing CDP messages through it.

However it could be that, as the AP is a transparent bridge, it is still passing CDP from the wireless interface to the wired interface.

I still don't understand though :-S

http://wirelessccielab.blogspot.co.uk/2010/06/101-cdp.html
0
 
Robert Sutton JrSenior Network ManagerCommented:
Yes, this can create issues and communication errors on the network.. Setting both sides to either Full or Half-Duplex should resolve this issue.
0
 
Craig BeckCommented:
Turn CDP off on your WLC - it should be turned off by default.
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
chikagohAuthor Commented:
Thanks  for the response:

1) I am using WiFi from the phones to the AP, so there is no full/half duplex setting like there is on a wired switch.

2) I am not using a WLC.  This is an autonomous AP

Wireless                  Wireless         Wired
C525G Phone ---> C1262 AP ----> C1861 Router

I am getting these CDP messages on the router.
0
 
Craig BeckCommented:
Ok, just disable CDP on the AP then.
0
 
chikagohAuthor Commented:
Not a problem, but to confirm, is there really a duplex issue between the phone and AP?
0
 
chikagohAuthor Commented:
Actually, after disabling CDP on the AP, it is still happening.  Looks like the CDP messages are coming from the phone
0
 
Craig BeckCommented:
Hmmm the phone IS half duplex by design, as that's how WiFi works for standard 802.11b/g.

I don't understand how CDP can reach the router if the AP has it turned off!?  The AP shouldn't pass the CDP from the phone to the router.

Can you post the config from the AP?
0
 
chikagohAuthor Commented:
I put back the cdp back in because I got a cdp message from my poe router about a power issue which resets the radios.  I had no cdp enable on dot0 and dot1, and gig0

XXX_AP#show running-config
Building configuration...

Current configuration : 1765 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname CUPROD_AP
!
logging rate-limit console 9
enable secret 5 $1$owvM$21kcIieLTJ6CFcvLiDct0/
!
no aaa new-model
!
!
dot11 syslog
!
dot11 ssid XXX
   authentication open
   authentication key-management wpa
   guest-mode
   wpa-psk ascii 7 XXX
!
!
!
!
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption mode ciphers tkip
 !
 ssid XXX
 !        
 antenna gain 0
 station-role root
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface Dot11Radio1
 no ip address
 no ip route-cache
 !
 encryption mode ciphers tkip
 !
 ssid XXX
 !
 antenna gain 0
 dfs band 3 block
 channel dfs
 station-role root
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface GigabitEthernet0
 no ip address
 no ip route-cache
 duplex full
 speed 100
 no keepalive
 bridge-group 1
 no bridge-group 1 source-learning
 bridge-group 1 spanning-disabled
!
interface BVI1
 ip address XXX 255.255.255.0
 no ip route-cache
!
ip default-gateway XXX
ip http server
ip http authentication local
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
 login local
!
end
0
 
chikagohAuthor Commented:
CDP isn't routable, but it can still travel through connected layer2 networks (with or without CDP enabled on a device in the middle) correct?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.