mikrotik email

Posted on 2012-09-06
Last Modified: 2012-09-06
I have a backup i want to email to me weekly. the backup works perfectly but when the sripts tries to email me it gets cannot connect to the server. I sent a test email from the email tools and it came through. here are the settings in my email tool. I am using gmail so the port has to be 587 and tls has to be used.

      port: 587
  starttls: yes
  password: #########

Here is my script:

:log info "backup beginning now"
:global backupfile ([/system identity get name] . "-" . [/system clock get time])
/system backup save name=$backupfile
:log info "backup pausing for 10s"
:delay 10s
:log info "backup being emailed"
/tool e-mail send to="" subject=([/system identity get name] . \
" Backup") file=$backupfile server=
:log info "backup finished"

Open in new window

I have done this before but not using gmail. I have googled the issue and found several sites where they have addressed the issue but nothing is working for me. any ideas would be greatly appreciated.
Question by:CCC-Ravens
    1 Comment

    Accepted Solution

    I found my problem i had a server ip I didn't need (server= removed that and all is well!

    Featured Post

    What Should I Do With This Threat Intelligence?

    Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

    Join & Write a Comment

    This story has been written with permission from the scammed victim, a valued client of mine – identity protected by request.
    David Varnum recently wrote up his impressions of PRTG, based on a presentation by my colleague Christian at Tech Field Day at VMworld in Barcelona. Thanks David, for your detailed and honest evaluation!
    Here's a very brief overview of the methods PRTG Network Monitor ( offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
    This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor ( If you're looking for how to monitor bandwidth using netflow or packet s…

    755 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    17 Experts available now in Live!

    Get 1:1 Help Now