disable UAC file virtualization in Windows 8

We have a legacy app which writes to an .ini file in a protected location.  In Windows Vista/7, we can bypass this issue by turning off UAC which in turn disables UAC file virtualization using the virtualstore.  Unfortunately this does not work in Windows 8.  Turn UAC all the way down and the problem still occurs.  Google info is full of tips for Vista/7, but I guess as 8 hasn't hit the masses yet I haven't found a solution.

Now I know that turning off UAC is not a great idea, and is not a true solution - which would be modifying the legacy app to write to a non-restricted area.  However, for various reasons this is not possible.
roberthdlAsked:
Who is Participating?
 
roberthdlConnect With a Mentor Author Commented:
I'm not sure what you mean by "integrity level".  The path is the %windir% environment variable, typically c:\windows\.  I modified appropriate user permissions to give full access to the specific .ini file in question.  However, I don't think we're even getting into a permissions issue at this point, because Win 8 is still using file virtualization when we access that path regardless of the file.  So until we can configure Win 8 to not use file virtualization any permissions are a moot point.  I guess maybe I could work around it by manually creating a manifest for the app so that Win 8 wouldn't see it as a legacy app and thus hopefully bypass file virtualization.
0
 
McKnifeCommented:
Hi.

You need to understand, what folder virtualization is about. It tries to solve the problem of weak users being unable to write to protected locations, normally, it does not create a problem.

If you turn it off to overcome whatever problem it creates, you still cannot write to protected locations because turning it off does not change NTFS permissions - not in win 8 and not in win7. So please tell us if you changed the NTFS permissions to enable the user of that app to write there. If yes, then you will need to use procmon (freeware logging tool) to reveal what causes access denials.
0
 
roberthdlAuthor Commented:
yes, I understand the issue.  The app is only used internally and only for a handful of users.  We are able to give appropriate user permissions to the required location, but as I indicated turning UAC off does not have the same effect in win 8 that it had in win 7.  The app still reads/writes to the virtual store location.  I'm looking for a way to turn this off in win 8.
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

 
McKnifeCommented:
Hi.

In what way did you modify permissions? Some paths like c:\ for example need to be modified both NTFS-permission-wise and also integrity level-wise. So what did you do so far and what directory is it all about?
0
 
McKnifeCommented:
About integrity levels: read http://msdn.microsoft.com/en-us/library/bb625964.aspx
c:\windows wears the label "no write up".
0
 
roberthdlAuthor Commented:
not the solution I was looking for, but works all the same. We created a .manifest to set the app security level such that file virtualization would be disabled. Place it in the .exe location and it works like a charm.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.