BLOCKING WINDOWS TO SURF THE INTERNET

WINDOWS stations on my network should not be able to browse the internet
I did get from someone this registry setting , that works

REGEDIT4

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]
"MigrateProxy"=dword:00000001
"ProxyEnable"=dword:00000001
"ProxyServer"="http://ProxyServername:80"
"ProxyOverride"

[HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\Restrictions]
"NoBrowserOptions"=dword:00000001


BUT:
Then I use a activex  from a third party in my VB6 programs to send mails

wich uses:
       SmtpServer = "smtp.xs4all.nl"  
      .SmtpPort = "25"                        
      .SmtpSSL = False                        
      .SmtpSPA = False                        

That wil give error due to no internet connection

SO:   how to prevent users can "Google"  but I still can send mails
BIAPROAsked:
Who is Participating?
 
marsiliesCommented:
You can set proxy exceptions so that certain sites don't try and use the non-existant proxy. To do so via registry:


[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]
"ProxyOverride"="*.local;smtp.xs4all.nl"

You can add in other exceptions by separating with a semicolon.

http://www.myitforum.com/articles/2/view.asp?id=2039
0
 
djsharmaTechnical ConsultantCommented:
0
 
Miguel Angel Perez MuñozCommented:
If you have not got any branch office or all of your workstations traffic are local, you can remove default gateway of all workstation.
0
 
mo_patelCommented:
use group policy to place a fake proxy address into their internet explorer connection settings tab and to also Grey it out so it cant be edited, so this way it will try connecting to the net via this fake proxy and always fail
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.