Slow WiFi internet on Windows 8

Hello,
I installed Windows 8 Pro from the Microsoft MSDN . but i face a problem that when i used the WiFi the internet is too slow . But when i use the Ethernet the internet is excellent . this problem happened on Windows 8 only . i Have 50 MB internet Connection . Please see the Test Speed Result :

Ethernet :
Ethernet Speed test
WiFi
WiFi Speed Test

And the Wireless Driver installed without any problem it is Broadcom 802.11n See the Screenshot Below :
Wireless Driver 1
Wireless Driver 2
How i can solve this problem

thanks alot
LVL 2
fadyazAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dallensworthCommented:
Could possibly be power consumption for the wifi which seems to be handled differently on Windows 8.

Right Click the Wireless Symbol by the Clock.
Go to "Network and Sharing Center."
On the left panel select "Change Adapter Settings."
Select your WiFi Card then Right Click it
Choose Properties (New Property Window open up)
Then Click Configure (New Window open up)
On the Top Tabs select "Advanced"
Go down the list of settings and see if there is a "Minimum Power Consumption" setting. If there is Disable it.

 Could potentially be encryption technique your using in your wifi settings.
Go to wireless properties of your connection
Go to the security tab
Encryption type: if this is set to AES change it to TKIP
fadyazAuthor Commented:
Thanks dallensworth for your answer

I didn't Find the bellow :
Right Click the Wireless Symbol by the Clock.
Go to "Network and Sharing Center."
On the left panel select "Change Adapter Settings."
Select your WiFi Card then Right Click it
Choose Properties (New Property Window open up)
Then Click Configure (New Window open up)
On the Top Tabs select "Advanced"
Go down the list of settings and see if there is a "Minimum Power Consumption" setting. If there is Disable it.

But after doing the next steps :
Could potentially be encryption technique your using in your wifi settings.
Go to wireless properties of your connection
Go to the security tab
Encryption type: if this is set to AES change it to TKIP

the Result was good but not as when i installed the windows 7 (see the screen shot for test speed)
Secoend test for wifi
but it was at least on my WiFi give me 30 MB Speed on windows 7 with the same settings .  does there any firewall settings or any configuration on windows 8 ?
EvilKnievelCommented:
Try installing the windows 7 driver for your wireless network card, the integrated windows 8 drivers are a bit buggy, experienced it on several systems unfortunately.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
OWASP Proactive Controls

Learn the most important control and control categories that every architect and developer should include in their projects.

fadyazAuthor Commented:
Thanks EvilKnievel for your reply ,
I tried the driver but it refuse to installed .

can you give me a linke for the driver ?
My laptop model Toshiba Sattellite L630 - 107 -  PSK04E
The Wireless adapter Model : Broadcom 802.11n Network Adapter .

thanks alot
davis731Commented:
This thread solved my slow Windows 8 wi-fi connection on my Dell Desktop Inspiron 410 (Zino HD).  I had the same Network Adapter and driver version as shown above (Broadcom 802.11n, 5.100.245.20).  Once I reverted back to an earlier adapter/driver (DW1501 Wireless-N WLAN Half-Mini Card, 5.60.48.35, available at driverguide.com) and followed the Expert procedures for "minimum power consumption" and encryption technique, my internet speed came back to what I had in Win 7.  Internet videos play again without hesitation or buffering delays.  Thanks for the solution.  This problem was really driving me crazy.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 8

From novice to tech pro — start learning today.