• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 716
  • Last Modified:

Windows 7 will not run login.bat from Windows 2003 server w/AD

We have a W7 machine and 2003 server. Up until yesterday, I set all users to change passwords, at which time the W7 user did and since then this machine will not automatically run login.bat for mappings. It had been working fine or I guess it was.

We can run it manually from the Run Prompt \\server\netlogon and everything is good to go.

I have read and tried putting UAC to its lowest level.
Also added a registry setting called EnableLinkedConnections with value of 1.

Very simple .bat
REM:  User drive mappings
net use o: /delete
net use o: \\iconserver\data
net use u: /delete
net use u: \\iconserver\home$\%username%

I had problems with setting User home directories from within the account, so I put the mapping in here.
0
Harold
Asked:
Harold
1 Solution
 
GeisrudCommented:
Double check that DHCP is enabled (or ensure static configuration is correct).

Check if windows firewall might be blocking traffic.

Check to make sure the computer didn't somehow get removed from the domain, and that the user is logging into the domain

Check the DC to make sure the [correct] login script is set for the user's profile
0
 
HaroldNetwork EngineerAuthor Commented:
Geisrud: We are getting IP from DHCP and the DNS is the server.
Firewall may be blocking what, for a batch file?
The domain is correct, I checked the Computer properties.
There is only one file and everyone uses the same.
0
 
redbmasterCommented:
I'd remove and re-add the Win7 PC back to the domain.
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 
HaroldNetwork EngineerAuthor Commented:
redbmaster: no go, after rejoining. Same problem
0
 
redbmasterCommented:
Out of curiosity, what is the functional level of your domain? Here is help determining this if you need it: http://www.windowsnetworking.com/articles_tutorials/determining-functional-level-windows-server-2003.html
0
 
HaroldNetwork EngineerAuthor Commented:
Ok, thus far, I stuck an ECHO and PAUSE in the batch file. When we login the cmd prompt never comes up, so this tells me it is not running the batch file at all, but I can manually run from the \\server\netlogon directory.

>I have removed and rejoined Domain.
>Machine is getting correct DHCP settings IP, Gateway and DNS. DNS is the server where the  batch file is located.
0
 
HaroldNetwork EngineerAuthor Commented:
redbmaster:
Domain and Forest:
Windows 2000 mixed
0
 
redbmasterCommented:
Jump on one of the Win7 machines, open the main share for the domain controller (start, run, "\\domaincontrollername"), and see if these two folders exist "sysvol" and "netlogon".
0
 
HaroldNetwork EngineerAuthor Commented:
As I noted earlier, I can run it manually. It would not run after you log in with the user credentials. I could go to any other machine and it worked fine(XP).

This is what I ended up doing. I deleted his account on the server and recreated. I THOUGHT it would just create and handle the server relevant stuff, but when I logged in the first time it recreated his desktop, even though same username. On anther note, it ran the login.bat file and mapped the drives.

This created more work though because all his old desktop and configs had to be moved, e-mail re-setup, BS.

Does Windows 7 store network and other passwords somewhere on it? The only thing I can figure is the credentials were stored incorrectly on the other profile. The new profile works fine. I really need to figure this one out.

I wanted to test, but he needed to get back to work and this is the only W7 machine. I figure at the next password change, this may or should happen again.
0
 
Gajendra RathodCommented:
Please check credential manager after login to user profile

Go to  Control Panel| Credential Manager

Remove any stored username and password for that mapped drive.
0
 
HaroldNetwork EngineerAuthor Commented:
I will have to try this the next time it happens, since the steps I took prior, resolved the problem.
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

Tackle projects and never again get stuck behind a technical roadblock.
Join Now