[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3472
  • Last Modified:

Sharepoint Foundation Error

Sharepoint 2010.
When trying to search our sharepoint site. I get Following error

Error

Internal server error exception:


Troubleshoot issues with Microsoft SharePoint Foundation.

Correlation ID: f1dbe1b0-1a82-4391-a4e9-3e09e462f601

Date and Time: 9/7/2012 9:14:30 AM



I check the event logs and seems like ever 15 minutes there is the following Critical error.


*Also If you know of other things i need to check for sharepoint let me know. I might have missed some other places where i need to change the password.*
(I am not a sharepoint Expert) .

Log Name:      Application
Source:        Microsoft-SharePoint Products-SharePoint Foundation
Date:          9/7/2012 9:06:34 AM
Event ID:      6398
Task Category: Timer
Level:         Critical
Keywords:      
User:          DOMAIN\spadmin2
Computer:      cOMPUTR.domain.local
Description:
The Execute method of job definition Microsoft.Office.Server.Search.Monitoring.HealthStatUpdateJobDefinition (ID 9b128770-8b10-468a-b977-05c7bbc6daad) threw an exception. More information is included below.

Microsoft SharePoint Foundation Usage service application not found.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-SharePoint Products-SharePoint Foundation" Guid="{6fb7e0cd-52e7-47dd-997a-241563931fc2}" />
    <EventID>6398</EventID>
    <Version>14</Version>
    <Level>1</Level>
    <Task>12</Task>
    <Opcode>0</Opcode>
    <Keywords>0x4000000000000000</Keywords>
    <TimeCreated SystemTime="2012-09-07T14:06:34.879Z" />
    <EventRecordID>15550857</EventRecordID>
    <Correlation ActivityID="{BDD7A747-A359-4CA6-858D-B90CA6CDFF61}" />
    <Execution ProcessID="21876" ThreadID="24972" />
    <Channel>Application</Channel>
    <Computer></Computer>
    <Security UserID="S-1-5-21-1110669541-1120488304-3473557-2409" />
  </System>
  <EventData>
    <Data Name="string0">Microsoft.Office.Server.Search.Monitoring.HealthStatUpdateJobDefinition</Data>
    <Data Name="string1">9b128770-8b10-468a-b977-05c7bbc6daad</Data>
    <Data Name="string2">Microsoft SharePoint Foundation Usage service application not found.</Data>
  </EventData>
</Event>
0
jamyoung
Asked:
jamyoung
  • 6
  • 5
1 Solution
 
Justin SmithSr. System EngineerCommented:
First things first.  Have you rebooted the server?

Do you have Search Server Express installed?  Or is it just plain SharePoint Foundation?

The event log is complaining about the Usage / Logging service.  This can happen if something is truely down, or if you've never configured it.  You can configure in Central Admin - Monitoring - Configure Health
0
 
jamyoungAuthor Commented:
I have not rebooted the server but will not be able to reboot This production server still next sunday. If there is anything else i could try before a reboot would be great.

Yes Search Server Express is installed.
THis was working but we had to change service account passwords cause of One of our IT person left our Company.
 Usage log is running.  when i try and add it i get following error:

A Usage Application already exists in this farm.

Troubleshoot issues with Microsoft SharePoint Foundation.

Correlation ID: 11504db2-016e-4682-aad9-7c6e40d1391c

Date and Time: 9/7/2012 12:19:50 PM


Here are the installed Components:
  Microsoft SharePoint Foundation 2010   Installed
 Microsoft SharePoint Foundation 2010
 14.0.4763.1000 Installed
   Microsoft SharePoint Foundation 2010 1033 Lang Pack
 14.0.4763.1000 Installed
  Hotfix for Microsoft SharePoint Foundation 2010 (KB2597132)
 14.0.6117.5000 Installed
  Microsoft SharePoint Foundation 2010 Core
 14.0.4763.1000 Installed
   Hotfix for Microsoft SharePoint Foundation 2010 (KB2597132)
 14.0.6117.5002 Installed
  Microsoft® Search Server 2010 Express   Installed
   Microsoft Office Server Proof (Arabic) 2010
 14.0.4763.1000 Installed
   Microsoft Office Server Proof (English) 2010
 14.0.4763.1000 Installed
   Microsoft Office Server Proof (French) 2010
 14.0.4763.1000 Installed
   Microsoft Office Server Proof (German) 2010
 14.0.4763.1000 Installed
   Microsoft Office Server Proof (Russian) 2010
 14.0.4763.1000 Installed
   Microsoft Office Server Proof (Spanish) 2010
 14.0.4763.1000 Installed
   Microsoft Search Server 2010 Core
 14.0.4763.1000 Installed
   Microsoft Search Server 2010 English Language Pack
 14.0.4763.1000 Installed
   Microsoft Search Server 2010 Express
 14.0.4763.1000 Installed
   Microsoft Shared Components
 14.0.4763.1000 Installed
   Microsoft Shared Coms English Language Pack
 14.0.4763.1000 Installed
   Microsoft SharePoint Foundation 2010 1033 Lang Pack
 14.0.4763.1000 Installed
   Hotfix for Microsoft SharePoint Foundation 2010 (KB2597132)
 14.0.6117.5000 Installed
   Microsoft SharePoint Foundation 2010 Core
 14.0.4763.1000 Installed
   Hotfix for Microsoft SharePoint Foundation 2010 (KB2597132)
 14.0.6117.5002 Installed
   Microsoft Web Analytics English Language Pack
 14.0.4763.1000 Installed
  Microsoft Web Analytics Web Front End Components
 14.0.4763.1000 Installed
0
 
Justin SmithSr. System EngineerCommented:
So you changed service account passwords?  Which service accounts exactly?  And how did you tell SharePoint about the changes?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
jamyoungAuthor Commented:
No just changed Passwords for those accounts. And i used sharepoint power shell Powershell To resync passwords and also changed them under services. Now with that being said Possible i missed something.

Btw i am not a sharepoint Expert by any means.

here is link to what i did for accounts
http://blog.sharepointsite.co.uk/2011/03/ad-account-password-out-of-sync-with.html 

Also here are all the services in Sharepoint that are started.
Business Data Connectivity Service  Started  Stop  
Central Administration  Started  Stop  
Claims to Windows Token Service  Started  Stop  
Lotus Notes Connector  Stopped  Start  
Microsoft SharePoint Foundation Incoming E-Mail  Started  Stop  
Microsoft SharePoint Foundation Sandboxed Code Service  Started  Stop  
Microsoft SharePoint Foundation Subscription Settings Service  Started  Stop  
Microsoft SharePoint Foundation Web Application  Started  Stop  
Microsoft SharePoint Foundation Workflow Timer Service  Started  Stop  
Search Query and Site Settings Service  Started  Stop  
Secure Store Service  Started  Stop  
SharePoint Foundation Help Search  Started  Stop  
SharePoint Server Search  Started  Stop  
Web Analytics Data Processing Service  Started  Stop  
Web Analytics Web Service  Started  Stop
0
 
Justin SmithSr. System EngineerCommented:
Pull up command window.  Run...

net stop "SharePoint Foundation Search V4"
net start "SharePoint Foundation Search V4"

Then try to do a search.
0
 
jamyoungAuthor Commented:
No luck with doing  that. Same error.
0
 
Justin SmithSr. System EngineerCommented:
When you look up the Correlation ID that is provided on the Search Error screen, what do you see?

http://sharepoint.microsoft.com/blogs/GetThePoint/Lists/Posts/Post.aspx?ID=353
0
 
jamyoungAuthor Commented:
Ok so i got rid of the Correlation ID.  but i still got error in logs


Log Name:      Application
Source:        Microsoft-SharePoint Products-SharePoint Foundation
Date:          9/27/2012 10:33:07 AM
Event ID:      6398
Task Category: Timer
Level:         Critical
Keywords:      
User:          
Computer:      
Description:
The Execute method of job definition Microsoft.Office.Server.Search.Monitoring.HealthStatUpdateJobDefinition (ID 9b128770-8b10-468a-b977-05c7bbc6daad) threw an exception. More information is included below.

Microsoft SharePoint Foundation Usage service application not found.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-SharePoint Products-SharePoint Foundation" Guid="{6fb7e0cd-52e7-47dd-997a-241563931fc2}" />
    <EventID>6398</EventID>
    <Version>14</Version>
    <Level>1</Level>
    <Task>12</Task>
    <Opcode>0</Opcode>
    <Keywords>0x4000000000000000</Keywords>
    <TimeCreated SystemTime="2012-09-27T15:33:07.209Z" />
    <EventRecordID>21735</EventRecordID>
    <Correlation ActivityID="{8576CECB-695A-49BA-AB0A-92A8AC037F30}" />
    <Execution ProcessID="4216" ThreadID="15348" />
    <Channel>Application</Channel>
    <Computer>sos-sql.sosdomain.local</Computer>
    <Security UserID="S-1-5-21-1110669541-1120488304-3473557-2409" />
  </System>
  <EventData>
    <Data Name="string0">Microsoft.Office.Server.Search.Monitoring.HealthStatUpdateJobDefinition</Data>
    <Data Name="string1">9b128770-8b10-468a-b977-05c7bbc6daad</Data>
    <Data Name="string2">Microsoft SharePoint Foundation Usage service application not found.</Data>
  </EventData>
</Event>

Please Help!
0
 
Justin SmithSr. System EngineerCommented:
Ok.  I think you said the Usage service appilcation actually already exists.  So you see it in the list of service apps?  If so, can you click on the name, does it take you to the Properties page?  Also, do you see the Proxy, under the name of the service app, and if you look to the far right, are both "Started"?
0
 
jamyoungAuthor Commented:
I have passed this issue along to other tech. Tried everthing on here no luck

Thank you all for all your help..
0
 
jamyoungAuthor Commented:
Passed Ticket to other tech
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

  • 6
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now