• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1765
  • Last Modified:

Access 97 Not prompting for username\password

Dear All,

I have a legacy Access 97 database.  It stores a lot of historic information that my users often need to access.  

After installation of Access 2010 Runtime on a Windows 7 machine, Access 97 no longer prompts for username and password under one users profile.

It does prompt for username and password for other user profile on the machine.

I have verified that is correctly joined to the system.mdw file.

I uninstalled Access 2010 Runtime, then reinstalled Access 97 and joined the security file again.  Still, it does not prompt for username and password.  It will open, but the user group has no permissions on the database.

Any ideas?

Thanks,

Tammy
0
tammyborden32
Asked:
tammyborden32
  • 12
  • 10
  • +1
1 Solution
 
peter57rCommented:
I would say that it is pretty certain that the two users you mention are NOT looking at the same system.mdw file.

I suggest you change the name of the 'working'  system.mdw file to security.mdw and then rejoin both users to that file.

It is never a good idea to use system.mdw as the name of the security file.There can be system.mdw files all over the place.  Any time Access opens and can't find one it will create a new one.
0
 
tammyborden32Author Commented:
Thanks, but this isn't the cause.  They are both joined to the same file in a network directory.  We've been using this file since 1998.  All users have a mapped drive to the directory and it is the only mdw file in the directory.  I double-checked this as it is usually a common cause of no prompt by Access.

I think it relates to compatibility of different versions of Access on the same computer.  Once you use Access 2010, Access 97 will no longer prompt for the account info for that user profile.  Any other user gets the prompt.
0
 
Jim Dettman (Microsoft MVP/ EE MVE)PresidentCommented:
I would agree with Peter.  When you install 2010, it creates system1.mdw and sets the current profile to use that as the default workgroup file, which is stored in the registry and set by the workgroup admin program.

So if you don't specify one, that's the one it will use.

To verify, create a shortcut on the desktop pointing to the DB.

Right click it, edit the properties and add:

/wrkgrp=

 followed by the path to the network folder with the MDW file.

 See if you get the login prompt then.

Jim.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Jim Dettman (Microsoft MVP/ EE MVE)PresidentCommented:
Sorry, no equals sign on that, just:

/wrkgrp <path>

so

/wrkgrp "M:\Myapp\MyApp.MDW"

Jim.
0
 
Scott McDaniel (Microsoft Access MVP - EE MVE )Infotrakker SoftwareCommented:
This isn't your trouble (I agree with Jim and Peter), but I'd also suggest that this indicates the database isn't properly secured. In a properly secured database, the user should not be allowed to open the database with the wrong .mdw file. Instead, you should get a warning about insufficient permissions, and the db should not open.
0
 
Jim Dettman (Microsoft MVP/ EE MVE)PresidentCommented:
<<This isn't your trouble (I agree with Jim and Peter), but I'd also suggest that this indicates the database isn't properly secured.>>

 on that note, just to be sure were all on the same page, the A97 DB was not converted to the ACE format correct?

  If it was, no prompt for a username/password would be expected and no permission errors would occur as from A2007 and up, if you convert to the new DB format, user level security is disabled (all the permissions on objects are reset).

Jim.
0
 
tammyborden32Author Commented:
Dear All,

Thanks for the responses.  

I have tried as suggested.  The path that I have is as follows:

"\\SERV\Office Admin\Work Order Database.mdb" /wrkgrp "z:\Users\Software & Programs\System.mdw"

Is this the correct syntax?

The database resides on a network server "SERV".  The system.mdw file resides on the server with the directory mapped to z.  

I also changed the name to 97system.mdw, and joined the renamed file.  Access still does not prompt, even though wrkgrp admin shows the correct path of z:Users\Software & Programs\97system.mdw.

Not sure if this is related, but I receive an error message when installing Access 97 on the workstation.  The error states that CTL3D32.DLL was not installed properly.  It should be saved in the Windows\System directory.  I found the file on the installation CD and copied it into the system directory. This had no effect on the issue.

Thanks,

Tammy
0
 
Jim Dettman (Microsoft MVP/ EE MVE)PresidentCommented:
Tammy,

Only one of two things then is possible:

a. It's not the right workgroup file (someone overlaid it).  

b. It's the right file and someone changed the admin users password to a blank.  That's what disables/enables the password dialog; if it's non-blank, you get the login box.


 If it is the wrong workgroup file or the password is blank, then one of two things should be happening:

a. You get a lot of permission error's when using the DB - with a blank password, you're being logged in as the admin user.  That user should have no rights in a secured DB.

b. It wasn't secured properly in the first place - The admin user in each workgroup file is the same, so if a DB is not secured properly, then anyone with any workgroup file can use the DB.

Jim.
0
 
tammyborden32Author Commented:
a.  The workgroup file works for everyone else, either on that machine or other machines in the company.

b.  The user who does not get prompted can open the db, but cannot access anything due to permissions being set properly.

I have recreated the same scenario on a test machine.  Install Access 97.  Join workgroup and can use the 97 database.  Next, install Access 2010.  Open Access 2010.  No problem.
Then, rejoin the Access97 workgroup file - try to open the 97 database - no prompt - can open the database, permissions do not allow any other access.  Log off and log on as a different user - try to open the 97 database - receive the prompt as expected.

Thanks,

Tammy
0
 
Jim Dettman (Microsoft MVP/ EE MVE)PresidentCommented:
Tammy,

 OK, that's good info...so the problem is with the users profile specifically.

 What I don't get however is the the /wrkgrp switch should over ride anything and you should get prompted for a login.

 Your not using any kind of a launcher utility or program to open the DB are you?

Jim.
0
 
tammyborden32Author Commented:
No, no launcher utility is used.
0
 
Jim Dettman (Microsoft MVP/ EE MVE)PresidentCommented:
Tammy,

When you do this:

"Next, install Access 2010.  Open Access 2010.  No problem."

Your opening the DB and getting prompted correct?  or are you just saying A2010 opens on it's own?

and then this:

"Then, rejoin the Access97 workgroup file - try to open the 97 database - no prompt - can open the database, permissions do not allow any other access."

 How exactly are you rejoining the workgroup file?

Jim.
0
 
Jim Dettman (Microsoft MVP/ EE MVE)PresidentCommented:
One other thing; you are leaving the database in MDB format correct?  Your not converting it to .ACCDB right?

Jim.
0
 
tammyborden32Author Commented:
I'm saying Access 2010 opens on its own, using the default workgroup file.

To join a workgroup file, I use wrkgadm.exe.

Yes, the database is in mdb format.

Thanks for your input.

Tammy
0
 
Jim Dettman (Microsoft MVP/ EE MVE)PresidentCommented:
Are you running the 64 bit version of Office 2010 or 32?

Something really odd at work here....everything is basically correct.  Your doing all the steps and it should be working, but it's not.  And others have done this without issues.

Jim.
0
 
tammyborden32Author Commented:
This machine and the one that I have completed the test on are both 64 bit machines.
0
 
Jim Dettman (Microsoft MVP/ EE MVE)PresidentCommented:
<<This machine and the one that I have completed the test on are both 64 bit machines. >>

 But what about Office (it comes in 32 bit and 64 bit versions, both of which run under a 64 bit OS)?

Jim.
0
 
tammyborden32Author Commented:
Sorry, been out of the office for a few days.

Both Office versions are 32 bit.

I also tried copying the system.mdw file I want to connect with to the default location (C:\Users\<username>\AppData\Roaming\Microsoft\Access)...Still no prompt.

As well, tried copying it to Windows\System32 folder.  When I open Access 97 and open the User Level Security Wizard - this is the file it is saying that is in use.
0
 
Jim Dettman (Microsoft MVP/ EE MVE)PresidentCommented:
Something odd is at work here with Access 2010.  Seems that once you use it, it is some how messing up the profile (registry entires) of the user.

Yet I don't understand why using the /wrkgrp switch doesn't take care of it.   There is no setting that I'm aware of that forces JET to ignore that or disable the login (other then setting the password for the admin user to a blank).

 I can't feel were missing something here because this has not come up before and yet I've gone over the thread a few times and can't think of anything else.  But still it just doesn't add up.

When you re-join the A97 workgroup file using the wrkgadm.exe after installing 2010, I take it to mean your using the one in C:\Windows\System32 and not the one buit into 2010 correct?

Jim.
0
 
tammyborden32Author Commented:
I was using the wrkgadmn.exe in the shared directory on the network, which I've used for years to join the security file.

I just tried using the one located in the C:\Windows\System32 folder.  The error regarding the CTL3D32.DLL mentioned earlier pops up.  It opens the executable though and allows me to join the file.  Then when I exit, a Windows Compatibility Assistant message appears.  The message states "This program might not have installed correctly.  If this program didn't install correctly, try reinstalling using settings that are compatible with this version of Windows.  Program:  Workgroup Administrator; Publisher:  Microsoft; Location:  C:\Windows\SysWOW64\Wrkgadm.exe.  It gives the option to reinstall using recommended settings, or This program installed correctly.

Curiously, when I open wrkgadm.exe again, it shows the network file I joined in the Workgroup path, but still no prompt when opening Access 97

It is definitely user profile specific.
0
 
Jim Dettman (Microsoft MVP/ EE MVE)PresidentCommented:
Well it looks like joining the default workgroup  file doesn't work in 2010 like it should.  Just found this:

"In Access 2010, if you use the User-Level Security wizard to specify a default workgroup information file, you must also use the /WRKGP command-line switch to point to your workgroup information file when you start Access. "

 So using the /wrkgrp switch with 2010 and a older DB is pretty much mandatory.

I'm also curious what 2010 thinks is the default workgroup file.  Please do the following:

Open Access by itself.
Press Alt/F11 to open the VBA editor
Press Ctrl + G to open the debug window.

Cut/Paste the following:

DoCmd.RunCommand acCmdWorkgroupAdministrator

Out your cursor at the end of this line and then hit Enter.  See what 2010 thinks is the default workgroup file (note it).

 Join your A97 workgroup file and try your A97 DB.

If that works, then that's the answer: A2010 is using a different registry key to store the default workgroup and you'll need to use the /wrkgrp switch with your older DB's and 2010 no matter what unless you can live with 2010 pointing to this old workgroup file.

 As to why /wrkgrp didn't work for you right off, we'll have to explore as it should have.

Jim.
0
 
tammyborden32Author Commented:
The workgroup file that it listed was C:\Users\<username>\AppData\Roaming\Microsoft\Access\system.mdw.

Oddly enough, I actually copied our system file in that location and it had no affect on Access 97.

I went ahead and joined the workgroup file on our shared network drive.  Then tried to open Access 97.  Once you open Access 2010, you have to reinstall Access 97 to open it.  The error message states Microsoft Access was unable to initialize the Windows registry.  Rerun Access or Office setup.... Doing so changes the workgroup file back to the default.
0
 
Jim Dettman (Microsoft MVP/ EE MVE)PresidentCommented:
<<I went ahead and joined the workgroup file on our shared network drive.  Then tried to open Access 97.  Once you open Access 2010, you have to reinstall Access 97 to open it.  The error message states Microsoft Access was unable to initialize the Windows registry.  Rerun Access or Office setup.... Doing so changes the workgroup file back to the default. >>

 Starting with A2007, ULS Security was stripped out of the product.   Really it wasn't.  What they did is removed all the ACL's in a DB (Access Control Lists) on objects, which leaves things set as default, and then ensured that a default workgroup is used.  So JET security is "on" just as it always has been, which is why 2010 really wants to make sure you use a default workgroup file.  

 That's why the workgroup admin is now buried in the product and why you need to use /wrkgrp on the command line.

 Now why doesn't that work?  Let's try this:

1. Create a new directory on the C drive called 'A97Workgroup"
2. Copy your A97 workgroup file off the network to that folder.
3. Rename it to something else, like LOCAL_<originalname>.MDW
4. Locate the path to MSACCESS.EXE for 2010 on the PC.
5. Create a shortcut on the desktop with a target of:

"C:\<path to MSACCESS.EXE>\MSACCESS.EXE" "C:\<path to database folder>\<database file name>" /wrkgrp="C:\A97Workgroup\LOCAL_<originalname>.MDW"

 replacing everything in the < > (and including them) with the appropriate values.

6. Execute the shortcut holding down the shift key.  Do you get the login or no?

Now check the workgroup file used:

7.  Key Alt/F11
8.  Key Ctrl/G and type:

? syscmd(acSysCmdGetWorkgroupFile)

 it should be

"C:\A97Workgroup\LOCAL_<originalname>.MDW"

Jim.
0
 
tammyborden32Author Commented:
Thanks for hanging in there with me.

I was able to join the workgroup on my test machine using both the workgroup admin utility in conjunction with the shortcut with the full target as you suggested.

On the original computer with the problem, I was able to completely uninstall all Access programs and do a clean install under the Administrator account.  After that I was able to join with only the workgroup admin utility.  No shortcut with the full target was required for either the Administrator or user.

As always, this is the #1 site forum for IT support!!!!
0

Featured Post

Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

  • 12
  • 10
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now