• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1520
  • Last Modified:

Telerik loading image not spinning

I'm trying to implement the loading panel example here:  http://demos.telerik.com/aspnet-ajax/ajax/examples/loadingpanel/loadingimages/defaultcs.aspx on one of my pages.  When i click the button it shows the loader image fine, but it's not spinning.  I'm not doing anything fancy, just following the example on their site.  Any reasons what could cause it not to spin?
0
NOVBusApps
Asked:
NOVBusApps
  • 2
  • 2
1 Solution
 
GaryCommented:
Where's your code, what browser, no reason an animated gif shouldn't work unless you have disabled animation in the browser.
0
 
NOVBusAppsAuthor Commented:
Using IE 8


<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="WebForm1.aspx.cs" Inherits="ManuDoc.WebForm1" %>

<%@ Register TagPrefix="telerik" Namespace="Telerik.Web.UI" Assembly="Telerik.Web.UI" %>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title></title>
    <style type="text/css">
        .module1
        {
            background-color: #dff3ff;
            border: 1px solid #c6e1f2;
        }
    </style>
</head>
<body>
    <form id="form1" runat="server" method="post">
    <div>
        <telerik:RadScriptManager ID="ScriptManager1" runat="server" />
        <telerik:RadAjaxManager ID="RadAjaxManager1" runat="server">
            <AjaxSettings>
                <telerik:AjaxSetting AjaxControlID="Panel1">
                    <UpdatedControls>
                        <telerik:AjaxUpdatedControl ControlID="Panel1" LoadingPanelID="RadAjaxLoadingPanel1" />
                    </UpdatedControls>
                </telerik:AjaxSetting>
            </AjaxSettings>
        </telerik:RadAjaxManager>
        <fieldset class="module1">
            <asp:Panel ID="Panel1" runat="server" HorizontalAlign="Center" Height="275px">
                <asp:Button ID="Button1" runat="server" Text="Button" OnClick="Button1_Click" />
            </asp:Panel>
        </fieldset>
        <telerik:RadAjaxLoadingPanel ID="RadAjaxLoadingPanel1" runat="server"
            Skin="Default">
        </telerik:RadAjaxLoadingPanel>
    </div>
    </form>
</body>
</html>


Code Behind:

using System;
using System.Collections.Generic;
using System.Linq;
using System.Web;
using System.Web.UI;
using System.Web.UI.WebControls;

namespace ManuDoc
{
    public partial class WebForm1 : System.Web.UI.Page
    {
        protected void Page_Load(object sender, EventArgs e)
        {

        }

        protected void Button1_Click(object sender, EventArgs e)
        {
            //simulate longer page load
            System.Threading.Thread.Sleep(2000);
        }
    }
}
0
 
NOVBusAppsAuthor Commented:
Ok nevermind, forgot to enable "Play Animations" under Multimedia section in Internet Options.

Thanks
0
 
GaryCommented:
It it's resolved you can accept an answer
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now