• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 743
  • Last Modified:

One Server with Multiple IP Addresses

I have an internal only Windows 2008 R2 server and a DHCP system with 2 IP address scopes.  How do I configure the server to allow our users on either DHCP scope to access the server from one address or name (example: http://myserver)
0
Matthew Yagi
Asked:
Matthew Yagi
  • 7
  • 3
  • 2
  • +3
2 Solutions
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
The NBIOS "Computer Name" would always remain the same just DHCP IP would be changing only.

So one can always browse by \\ServerName or you can ping the server and get the current IP ...... Ideally always the Server IP should be Static and not on DHCP ever.

- Rancy
0
 
Steve KnightIT ConsultancyCommented:
So do you have two cards in the server and two subnets, or two ip on one card?  Or has server got one ip and you have two vlans from a switch?

If the server has two ip addresses then the clients will resolve the name of the server using its dns server and get the relevant ip first.
0
 
Steve KnightIT ConsultancyCommented:
Anyway explain what you have now please.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell┬« is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
Davis McCarnOwnerCommented:
As long as the routers in your organization will forward the traffic, you can use the NETSH command to add multiple ip addresses to one NIC: http://technet.microsoft.com/en-us/library/cc731521(v=ws.10).aspx
0
 
QlemoBatchelor, Developer and EE Topic AdvisorCommented:
There are many ways to accomplish this. For example you can assign that server two IP addresses - one out of each DHCP network scope. Or you can expand the network mask to span both scopes, for example if you have 192.168.128.0 and 192.168.129.0, use /23 (255.255.254.0) as netmask instead of /24 (255.255.255.0).
0
 
Matthew YagiNetwork AdministratorAuthor Commented:
Thank you for your rapid responses and my apologies for the lack of detailed information.  I am the network manager for a small private elementary school.  The long winded description below details what we have and what is happening.

The server in question is Windows 2008 r2 Standard.  It houses our in house library cataloging and circulation server and the interface to it is via web browser.  The clients that will be contacting it are Windows 7 and Mac OS X laptops.  

Our network is a simple mostly peer to peer setup with a Windows 2008 r2 Standard server as the DHCP server (a different machine from the library server).  We connect to the Internet through a Netgear FVS318v3 firewall/router. DNS for Internet purposes is passed through the router from our ISP.  Internal contact to servers has been via the server's IP address.

The issue that brings me to this post is that we have now have more IP addresses than our original 192.168.0.xxx could provide.  I setup an additional scope - 192.168.1.xxx in the DHCP server and grouped them together under a superscope with an additional Netgear FVS318v3 as the gateway for the new scope.  I have assigned a static IP address from each scope to the library server so it has one NIC that holds two IP addresses.  I can reach the server if I use the IP address that matches with the IP address scope of the client but using the hostname fails. I realise that this setup may not be the best configuration but at the time immediate Internet access was the most critical issue.

As I mentioned we are an elementary school and both the teachers and the students access this server so the solution needs to be kid friendly.  We are just beginning a new expansion of our IT services to incorporate iPads and the like in the classrooms so completely rearranging the current setup is not out of the question.

Again my apologies for the prior lack of details and for being so long winded in this one.
0
 
Steve KnightIT ConsultancyCommented:
Your bdst bet would be for starters get rid of the extra router and change evrything to use a larger subnet mask, or get proper router.

Run dns on your internal server and point clients to that through dhcp options for their dns and then they will be able to resolve.

Are you really running more than 250adequate clients without a domain??

Out on mobile at moment, will consider more later.
0
 
Jamie McKillopIT ManagerCommented:
Hello,

The easiest solution to your problem would be to change your subnet mask to 255.255.0.0 so that you have a class B subnet (65,000+ hosts). In this case you wouldn't need the addition Netgear. Besides changing your DHCP scope and manully changing the mask on anything with a static IP, you wouldn't need to make any additional changes.

The networking equipment you have is designed for a home network and can't really handle a setup with multiple internal subnets.

JJ
0
 
Steve KnightIT ConsultancyCommented:
Yes that is what I meant.  Though like I said if you are running over 250 devices on one subnet would suggest s rethink is in order anyway.

If you want to do iPads etc. then you are going to want decent wireless, presumably from multiple access points to cover different areas.

So best probably to get someone local in to survey what you have and suggest what needs to go where -- I imagine you would want to seregate who can get to what, limit internet access etc.?

For starters a core switch that can support multiple VLAN's would mean you could allocate ports to different VLAN's, e.g. one to connect to wireless access points for your iPads etc., one for student machines, one for staff etc?  

This is all a LOT simpler than it might sound.  Once you have such a network in place with x subnets you configure the switch to send the DHCP requests to your DHCP server and it gives out IP from the correct subnet.

Superscopes are not needed most of the time and confuse the issue IMO.

For simple, quick fix:

Change subnet mask to 255.255.0.0 or 255.255.252.0 on the servers, routers, printers, any other fixed IP devices.  Actually doesn't matter on any fixed IP devices that only need to talk to the router or server rather than clients, they can be changed as you come to them.

Change your DHCP server to give out any ranges that fit with the subnet mask.  For 255.255.0.0 that is 192.168.0.x to 192.168.254.x

But much better if things are going through change is plan a better network going forward.

Steve
0
 
Matthew YagiNetwork AdministratorAuthor Commented:
I think I may be configuring something wrong.

I set the start address to 192.168.0.1 and the end address to 192.168.1.254 and added exceptions for the addresses that are assigned as static to our servers.  The subnet mask is 255.255.0.0 and the router address is 192.168.0.1 with DNS servers set according to our ISP.

However only the computers that have 192.168.0.xxx are able to get to the Internet.

We are in the beginning phase of a major overhaul of the entire network so my primary goal with this post is to keep what we have running for now - just a band-aid solution.  If the solution is something that we can use permanently and work into the new system that would be a plus.
0
 
Steve KnightIT ConsultancyCommented:
Ok it sounds like the computers or router dont have subnet mask set then.  If they have 255.255.255.0 set you would get this.

From host on 192.168.1.x range please check ipconfig.

Can you ping router for starters?

If so can you resolve names, I.e. ping www.google.com
0
 
Steve KnightIT ConsultancyCommented:
I presume here you have removed the extra router etc. And just connected new hosts to same switches as before.

Sorry above of course meant haven't got the CHANGED subnet mask
0
 
Jamie McKillopIT ManagerCommented:
Also, make sure you change the mask on the router itself.

JJ
0
 
Davis McCarnOwnerCommented:
Lets simplify this:
1) Lose the second router so only the internet gateway is on the network.
2) Set your DHCP scope to 192.168.0.1 thru 192.168.3.255 (That's up to 765 devices)
3) Go everywhere and set the subnet mask to 255.255.252.0.  You need to set it on the DHCP server, in any ip based printers or static ips, AND in the Netgear router.

And your done.  The problem of only 192.168.0.xxx having internet is because you haven't changed the subnet in the router.
0
 
Matthew YagiNetwork AdministratorAuthor Commented:
Thank you to everyone for your comments.  It turns out that I did forget to change the subnet mask on the router.  I took care of that and did the same to our servers and ip based devices and thing are working great.  Thanks again for your time.
0
 
Steve KnightIT ConsultancyCommented:
Good, easy mistake to make.  With this many hosts and school network do get someone who knows about networks in to help otherwise you are going to end up leaving the kids wide open to do what they like on the internet aside from anything else.

Steve
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

  • 7
  • 3
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now