Problem installing VMWare ESXi 4.1 on Sun Fire x4450 sever

Posted on 2012-09-08
Last Modified: 2012-09-08
Hey Everyone

I hope someone out there can point me in the right direction.  A Sun Fire x4450 server was donated to my children's school for a project that we are working on to virtualize and upgrade our infrastructure.  The plan is very straight forward, install vmware 4.1esxi on the server and then setup 1 or 2 file/print/AD servers for redundancy.  With every other install of VMWare ESXi 4.1 I've done on Dell and other i386 platform systems, the install only takes about 10 minutes and is simple as can be.  However, on this Sun Fire x4450 box, the install hangs and sometimes even throws a pink screen of detach with the error: "Could not populate the filesystem:  Boot image is corrupt".  I know that the install image is fine because I've tested it on a different box.  The LSI raid controller on the system is SAS1068 with an MPT Firmware version of - IR.  I've tried varying configurations and also confirmed that the Virtual Technology setting in the system Bios is enabled.

Any thoughts on this would be greatly appreciated as I'd hate to not be able to use this donated system.

Thanks in advance,
Question by:RBrogen
    LVL 55

    Expert Comment

    Hate to sound stupid but how can some VMs running under VMware on a single host be redundant? As I see it the chance of failure is about the same as a single host running the native OS except that there's the additional slight possibility of the hypervisor failing.

    Author Comment

    andyalder:  it's redundant only in a sense of operating system issue not VMWare nor hardware.    The single host is a known single point of failure.  The issue is actually getting the VMWare ESXi 4.1 installed as indicated.
    LVL 116

    Accepted Solution

    We ve had issues in the past getting ESXi 4.1 to install on these Sun Fire x platform, which was related to storage controllers and BIOS, memory arrangements.

    The LSI SAS1068 is a controller that does work with ESXi.

    When these servers were released I seem to remember getting a Bios update from then Sun, and working with Sun on an OEM ESXi 4.1 custom build we created for our clients.

    Have you tried a test USB installation on ESXi 4.1.

    Now my memory is a bit foggy if it was 4.0 or 4.1, because these were originally listed and definately worked for 4.0.

    The VMware HCL has them listed unfortunately, much of the Sun docs have since disappeared since the Oracle purchase!

    What model processors do you have 7xxx series?

    Author Comment

    I had seen some posts on the LSI but having a hard time finding firmware update.  Oracle doesn't let you just download the files.  There are four 2.93GHz E7220 Xeon processors.
    LVL 116

    Expert Comment

    by:Andrew Hancock (VMware vExpert / EE MVE)
    yes, from memory those were the models that caused issues. that model or processor was added later to the HCL.

    try usb install for ESXi, you could always try ESX.

    Author Closing Comment

    Created USB install and system worked!  Thanks

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    How to improve team productivity

    Quip adds documents, spreadsheets, and tasklists to your Slack experience
    - Elevate ideas to Quip docs
    - Share Quip docs in Slack
    - Get notified of changes to your docs
    - Available on iOS/Android/Desktop/Web
    - Online/Offline

    One of the new features of a version 7.0 or later virtual machine, supported in VMware vSphere 4.1, 5.0 or the VMware vSphere Hypervisor ESXi 4.1, ESXi 5.0 often overlooked by VMware Administrators is the ability to add and connect USB devices conne…
    The 6120xp switches seem to have a bug when you create a fiber port channel when you have a UCS fabric interconnects talking to them.  If you follow the Cisco guide for the UCS, the FC Port channel will never come up and it will say that there are n…
    Teach the user how to install ESXi 5.5 and configure the management network System Requirements: ESXi Installation:  Management Network Configuration: Management Network Testing:
    This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…

    779 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    14 Experts available now in Live!

    Get 1:1 Help Now